EOS Utility 3.4.30 Not Installing (Mac)

Started Apr 11, 2016 | Discussions
kyleunwin
kyleunwin New Member • Posts: 24
EOS Utility 3.4.30 Not Installing (Mac)

I'm trying to install EOS Utility 3 for my 6D. I've downloaded the latest file from Canon's support site, my install gets as far as; extracting from .zip > mounting > running installation programme > extracts files itself > opens universal installer for about a second before it crashes and then nothing else happens.

I'm running OSX 10.11 Yosemite, I installed EOS utility 2 fine a few weeks back so it's not as if the version of OSX I'm on is unsupported by Canon. I really could do with the utility installed for some remote shooting.

Has anyone else experienced anything like this? Thanks in advance if you can offer any help!

Kyle

 kyleunwin's gear list:kyleunwin's gear list
Canon EOS 6D Canon EOS 70D Canon EF 50mm F1.8 II Canon EF 85mm F1.8 USM Canon EF 24-105mm f/4L IS USM +2 more
Canon EOS 6D
If you believe there are incorrect tags, please send us this post using our feedback form.
Birdman7
Birdman7 Senior Member • Posts: 1,058
Re: EOS Utility 3.4.30 Not Installing (Mac)

You tried closing all apps and rebooting your machine?  Sometimes that works.

-- hide signature --

Bird Photography workshops
Digiscoping courses
Birdwatching tours
Specialising in Spain & Morocco
www.aviantours.net

 Birdman7's gear list:Birdman7's gear list
Canon EOS-1D Mark IV Canon EOS 5D Mark II Canon EOS 7D Canon EF 50mm F1.8 II Canon EF 85mm F1.2L II USM +7 more
nidua42 New Member • Posts: 7
Re: EOS Utility 3.4.30 Not Installing (Mac)

Same problem here. OS X 10.11.4 and I can't install/update EOS utilities or DPP. Looks like it decompresses the install package, something flashes on the screen and doesn't install. Closing apps and rebooting doesn't help.

John_Hoffman
John_Hoffman Senior Member • Posts: 1,917
Re: EOS Utility 3.4.30 Not Installing (Mac)

Saw this on another forum, FWIW.

Mac ...

Macintosh HD \ library \ Canon_Inc_IC \ uninstall \ UniversalUninstallerApp

select the DPP program and other software to uninstall
then clean up the library under your home folder (profile)

also check your home (profile) library
go to your Home folder and search for "Canon"

delete the folder Home \ library \ Canon_Inc_IC
com.canon.digital-photo-professional-4.batch.sfl
com.canon.digital-photo-professional-4.sfl
com.canon.eos-utility.sfl
com.canon.subinstaller.sfl

empty the trash, reboot, re-install DPP v4, EOS Utility latest versions

if that fails give Canon support a call

-- hide signature --

John Hoffman
Conway, NH

 John_Hoffman's gear list:John_Hoffman's gear list
Canon EOS-1D X Mark III Canon EF 100mm F2.8L Macro IS USM Canon EF 70-200mm F2.8L IS II USM Canon EF 8-15mm f/4L Fisheye USM Canon EF 24mm f/2.8 IS USM +9 more
kyleunwin
OP kyleunwin New Member • Posts: 24
Re: EOS Utility 3.4.30 Not Installing (Mac)

nidua42 wrote:

Same problem here. OS X 10.11.4 and I can't install/update EOS utilities or DPP. Looks like it decompresses the install package, something flashes on the screen and doesn't install. Closing apps and rebooting doesn't help.

Exactly my problem - I've managed to work out the window that pops up for a fraction of a second is called Universal Installer, so it's that stage it breaks at. I emailed Canon and just got a stock troubleshooting by restarting/closing all programmes response. Going to follow it up so they hopefully work on resolving it

 kyleunwin's gear list:kyleunwin's gear list
Canon EOS 6D Canon EOS 70D Canon EF 50mm F1.8 II Canon EF 85mm F1.8 USM Canon EF 24-105mm f/4L IS USM +2 more
Birdman7
Birdman7 Senior Member • Posts: 1,058
El Capitan..

installed on my 2011 17" Macbook Pro running El Capitan without any issues.

-- hide signature --

Bird Photography workshops
Digiscoping courses
Birdwatching tours
Specialising in Spain & Morocco
www.aviantours.net

 Birdman7's gear list:Birdman7's gear list
Canon EOS-1D Mark IV Canon EOS 5D Mark II Canon EOS 7D Canon EF 50mm F1.8 II Canon EF 85mm F1.2L II USM +7 more
kyleunwin
OP kyleunwin New Member • Posts: 24
Re: EOS Utility 3.4.30 Not Installing (Mac)

kyleunwin wrote:

I'm trying to install EOS Utility 3 for my 6D. I've downloaded the latest file from Canon's support site, my install gets as far as; extracting from .zip > mounting > running installation programme > extracts files itself > opens universal installer for about a second before it crashes and then nothing else happens.

I'm running OSX 10.11 Yosemite, I installed EOS utility 2 fine a few weeks back so it's not as if the version of OSX I'm on is unsupported by Canon. I really could do with the utility installed for some remote shooting.

Has anyone else experienced anything like this? Thanks in advance if you can offer any help!

Kyle

Sorry everyone, I meant 10.11 El Capitan, not Yosemite

 kyleunwin's gear list:kyleunwin's gear list
Canon EOS 6D Canon EOS 70D Canon EF 50mm F1.8 II Canon EF 85mm F1.8 USM Canon EF 24-105mm f/4L IS USM +2 more
kyleunwin
OP kyleunwin New Member • Posts: 24
Re: El Capitan..

Is it EOS Utility 3.4.30 you've got installed? it seems to have only come out a month ago - i've tried full uninstallation of all canon products, closing all apps and resetting my mac with little success

 kyleunwin's gear list:kyleunwin's gear list
Canon EOS 6D Canon EOS 70D Canon EF 50mm F1.8 II Canon EF 85mm F1.8 USM Canon EF 24-105mm f/4L IS USM +2 more
Birdman7
Birdman7 Senior Member • Posts: 1,058
Re: El Capitan..

kyleunwin wrote:

Is it EOS Utility 3.4.30 you've got installed? it seems to have only come out a month ago - i've tried full uninstallation of all canon products, closing all apps and resetting my mac with little success

Yep heres the proof...

-- hide signature --

Bird Photography workshops
Digiscoping courses
Birdwatching tours
Specialising in Spain & Morocco
www.aviantours.net

 Birdman7's gear list:Birdman7's gear list
Canon EOS-1D Mark IV Canon EOS 5D Mark II Canon EOS 7D Canon EF 50mm F1.8 II Canon EF 85mm F1.2L II USM +7 more
nidua42 New Member • Posts: 7
Re: EOS Utility 3.4.30 Not Installing (Mac)

I hope they will fix it and in the mean time I'm gonna contact Canon's support as well and see what they have to say about it.

kyleunwin
OP kyleunwin New Member • Posts: 24
Re: EOS Utility 3.4.30 Not Installing (Mac)

I've emailed them 3 times and every time they're just giving rubbish replies running through the basic steps of how to install something, despite me every single time describing my problem.

If you get anything out of them please do let me know!

 kyleunwin's gear list:kyleunwin's gear list
Canon EOS 6D Canon EOS 70D Canon EF 50mm F1.8 II Canon EF 85mm F1.8 USM Canon EF 24-105mm f/4L IS USM +2 more
kyleunwin
OP kyleunwin New Member • Posts: 24
Re: El Capitan..

hmm, i wonder what the problem with mine is then!

 kyleunwin's gear list:kyleunwin's gear list
Canon EOS 6D Canon EOS 70D Canon EF 50mm F1.8 II Canon EF 85mm F1.8 USM Canon EF 24-105mm f/4L IS USM +2 more
nidua42 New Member • Posts: 7
Re: EOS Utility 3.4.30 Not Installing (Mac)

Oh man did I get an answer from Canon Basically they told me to download digital solutions disk (with outdated DPP and EOS Utils) and install that adding that if I have problems downloading to disable any anti-virus and security.

kyleunwin
OP kyleunwin New Member • Posts: 24
Re: EOS Utility 3.4.30 Not Installing (Mac)

So we basically can't have the latest version for no obvious reason? At least they actually acknowledged you weren't just inept at installing things like they seemed to think I was!

 kyleunwin's gear list:kyleunwin's gear list
Canon EOS 6D Canon EOS 70D Canon EF 50mm F1.8 II Canon EF 85mm F1.8 USM Canon EF 24-105mm f/4L IS USM +2 more
nidua42 New Member • Posts: 7
Re: EOS Utility 3.4.30 Not Installing (Mac)

Haha I'm not sure, man. I think they were implying I don't know how to download the app. I'll wait couple of days and contact them again.

brightcolours Forum Pro • Posts: 15,883
Re: El Capitan..

kyleunwin wrote:

hmm, i wonder what the problem with mine is then!

Do you have DPP4 installed? Since you say you used EOS Utility 2 before, I guess you did not? Try installing a version of DPP4 first, maybe not the newest one as someone in this thread seems to have an issue with installing it too?

When I get home I'll see which versions of EOS Utility 3 and DPP4 are on my 10.11 Mac, and after that try to update to the newest versions. This computer has 10.9 still.

Keyboard shortcuts:
FForum MMy threads