Sony SLT-A77

Announced Aug 24, 2011 •
24 megapixels | 3 screen | APS-C sensor
Sony SLT-A77 Ask a question in forums about the Sony SLT-A77.
Ask a new question
685
Questions
asked
126
Questions
answered
Filter questions by
« First‹ Previous12345Next ›Last »
2
replies
Hi all. Please help me decide which lens to buy. I am hesitating between the SONY 70-300mm F/4.5-5.6 G SSM II and the Sigma AF 70-200mm f/2.8 APO EX DG OS HSM. I am working in a wet white water environment making pictures on rafting trips. I think it would be awesome to seea bit further with the 70-300 but on the other hand having f/2.8 can be nice too. I think the Sigma performs better in low light and maybe the focusing is better too. What do you think? I really appreciate a little help...
5
replies
So, I recently upgraded from Sony A77 to A99 and I'm looking over my lenses. Right now I don't have any lense wider than my Minolta 50mm f/1.4, which I absolutely love. I use it all the time, but I want to start shooting more landscape/environment/sunsets and stuff since I've been focusing a lot on portraits, animals and just single subject photos.  I love primes and have no issues with them at all, and I use mostly natural light, often sparse and dim, so the price/performance is a big thing...
10
replies
I have been using a Sony A77 plus Sony SAL 16-50mm and Minolta 100-300mm APO D. These I have been very happy with. However, it is clear that things are moving on and mirrorless is proably the future of changeable lens cameras. Also I am keen to reduce the weight of what I have to carry around. The trade off being not so good ergonomics. I have bought a Sony A6300 with the standard kit lens just to try it out with the aim of adding firstly the Sony SEL 70300G and if I am happy then the Sony...
7
replies
Hi guys, I have just got an A77 from Yahoo, worked whole day until just now... I was testing/taking picture of a new recipe of some food I was making, one shot took extra long to process, as I thought it might have freezed, I switched off and switched back on.... The viewfinder became all green when it is on Auto focus, Red when its on Manual .... Please please please help me ... What could this be and can it be fixed??? thank you in advance ...
14
replies
I am really confused.  I see focus peaking discussed  in forums for the A77 and A77ii but nothing about it on the Sony website.  I am hoping the A77ii does have focus peaking so I can use older MF lenses with it.  That feature on my A7 is amazing.  So does the A77ii have it or not?  --John Ellis
15
replies
A while back I posted a question about what flash system to buy. I have Sony cameras (Alpha mount, not E-mount), and a nice Minolta 5600HS(D) flash (Minolta's top-of-the-line). I'd like to get my flash off of the camera. My main camera is a Sony A99, but IU also have A77, A55, and A700. My initial use would be experimenting with portrait lighting at home. Later on, I'd like to be able to toss these somewhere at events and shoot as well, and generally, experiment with lighting. People...
MicheleP
By: MicheleP (3 months ago)
10
replies
I wrote about me dropping my A77 in Ireland and cracking the lens housing and the flash on the camera. It is being repaired right now. I need a strong strap that can be held cross body or my back, with easy access when shooting. I know someone posted about this kind of strap, a Peak Design Slide.  My question is, are there any other options I should look at.  I never want to go through this again $$$ and we travel a lot, so I want my camera available at all times, not in a bag. Thanks in...
18
replies
Last time my A77 can wireless the HVL-60M, but now can not work the wireless, please let me know to solve it, thanks
1
reply
I dropped my A77 with the sd card door open and broke it. I have received a replacement door but don't know how to take the front of the camera off to replace. Does anyone have a diagram or video that will help me out. Thanks much
3
replies
I have an old Phottix Odin transmitter attached to an A7r ii with an adapter. On the other end is a Phottix receiver with an HVL F43AM flash (the older one, not the F43M). I can hit the test button on the Odin transmitter and it will fire the flash attached to the receiver. But with the A7Rii set to Fill Flash (I've also tried Wireless), the flash will not trigger. So it seems like the A7R ii isn't really connecting to the Odin transmitter. I bought the adapter to connect to my old A77 (which...
Filter questions by
« First‹ Previous12345Next ›Last »