Sony SLT-A55

Announced Aug 24, 2010 •
16 megapixels | 3 screen | APS-C sensor
Sony SLT-A55 Ask a question in forums about the Sony SLT-A55.
Ask a new question
134
Questions
asked
21
Questions
answered
Filter questions by
« First‹ Previous12345Next ›Last »
19
replies
So I'm looking for an all round lens to take travelling with me next you so I don't have to change my lens all the time. So far I've seen the Sigma 18-300mm, Tamron 16-300mm and the Sony 8-250mm. Does anyone know if there is much difference between these lens and which one would be best? Also I'm open to any other suggestions. Thank you, Jess.
15
replies
A while back I posted a question about what flash system to buy. I have Sony cameras (Alpha mount, not E-mount), and a nice Minolta 5600HS(D) flash (Minolta's top-of-the-line). I'd like to get my flash off of the camera. My main camera is a Sony A99, but IU also have A77, A55, and A700. My initial use would be experimenting with portrait lighting at home. Later on, I'd like to be able to toss these somewhere at events and shoot as well, and generally, experiment with lighting. People...
2
replies
I have a money a55 and just bought the sony a6300.   It is my understanding that the batteries are compatible.  But I wanted to come here and ask you guys to confirm.  (I have emailed sony too). They seem to be the same battery for all that I can see, but sometimes there are small nuances that I don't want to mess anything up.
By: Tlon (3 months ago)
Posted to: Open Talk
2
replies
Hello, I'm going to buy a Sony A6300 soon. Since this is a complex camera (much more complex than the A55 I'm currently using), I think it's worthwhile to invest a few dollars in an external guide book for the camera (unfortunately Thom Hogan only produces books for Nikon cameras.). Can anyone recommend such a book? Thanks! gallery at https://www.flickr.com/photos/7205719@N05
3
replies
Answered
When I run the sensor cleanining mode on my a55, I feel a vibration, but when I do it with my a6000, there is no vibration. Is there something wrong with cleaning mode on the a6000? Rick
7
replies
Hello, I currently use the A55 with the 18-250mm, 10-20mm and 30mm f/1.4 lenses. The A55 has served me well for five years, but it's starting to show its age (loses connectivity with lenses, occasionally produces wildly over- or under-exposed images, etc). In addition, the Sigma 30mm f/1.4 always back focused on it, so I've used manual focus (thank god for the EVF), and now the other two lenses also focus less reliably. The obvious solution would be to replace my system with the A6300,...
36
replies
So here I go again.... I currently have an SLTA55 - with a Tamron 18 - 270 lens. Love it, but time for a new one as the SLTA55 has had some recent problems. I even sent it away to see if it could be fixed. Today spent some time at a camera store, just looking at different cameras. Looking at wanting to spend around $2500 max (but of course can be talked into more if needed). A little about me: - majority of time I am shooting landscape/vacation pictures - could be europe - could be...
2
replies
so with the a6300 now having min shutter speed with auto iso as a feature I'm hoping this camera will have it too. I have a much older a55 and looking to swap out the body for this a68, although I'm tempted to altogether switch over to a6300 or if they release the a5xxx equivalent. One no website preorder says shipping mid-may so we could also just wait and see
7
replies
Hi friends, Just bought a Sigma 18-200mm F3.5-6.3 II DC HSM lens and used in Sony A65, it work properly and used it in Sony A55, Auto focus not working, Aperture working, everything fine but not AF not working, I felt so strange dyxum.com say compatible with SLT, also working in A65 why not in A55? am i missing something or that lens not support it? Any solution? Any real experiences? Need help. --RegardsAfzal KhanKathmandu, Nepal
1
reply
A favorite feature of mine with the SLTs is the auto-focus during video.  It is restricted to F/3.5, but works better than any other Sony camera I've tried (haven't got my hands on A7Rii yet though). Has anyone use the LA-EA4 with the A7s while taking video?   Should I expect the same?  I know it won't match my A77ii, but the specs say it is the same as my old A55.   And while I am asking, does focus confirmation still work when using other apertures like F/1.4? Thanks in advance.
Filter questions by
« First‹ Previous12345Next ›Last »