Sony Cyber-shot DSC-WX350

Announced Feb 13, 2014 •
18 megapixels | 3 screen | 25 – 500 mm (20×)
Sony Cyber-shot DSC-WX350 Ask a question in forums about the Sony Cyber-shot DSC-WX350.
Ask a new question
16
Questions
asked
2
Questions
answered
Filter questions by
« First‹ Previous12Next ›Last »
2
replies
I have the Sony DSC WX350 and I take pictures mainly of horses at our barn.  What is the best setting for this?  I've tried all the settings and there seems to be a "freeze" of about 3 seconds after each shot.  Is this normal?  This makes it impossible to take pictures of a horse that is moving. I called Best Buy and the guy said all cheap cameras do that because they can't process the shot as well as an expensive camera.  I know he was just being a jerk but I really need some help.  Thank...
23
replies
I own   a Sony Cybershot, I have the HX9V, 20v, wx350 and now the HX90V As if I came across a review that lead me to the ZS60...   I would love to know how well this will stand up against the Sony?  Knowing  the lcd screen does not fold, which I love that feature.  I know I have to give up to get more etc...   Love to hear some thoughts?
4
replies
if I take a snap shot and  continue on  the desc001number system continues the count, and does not reset?   If I take  video, this resets back to C001.  If I delete the  all images.  only thing that correctly counts is the images? On my older models  the actual video numbering is not C001, its the  date with a number?   Am I missing something?     My cam has been  reset, fully, and matches the WX350. love to hear your thoughts,   A fix will be is to make sure existing files are highlighted...
By: Mateo64 (Sep 13, 2015)
0
replies
My WX350 has decided to shift the image randomly (and audibly) up and down when zoomed.  Click, click, click from say 0.1 to 3 seconds.  At maximum zoom the shift is most of the frame.  I can still take pictures but it is almost impossible to get what you want in the frame.  Unbelievably frustrating to use.  I tried removing/replacing the battery, updating the firmware, and colorful language to no avail.  Wondering if anyone else has run into this problem and might have a solution?  Thanks.
6
replies
Hi guys I am going on a gap year next year and want to cover all types of photography conditions from Iceland to Antarctica. My original plan was to get Sony Rx100III for everyday situation and I have seen some amazing northern lights taken with Rx100m3. However I also need a super zoom camera for shooting wild life such as penguins when I am in Antarctica. If I were to purchase RX100M3, I would pair up with WX350 since all I need is the zoom. However if I only go with HX90V, it seems ideal,...
4
replies
Answered
Are picture effect & White balance available in video mode? Br. Karsten (Copenhagen, Denmark)
11
replies
Answered
I'm taking a pretty major trip to the UK this fall and am looking to purchase a new camera to go along for the ride. For the last six years I've been using a Sony W230 that I love but it's never done a good job in low light or indoors without flash and I'm tired of washed out photos. I originally set out with a budget of no more than $300. After two days of reading reviews and specs I feel like I'm going in circles. I just want something that takes good photos and will shoot in...
1
reply
spec says this camera has 25mm wide lens. but when you taking HD movie will be the same 25mm wide? or ? any suggestion for a  sony pocket camera has very wide angle with hight quality hd movie record ? thank you
6
replies
all right, I started another thread which was mystically deleted for some odd reason. :-x So I'll start another... I purchased a wx350 after seeing decent video on youtube and seeing people here liking it. I've got an HX20V, which I'm comparing it to. I returned the first wx350, thinking it was a fluke...the second one doesn't seem much (if any) better. I took pics/video in low light, and hit about 50/50 good/bad. They were just interior pics in a house with normal lighting. (I can't post...
0
replies
Also, I was using the "soft skin" and "anti motion" scenes and both take about 5 seconds for each picture to "process" to the card. That's a pretty long time to go without be able to shoot a second shot. When I take some shots the camera also makes some type of internal noise that almost sounds like the camera is taking about 4 shots for each pic but there is always just one. Thank you for helping me! Patti
Filter questions by
« First‹ Previous12Next ›Last »