Canon EOS 5D Mark II

Announced Sep 17, 2008 •
21 megapixels | 3 screen | Full frame sensor
Canon EOS 5D Mark II Ask a question in forums about the Canon EOS 5D Mark II.
Ask a new question
377
Questions
asked
52
Questions
answered
Filter questions by
« First‹ Previous12345Next ›Last »
7
replies
Hello everyone, I'm an amateur photographer. I recently bought a used Canon EOS 5D Mark II Body. I'm having a little issue with the camera during Live View ( AF OPTIONS—STILL ). During AF Live Mode and Face Detect Live Mode, the movable white rectangle focus frame does not light up to green when the area within the frame is in focus. I am still able to take the picture thought and it still looks fairly sharp. Is there a way to fix this? Does the focus frame really have to turn green to...
1
reply
I am using 5D2 for almost 4 years with shutter count of 13190. A week ago I got Error 30. (error code 30: "Turn the power switch to <OFF> and <ON> again or re-install the battery"). I surfed the internet and followed the following instructions: 1st: Remove batteries(both, main and clock battery) and card for quite a time. 2nd Update the firmware: I was already on the latest firmware. However, I updated it again. Issue was solved right away. I took quite a few pictures. single shoots, long...
4
replies
Answered
Is it ok to use the new, LP-6N batteries with the 5d2 cameras?  Any issues with that? Thanks
0
replies
So I'm having an issue with getting the battery for the 5D Mark ii I'm renting (and regularly rent, as it comes from my workplace). It just won't charge. Now to be clear; yes, this is by now an old camera, so there is some obvious wear and tear in general. But up until recently, there weren't any issues with the battery itself. What happens is that I plug it into a charger and the yellow light does not flash or anything. Instead, the signal on the charger just shows green from the get-go. I...
5
replies
After reading quite a bit about the 5d mark iv, the biggest issue about the video is the compression ratio and subsequent large need for memory card space.  Can anyone tell me how important that is really?  Lake of zebra as well.  I am wanting to upgrade from my 5d Mark II.  It seems as though people are making a very big deal of out those "missing components" from video capabilities. Thanks --Dejavuredundancy
20
replies
Hi all, Having bought a Canon 5D MkII almost 8 years ago, I have used it for travel, volunteer jobs, and art, making prints of up to 40x60 in. I specifically bought this camera + 24-70mm f/2.8 MkI for its low-light capabilities. While the 5D has great image quality for stills, taking candid shots leads to dirty looks due to the loud shutter (even in silent mode). It also gets a little heavy around the shoulder, walking around the city, which is why I am reluctant to travel with more lenses...
12
replies
Hi Guys, im having a weird problem with my Canon 5dii, hope someone can suss it out. The issues im having is: 1. When Auto Focus is on I cannot take a picture, press down fully nothing happens. 2. The other issue is even in Daylight I have to crank up the ISO to 4000-5000 to get a decently exposed image. 3. Also the aperture meter is off, I have to expose it at 1-2 stops down to get it exposed correctly. All these problems happened suddenly at the same time. The only triggers I can think of...
45
replies
Answered
HELP!!My new canon eos 5d mark ii is showing these awful grainy and magenta pictures in raw, they cant be corrected. This picture was taken in low light at f4 200mm 1/1000s iso 100, with noise reduction off. Is my sensor on the way out or is it the memory card. The pictures i took in the day were fine.
9
replies
So I bought a 400W portable strobe that has a separate trigger. It supports hss and ttl. Problem is that on my canon 5d mark ii whatever shutter speed I do 1/8000 etc I always get the photo on 1/200. On my canon 6d I get the correct shutter speed but seems hss still not working even though it is set on both the strobe and trigger. Can it be cause am using ttl instead of full power manual ?
16
replies
Hi all About 2 weeks ago my 5d mkr 2 which ive had for 8 years just wouldnt turn on and there was just a blue flashing light (faint) in the live view screen. After a day of trying everthing it started working again but was talking awhile to turn on. I replaced the internal battery just to see if it was the issue. Today the camera did the same thing and after 3 hours of leaveing it , it eventually turned on but with some issues. These are after turning on the blue light flashes for about 30-...
Filter questions by
« First‹ Previous12345Next ›Last »