Sony SLT-A77

Announced Aug 24, 2011 •
24 megapixels | 3 screen | APS-C sensor
Sony SLT-A77 Ask a question in forums about the Sony SLT-A77.
Ask a new question
713
Questions
asked
127
Questions
answered
Filter questions by
« First‹ Previous12345Next ›Last »
5
replies
Hi all, Glad to finally register here after reading so many google hits from this community. I started photography with an A57 and a bunch of the top minolta picks for price and performance. 70-210, 50, 28, 28-105 etc. I know nothing else about any other type of cameras or lenses. My A57 is in a wheelchair and almost dead so I moved up to the A77ii which made great sense due to the lens compatibility. Now my A77ii is making funny noises when shooting bracketed 2.0EV3 I have actually managed...
10
replies
hey guys, first time poster but long time reader. i have a a77II, i upgraded from the a77 which i loved. great all rounder. Now we have just started a apart time photography business shooting maternity, babies, kiddies etc, i shoot night and day landscapes and surf/ocean, and sunrise/sunset stuff. now our shots inside and in afternoon light or shade are really noisey and soft. i use manual but misses is still learning so live view is super handy and we love it. is this happening to anyone...
14
replies
I need Sony a57 remote port but I can't find anywhere. Some A Mount camera's remote port looks like A57's port. Can I use other port for A57 for changing?I mean port about photo in linkhttp://www.imaging-resource.com/PRODS/AA77/ZURPORTS-S.JPG
12
replies
Out shooting today and all info on the rear screen started shifting back and forth pretty fast. Took battery out for a couple of minutes and removed the lens and remounted it but still has the jitters. Look thru the view finder and that is fine. Can someone please help me with this. Thanks.
19
replies
I just bought a used A77 with a year's warranty. The camera is in excellent working order. Body in great condition, only concern was slight delamination to the screen. I was delighted with the deal I got and the camera's performance. Imagine my surprise when I checked the shutter count and the number of actuations is 140302! I read somewhere these shutters are reasonably reliable up to 150,000 actuations, so I'm unsure whether to return the camera while in the return window. So my question to...
17
replies
Hi looking for advice. Does anyone have experience to compare an A77mk1 and an LAEA4 + A6000? Does the A77 have any major advantages / disadvantages, for example over the LEA4 focusing or in IQ and the A6000 sensor? I would be using it primarily with a Sigma 120-400 APO OS, for birding. Thanks! TL;DR The LEA4 is not much cheaper than a used A77 at the moment. I've owned an LEA4 but wasn't overly impressed. Nearly sold the Sigma too but I love it. I'll be keeping my nex cameras, this would be...
12
replies
I've had a used a77 for just over a year now.  This January I used it to take some pictures and it froze up after releasing the shutter.  The lcd screen displayed "err".  The next time I went to use it, it was perfectly normal.  I kept getting the same "err" on and off when using it after that with it eventually getting worse.  Turning the camera off and taking the battery out and replacing it sometimes cleared the issue.   Now when I turn I turn the camera on, I get a green screen with...
5
replies
I have a konica Minolta 17-35 2.8-4 that I im not satisfied with... That lens is not sharp at 35mm and f4 it has soft corners both at 35mm and at 17mm (at least here in the middle its very sharp and usable at f4.5) and it looses too much light (at 35mm the difference between f4 and f4.5 its almost zero and only f5 really ends the vignetting).Things start to sharpen until at f7.1 becomes acceptable in the corners and center and only at f11 is sharp all over. It has noticeable distortion too...
6
replies
Is Sony planning to launch the Sony a77 III anytime soon in 2017 for the a-mount users, now that the entire camera industry's attention is on the new Beast Sony a9. Cheers
1
reply
I have a A77, it's been working fine and now no matter what SD card I put in it the shutter won't work. It work fine if there's no card in the camera. I have tried different cards, batteries, lenses with no luck. All these work on my Sony A77II so it's got to be the camera. Any thoughts/ideas? Thanks for any and all help
Filter questions by
« First‹ Previous12345Next ›Last »