Olympus E-510 (EVOLT E-510)

Announced Mar 5, 2007 •
10 megapixels | 2.5 screen | Four Thirds sensor
Olympus E-510 (EVOLT E-510) Ask a question in forums about the Olympus E-510 (EVOLT E-510).
Ask a new question
13
Questions
asked
1
Questions
answered
Filter questions by
« First‹ Previous12Next ›Last »
By: CZ1000 (1 month ago)
Posted to: Olympus SLR Talk
1
reply
All of a sudden I'm getting Card Errors. Initially card loads and I can review photos, but when I turn it on again I get a Card Error. When I try to format, activity light blinks for about 10 seconds and then I get the Card Error message.  This happens with two different CF cards. Lexar Pro 2GB 1333x and Sandisk Ultra 8gb. All pins appear  to be straight and there is no additional residence when trying to insert the card. Any insight is appreciated.
109
replies
I damaged this camera.  It was so dependable, but I cannot decide how to replace it with a retired slim budget.  I wonder about the new M-10 .. But there was something so solid and dependable about the E-510 . Now, my pictures are grandchildren and pets with flowers here and there -- both fast moving objects with continual reliable focusing and a lot of indoor shooting. .. I have no one to advise me now, so I am just "stuck" in reading reviews and forums.  Someone please give me ideas. I...
5
replies
I switched to Nikon a couple years ago but had a hard time letting go of my beloved Olympus gear.  My husband is bugging about it though so it's time.  Where's the best place for me to sell it these days?  Just craigslist or ebay or are there any Olympus groups online that have selling forums? E-1, E-510, E-30 50mmF2, sigma 17-50mmf2.8, and more..... ------Cathyhttp://www.cathykurtzphotography.com
2
replies
Hi. Just wondering if anybody has managed the above repair without sending to Olympus. I have 2 e510s both with the same problem & would like to sell or pass them on as I'm getting the e-m1. To clarify the cameras work fine but flash, viewfinder display, red dot & focus beep have all died, a fairly common fault I believe. Cheers Mick.
2
replies
Hi!Today I got my new camera, a Canon PowerShot SX240 HS. I actually was thinking about buying the SX260 HS but I don't need GPS.I took some pictures with my old Olympus E-510 DSLR and the same picture with the Canon SX240 HS. I put both on Auto. Olympus E-510Canon SX240 HS and again ...Olympus E-510Canon SX240 HSThe pictures from the Canon SX240 HS are looking brighter but overall it doesn't look good at all.Any idea how this is? I actually hoping for at least a similar picture quality or...
By: trevor4455 (Feb 7, 2013)
Posted to: Olympus SLR Talk
29
replies
Up to this point have been shooting jpeg but I have been thinking about shooting raw.  Does anyone know of any resources where I could learn more about raw and photo-editing?  I have the cd that came with my evolt 510.  Is that worth using?
6
replies
I recently got some really good deals (I think anyway) on a few zuiko lenses to add to my newly acquired photog hobby.  The new (but used) lenses are the 14-54mk1, 18-180, 50 macro, 70-300.  Love the 70-300 and 14-54. I haven't received the 18-180 or 50 macro, which receives much acclaim and subsequently has me eagerly awaiting its arrival, because they are in transit.My question is this:  Should I sell the two kit lenses or keep one or the other.  I like them both but to offset the price of...
By: trevor4455 (Feb 7, 2013)
Posted to: Olympus SLR Talk
4
replies
As I am relatively new to the forum, can I post lenses I would like to sell here?
By: trevor4455 (Feb 5, 2013)
Posted to: Olympus SLR Talk
8
replies
Answered
Does anyone have any advice about how to remove a polarizing filter from a lens without destroying the lens or the filter?
By: trevor4455 (Jan 29, 2013)
Posted to: Olympus SLR Talk
19
replies
Does anyone know the difference between the zuiko 14-54 I and 14-54 II?  I have an opportunity to buy the first model, used, for 175 and I am curious if that is a good deal.Thanks
Filter questions by
« First‹ Previous12Next ›Last »