PIngp0NGMW

Lives in Canada Canada
Works as a Post-doctoral Fellow
Joined on Oct 7, 2007
About me:

Be excellent to one another. Party on.

PIngp0NGMW's recent activity

  • Good to know!  I recently cracked my K-S2 open when it had the aperture problem.  I am going to remember this post if it dies on me again in the future.  It would be great to fix the problem ...
  • 100% agree with this assessment.  My own observations completely jive with this anecdote.  Everyone I know takes pics and videos with their phones.  Phones are ubiquitous and actually take pretty ...
  • Hi Peter, absolutely fair point.  I am not an electrical or any other kind of engineer.  I confess that I have 100% no idea how this works or why it works.  I just decided to implement a process ...
  • HI there, I recently had the aperture block failure issue on my K-S2. I took the plunge and fixed it myself, as described here: https://www.dpreview.com/forums/thread/4221622 My camera works fine ...
  • The issue appeared to be with needing to rough up the metal a bit.  It looked clean and pristine to me when I removed it.  I just used a bit of fine sandpaper on it and a file and roughed it up ...
  • Thanks TomW! I just figured that if I did kill the camera, well, it was basically unusable anyway. But so many people reported with success that the fix worked that I decided I just had to try for ...
  • Created discussion thread K-S2 Aperture block failure repaired
    Hello everyone, a few months ago I reported that I was experiencing the black images problem on my K-S2. I came to realize that this was the dreaded aperture block failure problem. My camera was ...
  • Added 4 photos to their gallery
    DSC04649DSC04648DSC04647DSC04646
  • Thanks everyone for the feedback.  I will give the rubbing alcohol (99% or greater concentration) trick another go and see if it helps! I actually like the K-01 quite a lot so am determined to get ...
  • Yeah, I'm hoping it was just software as it never happened before and then only happened after the firmware update.  I read about the K30/50 aperture control motor problem and I'm really hoping ...
  • Unfortunately not.  My K-01 is still broken (the rubbing alcohol thing didn't work).  I have decided to poke around it as it's long out of warranty and I don't use it as my primary.  I saw a few ...
  • Hi folks, I recently upgraded my K-S2 firmware to 1.2 in order to use the new 55-300 PLM lens.  However, I have noticed a strange problem now that occurs with my 18-50 DC lens.  The first few ...
  • I just came back from an Alaskan cruise where I used my KS-2 and 55-300 PLM almost exclusively.  The lens was fantastic and a massive improvement from my DA 55-300 circa-2008 copy.  The autofocus ...
  • Hello folks, I have a K-01 from a few years ago that I used recently without issue and was looking forward to using again.  I powered it on today with the 18-55 DA WR (KS-2 kit lens) and noticed ...
Activity older than 12 months is not displayed.
Total messages 289
Threads started 33
Last post 2 months ago
Total comments 4
Total likes 4
Last post Feb 11, 2015
Total reviews 0
Entries 0
Votes cast 0
Photos uploaded 81
Last upload 2 months ago