santaklaus

santaklaus

Joined on Aug 4, 2017

santaklaus' recent activity

  • received the chip 2 days ago! Apparently it had to go to from Beijing to Sweden first, before coming to Bangkok. I will try my hand on assembly this week. (It's a bit daunting...)
  • appreciate the heads-up, and glad your lens is working again
  • I am starting to lose faith in James Lao. It's now over 10 days since I ordered and paid for the rechip, and there has been no confirmation, or acknowledgment from him, and no answer to my emails ...
  • re: email to JL I ordered the replacement chip 8 days ago and paid with PayPal. To date I have not received any acknowledgment or confirmation of my order/receipt of payment from JL. So I emailed ...
  • Appreciate your heads-up on this. From your pix I can see that my lens is the same as yours... I have already placed the order with JL, so when the chip arrives I will know more. Sigh...
  • Thank you Neil! This was very detailed of you and helped me ordering the correct part from James. Highly appreciated and hope it will work..., and yes, my lens is the first one in your post. thanks ...
  • Thanks lots, I have ordered with James Laot.
  • Created discussion thread My 300mm/2.8 is dead?
    I had this Minolta High Speed AF APO Tele 300mm/2.8and used it on my 7D for well over 12 years and my Sony alpha 850 for over 7 years. And it performed just fine. This year the trouble started: ...
Activity older than 12 months is not displayed.
santaklaus has not added any gear yet.
Total messages 8
Threads started 1
Last post 4 months ago
Total comments 0
Total likes 0
Total reviews 0
Entries 0
Votes cast 0
Photos uploaded 0