Godox_Studio

Joined on Dec 26, 2017

Godox_Studio's recent activity

  • Yes it was fully charged.. it has been returned.
  • Yes I have tried removing the bulb and ensuring it is snug.  I guess it is back to the store with it.
  • Yes It has been inserted correctly.  As mentioned it was firing fine during test session, left it turned off unattended and came back to it not working.  I can see a small spark in the tube when I ...
  • Yes I have removed the head and reattached.  Did this when checking to ensure the other flash head still worked.
  • Created discussion thread AD200 Bare bulb issue?
    Bought an AD200 along with a couple of AD600... it is still very new less than a month.  I used it for a test session took about 30 pictures all was working fine. I shut it off, left it mounted in ...
  • Sailor Blue thank you for the information.  I actually found and read your studio equipment list write up that you shared on another post a while back.   All great info.  Thanks.
  • Chris thank you for the detailed replies they have helped a lot.  I actually own a Westcott Rapidbox XL already that I have used with speedlight in s bracket.  I will keep this for location work ...
  • Thank you for the video, thinking about your siggestions for lighting setup.  I was drawn to something with a modeling light just didnt think the AD600 was going to be strong enough. Can I ask your ...
  • Thanks for the replies.  Is the AD600 modeling light useable?   I know proper A.C. strobes have 150W modeling lights.  But Ad600 is only a 10W LED?
  • Created discussion thread New Studio Setup
    Hello All, Been on here reading a lot lately and was hoping to get some advice.  I am looking at starting up a new home studio and need some help on light set up.  I would like to stick with ...
Activity older than 12 months is not displayed.
Total messages 10
Threads started 2
Last post 5 months ago
Total comments 0
Total likes 0
Total reviews 0
Entries 0
Votes cast 0
Photos uploaded 0