Pics not loading

Started 8 months ago | Questions
Cluny New Member • Posts: 1
Pics not loading

My Finepix 52000HD ---I cannot transfer my pics from this camera to my newer Dell laptop. I used the cd that came with the camera, but I cannot get my pics to load. I do get something that says the address is wrong (the C drive address for the computer). Any ideas what I can do. My old laptop has a million things wrong with it and takes forever to download.

ANSWER:
This question has not been answered yet.
Derek49 Contributing Member • Posts: 556
Re: Pics not loading

Cluny wrote:

My Finepix 52000HD ---I cannot transfer my pics from this camera to my newer Dell laptop. I used the cd that came with the camera, but I cannot get my pics to load. I do get something that says the address is wrong (the C drive address for the computer). Any ideas what I can do. My old laptop has a million things wrong with it and takes forever to download.

The easiest way to copy pics is to use a card reader. Plug it into a USB port with your card in and it appears as another drive, then all you do is copy and paste your pics using Windows File Explorer. Newer laptops often have a built in card reader, check your Dell for this.

 Derek49's gear list:Derek49's gear list
Fujifilm FinePix F40fd Fujifilm FinePix F450 Zoom Panasonic Lumix DMC-TZ5 Sony Cyber-shot DSC-R1 Fujifilm X10 +29 more
GeoffreyHP Junior Member • Posts: 25
Re: Pics not loading

You will probably need a USB Reader which accepts an XP card (rather than SD which is the current standard for laptops)  Readily available from WWW .  Recently,  I passed mine on to my daughter,  to use with the F31hd  which she has used for underwater work.

GeoffreyHP Junior Member • Posts: 25
Re: Pics not loading

Sorry:  Shoud read "XD"  card, which were standard on earlier Fuji cameras

Keyboard shortcuts:
FForum MMy threads