D5 - Stuck AF-Mode Button

Started 3 months ago | Discussions
Gavinw Forum Member • Posts: 64
D5 - Stuck AF-Mode Button

It appears that the button on my D5 that you push to select AF modes is stuck. The camera will still shoot but you can't change any settings unless you switch the lever adjacent to the button from AF to M. At that point you can change things agin. Has anyone had this problem before? I hope there is some way to fix it without sending it in to Nikon.

 Gavinw's gear list:Gavinw's gear list
Nikon D700 Nikon D810 Nikon D5 Nikon AF-S Nikkor 14-24mm f/2.8G ED Nikon AF-S Nikkor 24-70mm f/2.8G ED +5 more
Nikon D5
If you believe there are incorrect tags, please send us this post using our feedback form.
TheMerchantofVenice Regular Member • Posts: 305
Re: D5 - Stuck AF-Mode Button

My only experience in this area is vigorously exercising the offending button in the hope that bit of debris or some such is cleared out.

A long long time ago I worked on an old computer terminal that used thumbwheels for a particular function.  The mfgr advised they were "self cleaning" if you regularly worked them vigorously from one end to the other.

Otherwise I suspect it's a service center issue.

I did see one poster suggest squirting something like contact cleaner behind the button, but I don't personally endorse this approach as you don't really know where all the cleaner is going to end up.

Keyboard shortcuts:
FForum MMy threads