HELP: Flash/Auto setting not working on Canon Rebel EOS 2000 35mm camera

Started 7 months ago | Discussions
mack3nz13 New Member • Posts: 3
HELP: Flash/Auto setting not working on Canon Rebel EOS 2000 35mm camera
1

I have used this canon film camera for 5 years and have had no issues, and now when I try to use the automatic setting the flash will not pop up or fire, and there is a whining noise when I press down on the button to take a photo. When I try to make the flash go off on a different setting the body of the camera will also make a whining noise. The camera is (I think) working otherwise, though I haven't developed any of the film I have taken on it for a while. Please let me know if there is something in the camera body I should check or if I should just admit defeat.

 mack3nz13's gear list:mack3nz13's gear list
Canon EOS 300D
Lemming51
Lemming51 Forum Pro • Posts: 15,261
Re: HELP: Flash/Auto setting not working on Canon Rebel EOS 2000 35mm camera

mack3nz13 wrote:

I have used this canon film camera for 5 years and have had no issues, and now when I try to use the automatic setting the flash will not pop up or fire, and there is a whining noise when I press down on the button to take a photo. When I try to make the flash go off on a different setting the body of the camera will also make a whining noise. The camera is (I think) working otherwise, though I haven't developed any of the film I have taken on it for a while. Please let me know if there is something in the camera body I should check or if I should just admit defeat.

There may be some sticky residue keeping the built-in flash from popping up.  Try giving it a little assist with your fingernail, then clean the area underneath it.

-- hide signature --

Unapologetic Canon Apologist

 Lemming51's gear list:Lemming51's gear list
Canon EOS 40D Canon EF 50mm F1.8 II Canon EF-S 15-85mm f/3.5-5.6 IS USM Canon EF 70-200mm f/2.8L USM Canon EF-S 55-250mm f/4-5.6 IS STM +5 more
Keyboard shortcuts:
FForum MMy threads