problem with flash setting on Canon 7D mk2

Started 3 months ago | Discussions
Adyaacov New Member • Posts: 19
problem with flash setting on Canon 7D mk2

Greetings everyone

I have been using my Canon 7D2 with multiple off camera flashes (Canon and Godox) triggered by the Godox X-pro. Recently my camera took a fall and was totaled so I got a replacement body.

On the new body when I use the flashes in ETTL and the camera is on manual mode, when I try to change the aperture I get the message "Low" and the camera goes back to F4 (which is the lowest F stop of the lens). On my old body on manual mode I could change both shutter speed (up to 250) and aperture freely. Other than the body I have made no changes.

I am guessing (hoping) that this is just a setting issue. Does anyone know how to fix it?

Other than that the new body seems to be working well.

Cheers

A

Canon EOS 7D
If you believe there are incorrect tags, please send us this post using our feedback form.
tugwilson Veteran Member • Posts: 3,447
Re: problem with flash setting on Canon 7D mk2

You could try to do a system reset. Instructions here.

OP Adyaacov New Member • Posts: 19
Re: problem with flash setting on Canon 7D mk2

Editing

Turns out the problem is with manual mode in general. Regardless of the flash.

Would still appreciate any help.

A

ScratchDisk Veteran Member • Posts: 3,788
Re: problem with flash setting on Canon 7D mk2

Hi, Beyond a Camera reset, as above, I'd add a flash reset as well.

Battery door open, turn 'on', fully press 'pilot', turn 'off' . .

Also, re-attach speedlite with both body & flash off, turn flash on first . .

(re-clean all 12 contact surfaces (5 + rail) X 2)

 ScratchDisk's gear list:ScratchDisk's gear list
Canon EOS 5D Mark III Canon EOS M5 Canon EOS 90D
OP Adyaacov New Member • Posts: 19
Re: problem with flash setting on Canon 7D mk2

Solved

Was just the shift lock LOL.

Thank you all

Keyboard shortcuts:
FForum MMy threads