K3III firmware 1.01 ?

Started 3 months ago | Questions
Valeriu 64
Valeriu 64 Veteran Member • Posts: 3,938
Re: K3III firmware 1.01 ?

MightyMike wrote:

Valeriu 64 wrote:

MightyMike wrote:

First off, go into sensor cleaning mode and take an air blower and blow the area at the bottom of the mirror box a good amount to knock any dust out of there. Secondly take a dry cloth and give the contacts on the camera mount and lens a good wipe down. The try it out again, if the issues persist then there may be other problems that could be hard to diagnose and pin down.

Should it be blown under the mirror, exactly on the sensor?

Can't blow dust into the camera?

I also blew a few years ago at the K5 with a photo pump and it was filled with dust and lint, inside the focusing screen glass.

Blow and pray LOL I choose not to wipe the AF optics,

Not even with sandpaper?

no telling if they're easily scratched, I just blow the dust and if it lands on the sensor that is unfortunate... I tend to squeeze the blowers several times before aiming them into the camera in hopes that any dust that got in them gets out first.

Thank you, dear Mike!

Best regards, Valeriu

-- hide signature --

Mike from Canada
"I am not a great photographer! God is a great creator! All I do is capture His creation with the tools He has provided me."
'I like to think so far outside the box that it would require a telephoto lens just to see the box!' ~ 'My Quote :)'
http://www.michaelfastphotography.com/galleries/VP-BDI_3a.jpg
http://www.airliners.net/user/SpeEedy/profile/photos?sortBy=photoFavoriteCount

 Valeriu 64's gear list:Valeriu 64's gear list
Pentax K-1 II Pentax K-3 Mark III Sigma 70-200mm F2.8 EX DG Macro HSM II Pentax smc D-FA 100mm F2.8 Macro WR Pentax smc DA 18-135mm F3.5-5.6ED AL [IF] DC WR +8 more
MightyMike Forum Pro • Posts: 41,126
Re: K3III firmware 1.01 ?
1

Valeriu 64 wrote:

MightyMike wrote:

Valeriu 64 wrote:

MightyMike wrote:

First off, go into sensor cleaning mode and take an air blower and blow the area at the bottom of the mirror box a good amount to knock any dust out of there. Secondly take a dry cloth and give the contacts on the camera mount and lens a good wipe down. The try it out again, if the issues persist then there may be other problems that could be hard to diagnose and pin down.

Should it be blown under the mirror, exactly on the sensor?

Can't blow dust into the camera?

I also blew a few years ago at the K5 with a photo pump and it was filled with dust and lint, inside the focusing screen glass.

Blow and pray LOL I choose not to wipe the AF optics,

Not even with sandpaper?

uh... wipe them with Vaseline, it'll do wonders for you AF system... NOT!

no telling if they're easily scratched, I just blow the dust and if it lands on the sensor that is unfortunate... I tend to squeeze the blowers several times before aiming them into the camera in hopes that any dust that got in them gets out first.

Thank you, dear Mike!

Best regards, Valeriu

-- hide signature --

Mike from Canada
"I am not a great photographer! God is a great creator! All I do is capture His creation with the tools He has provided me."
'I like to think so far outside the box that it would require a telephoto lens just to see the box!' ~ 'My Quote :)'
http://www.michaelfastphotography.com/galleries/VP-BDI_3a.jpg
http://www.airliners.net/user/SpeEedy/profile/photos?sortBy=photoFavoriteCount

Valeriu 64
Valeriu 64 Veteran Member • Posts: 3,938
Re: K3III firmware 1.01 ?

MightyMike wrote:

Valeriu 64 wrote:

MightyMike wrote:

Valeriu 64 wrote:

MightyMike wrote:

First off, go into sensor cleaning mode and take an air blower and blow the area at the bottom of the mirror box a good amount to knock any dust out of there. Secondly take a dry cloth and give the contacts on the camera mount and lens a good wipe down. The try it out again, if the issues persist then there may be other problems that could be hard to diagnose and pin down.

Should it be blown under the mirror, exactly on the sensor?

Can't blow dust into the camera?

I also blew a few years ago at the K5 with a photo pump and it was filled with dust and lint, inside the focusing screen glass.

Blow and pray LOL I choose not to wipe the AF optics,

Not even with sandpaper?

uh... wipe them with Vaseline, it'll do wonders for you AF system... NOT!

I was kidding, you know, anyway.

😀😀😀

And I thank you for your solution to Jeremiah's problem.

Best regards, Valeriu

no telling if they're easily scratched, I just blow the dust and if it lands on the sensor that is unfortunate... I tend to squeeze the blowers several times before aiming them into the camera in hopes that any dust that got in them gets out first.

Thank you, dear Mike!

Best regards, Valeriu

-- hide signature --

Mike from Canada
"I am not a great photographer! God is a great creator! All I do is capture His creation with the tools He has provided me."
'I like to think so far outside the box that it would require a telephoto lens just to see the box!' ~ 'My Quote :)'
http://www.michaelfastphotography.com/galleries/VP-BDI_3a.jpg
http://www.airliners.net/user/SpeEedy/profile/photos?sortBy=photoFavoriteCount

 Valeriu 64's gear list:Valeriu 64's gear list
Pentax K-1 II Pentax K-3 Mark III Sigma 70-200mm F2.8 EX DG Macro HSM II Pentax smc D-FA 100mm F2.8 Macro WR Pentax smc DA 18-135mm F3.5-5.6ED AL [IF] DC WR +8 more
MightyMike Forum Pro • Posts: 41,126
Re: K3III firmware 1.01 ?

Valeriu 64 wrote:

MightyMike wrote:

Valeriu 64 wrote:

MightyMike wrote:

Valeriu 64 wrote:

MightyMike wrote:

First off, go into sensor cleaning mode and take an air blower and blow the area at the bottom of the mirror box a good amount to knock any dust out of there. Secondly take a dry cloth and give the contacts on the camera mount and lens a good wipe down. The try it out again, if the issues persist then there may be other problems that could be hard to diagnose and pin down.

Should it be blown under the mirror, exactly on the sensor?

Can't blow dust into the camera?

I also blew a few years ago at the K5 with a photo pump and it was filled with dust and lint, inside the focusing screen glass.

Blow and pray LOL I choose not to wipe the AF optics,

Not even with sandpaper?

uh... wipe them with Vaseline, it'll do wonders for you AF system... NOT!

I was kidding, you know, anyway.

Same here

😀😀😀

And I thank you for your solution to Jeremiah's problem.

It took me many months of this inconsistent intermittent issue to pin it down, I came close to tossing my Sigma 100-300mm F4.0 EX DG into the lake at one point, so happy I didn't! and it wasn't even the problem! Anyhow I'm happy to share my solution when this problem comes up, its truly maddening when you don't know the cause of it.

Best regards, Valeriu

no telling if they're easily scratched, I just blow the dust and if it lands on the sensor that is unfortunate... I tend to squeeze the blowers several times before aiming them into the camera in hopes that any dust that got in them gets out first.

Thank you, dear Mike!

Best regards, Valeriu

-- hide signature --

Mike from Canada
"I am not a great photographer! God is a great creator! All I do is capture His creation with the tools He has provided me."
'I like to think so far outside the box that it would require a telephoto lens just to see the box!' ~ 'My Quote :)'
http://www.michaelfastphotography.com/galleries/VP-BDI_3a.jpg
http://www.airliners.net/user/SpeEedy/profile/photos?sortBy=photoFavoriteCount

Valeriu 64
Valeriu 64 Veteran Member • Posts: 3,938
Re: K3III firmware 1.01 ?

MightyMike wrote:

Valeriu 64 wrote:

MightyMike wrote:

Valeriu 64 wrote:

MightyMike wrote:

Valeriu 64 wrote:

MightyMike wrote:

First off, go into sensor cleaning mode and take an air blower and blow the area at the bottom of the mirror box a good amount to knock any dust out of there. Secondly take a dry cloth and give the contacts on the camera mount and lens a good wipe down. The try it out again, if the issues persist then there may be other problems that could be hard to diagnose and pin down.

Should it be blown under the mirror, exactly on the sensor?

Can't blow dust into the camera?

I also blew a few years ago at the K5 with a photo pump and it was filled with dust and lint, inside the focusing screen glass.

Blow and pray LOL I choose not to wipe the AF optics,

Not even with sandpaper?

uh... wipe them with Vaseline, it'll do wonders for you AF system... NOT!

I was kidding, you know, anyway.

Same here

😀😀😀

And I thank you for your solution to Jeremiah's problem.

It took me many months of this inconsistent intermittent issue to pin it down, I came close to tossing my Sigma 100-300mm F4.0 EX DG into the lake at one point, so happy I didn't! and it wasn't even the problem! Anyhow I'm happy to share my solution when this problem comes up, its truly maddening when you don't know the cause of it.

Such a situation, if we did not know the solution given by you, would send the camera and the lens to the service. If the equipment is no longer under warranty, then additional costs will result, which is not a happy case.

Best regards, Valeriu

no telling if they're easily scratched, I just blow the dust and if it lands on the sensor that is unfortunate... I tend to squeeze the blowers several times before aiming them into the camera in hopes that any dust that got in them gets out first.

Thank you, dear Mike!

Best regards, Valeriu

-- hide signature --

Mike from Canada
"I am not a great photographer! God is a great creator! All I do is capture His creation with the tools He has provided me."
'I like to think so far outside the box that it would require a telephoto lens just to see the box!' ~ 'My Quote :)'
http://www.michaelfastphotography.com/galleries/VP-BDI_3a.jpg
http://www.airliners.net/user/SpeEedy/profile/photos?sortBy=photoFavoriteCount

 Valeriu 64's gear list:Valeriu 64's gear list
Pentax K-1 II Pentax K-3 Mark III Sigma 70-200mm F2.8 EX DG Macro HSM II Pentax smc D-FA 100mm F2.8 Macro WR Pentax smc DA 18-135mm F3.5-5.6ED AL [IF] DC WR +8 more
5r82 Contributing Member • Posts: 632
Re: K3III firmware 1.01 ?

Valeriu 64 wrote:

JeremieB wrote:

Hello,

Did anyone keep/have/know where to find firmware 1.01 for Pentax K3iii ?

I just upgraded to 1.02, and apparently I didn't keep previous ones ...

Asking that because after this upgrade, I think AF is failing big time

Symptoms so far:

- with DFA 100 macro, sometimes it would just not focus, in af-c, when you change subject quickly. There is a leaf, I can reproduce it all the time from some angle, but it happens frequently in other circumstances (never before).

Then, either it waits for a few seconds, doing nothing, then it focuses. It's doing pauses like this frequently.

Either it acquires (correct) focus, then moves it backwards - pause - move backwards - pause, until it's at closest distance. If I move to another subject and trigger AF again it might work. If I move back to same subject (some leaf in my case), the same weird behaviour occurs.

- with 150+450 and typical scene of a bird flying high in the sky, in AF auto: when triggering AF, it moves backwards a little, viewfinder gets blurred and... That's it. It never tries to acquire focus again, it's like it became completely blind to the birds. But it might just be the same pause, but when it's back to work birds have gone away for sure a long time ago.

I must say I'm absolutely sure none of this happened before I migrated to 1.02 and reset settings. I did both in sequence so I didn't test upgrade without reset settings. I normally did set back main AF settings but even with defaults, it never behaved like that.

Alternatively, is there some reset to factory settings feature ? (that would include original firmware)

Is this somehow the bankruptcy of the Pentax brand? 😏

As we can see, the problems are multiplying instead of being solved.

Actually, the same things happened with K-1. But finally Pentax polished most of the issues into one great camera. Well perhaps except the selecting cards issue which remained. But perhaps that was designers wish for some reason not known to us. So I believe the same corrections will happen to K-3 III with new firmware updates soon.

 5r82's gear list:5r82's gear list
Panasonic Lumix DMC-LX5 Pentax K-5 II Pentax K-1 Pentax smc FA 50mm F1.4 Sigma 10-20mm F4-5.6 EX DC HSM +3 more
Valeriu 64
Valeriu 64 Veteran Member • Posts: 3,938
Re: K3III firmware 1.01 ?

5r82 wrote:

Valeriu 64 wrote:

JeremieB wrote:

Hello,

Did anyone keep/have/know where to find firmware 1.01 for Pentax K3iii ?

I just upgraded to 1.02, and apparently I didn't keep previous ones ...

Asking that because after this upgrade, I think AF is failing big time

Symptoms so far:

- with DFA 100 macro, sometimes it would just not focus, in af-c, when you change subject quickly. There is a leaf, I can reproduce it all the time from some angle, but it happens frequently in other circumstances (never before).

Then, either it waits for a few seconds, doing nothing, then it focuses. It's doing pauses like this frequently.

Either it acquires (correct) focus, then moves it backwards - pause - move backwards - pause, until it's at closest distance. If I move to another subject and trigger AF again it might work. If I move back to same subject (some leaf in my case), the same weird behaviour occurs.

- with 150+450 and typical scene of a bird flying high in the sky, in AF auto: when triggering AF, it moves backwards a little, viewfinder gets blurred and... That's it. It never tries to acquire focus again, it's like it became completely blind to the birds. But it might just be the same pause, but when it's back to work birds have gone away for sure a long time ago.

I must say I'm absolutely sure none of this happened before I migrated to 1.02 and reset settings. I did both in sequence so I didn't test upgrade without reset settings. I normally did set back main AF settings but even with defaults, it never behaved like that.

Alternatively, is there some reset to factory settings feature ? (that would include original firmware)

Is this somehow the bankruptcy of the Pentax brand? 😏

As we can see, the problems are multiplying instead of being solved.

Actually, the same things happened with K-1. But finally Pentax polished most of the issues into one great camera. Well perhaps except the selecting cards issue which remained. But perhaps that was designers wish for some reason not known to us. So I believe the same corrections will happen to K-3 III with new firmware updates soon.

Let's hope that they will solve the problems that are, and will be discovered, and that they will definitely improve AF-C.

 Valeriu 64's gear list:Valeriu 64's gear list
Pentax K-1 II Pentax K-3 Mark III Sigma 70-200mm F2.8 EX DG Macro HSM II Pentax smc D-FA 100mm F2.8 Macro WR Pentax smc DA 18-135mm F3.5-5.6ED AL [IF] DC WR +8 more
Keyboard shortcuts:
FForum MMy threads