K3III firmware 1.01 ?

Started 1 month ago | Questions
JeremieB Senior Member • Posts: 1,000
K3III firmware 1.01 ?

Hello,

Did anyone keep/have/know where to find firmware 1.01 for Pentax K3iii ?

I just upgraded to 1.02, and apparently I didn't keep previous ones ...

Asking that because after this upgrade, I think AF is failing big time

Symptoms so far:

- with DFA 100 macro, sometimes it would just not focus, in af-c, when you change subject quickly. There is a leaf, I can reproduce it all the time from some angle, but it happens frequently in other circumstances (never before).

Then, either it waits for a few seconds, doing nothing, then it focuses. It's doing pauses like this frequently.

Either it acquires (correct) focus, then moves it backwards - pause - move backwards - pause, until it's at closest distance. If I move to another subject and trigger AF again it might work. If I move back to same subject (some leaf in my case), the same weird behaviour occurs.

- with 150+450 and typical scene of a bird flying high in the sky, in AF auto: when triggering AF, it moves backwards a little, viewfinder gets blurred and... That's it. It never tries to acquire focus again, it's like it became completely blind to the birds. But it might just be the same pause, but when it's back to work birds have gone away for sure a long time ago.

I must say I'm absolutely sure none of this happened before I migrated to 1.02 and reset settings. I did both in sequence so I didn't test upgrade without reset settings. I normally did set back main AF settings but even with defaults, it never behaved like that.

Alternatively, is there some reset to factory settings feature ? (that would include original firmware)

 JeremieB's gear list:JeremieB's gear list
Pentax K100D Pentax K-3 Mark III Pentax smc FA 50mm F1.4 Pentax smc DA 18-55mm F3.5-5.6 AL Pentax smc D-FA 100mm F2.8 Macro WR +6 more
ANSWER:
MarBa Contributing Member • Posts: 806
Is it possible to downgrade?

This is sad to hear. I hope you will find out what is going on!

Is it even possible to downgrade the firmware?

I tried to just change the number in this link ... But no luck.

http://www.ricoh-imaging.co.jp/english/support/digital/firmware/k3III_v102.zip

Hopefully someone will have the file.

Best,

M

 MarBa's gear list:MarBa's gear list
Pentax K-1 Pentax K-3 Mark III Pentax smc FA 31mm F1.8 AL Limited Pentax smc FA 43mm F1.9 Limited Pentax smc FA 77mm 1.8 Limited +3 more
Valeriu 64
Valeriu 64 Veteran Member • Posts: 3,938
Re: K3III firmware 1.01 ?
1

JeremieB wrote:

Hello,

Did anyone keep/have/know where to find firmware 1.01 for Pentax K3iii ?

I just upgraded to 1.02, and apparently I didn't keep previous ones ...

Asking that because after this upgrade, I think AF is failing big time

Symptoms so far:

- with DFA 100 macro, sometimes it would just not focus, in af-c, when you change subject quickly. There is a leaf, I can reproduce it all the time from some angle, but it happens frequently in other circumstances (never before).

Then, either it waits for a few seconds, doing nothing, then it focuses. It's doing pauses like this frequently.

Either it acquires (correct) focus, then moves it backwards - pause - move backwards - pause, until it's at closest distance. If I move to another subject and trigger AF again it might work. If I move back to same subject (some leaf in my case), the same weird behaviour occurs.

- with 150+450 and typical scene of a bird flying high in the sky, in AF auto: when triggering AF, it moves backwards a little, viewfinder gets blurred and... That's it. It never tries to acquire focus again, it's like it became completely blind to the birds. But it might just be the same pause, but when it's back to work birds have gone away for sure a long time ago.

I must say I'm absolutely sure none of this happened before I migrated to 1.02 and reset settings. I did both in sequence so I didn't test upgrade without reset settings. I normally did set back main AF settings but even with defaults, it never behaved like that.

Alternatively, is there some reset to factory settings feature ? (that would include original firmware)

Is this somehow the bankruptcy of the Pentax brand? 😏

As we can see, the problems are multiplying instead of being solved.

 Valeriu 64's gear list:Valeriu 64's gear list
Pentax K-1 II Pentax K-3 Mark III Sigma 70-200mm F2.8 EX DG Macro HSM II Pentax smc D-FA 100mm F2.8 Macro WR Pentax smc DA 18-135mm F3.5-5.6ED AL [IF] DC WR +8 more
MightyMike Forum Pro • Posts: 41,069
Re: K3III firmware 1.01 ?
6

First off, go into sensor cleaning mode and take an air blower and blow the area at the bottom of the mirror box a good amount to knock any dust out of there. Secondly take a dry cloth and give the contacts on the camera mount and lens a good wipe down. The try it out again, if the issues persist then there may be other problems that could be hard to diagnose and pin down.

-- hide signature --

Mike from Canada
"I am not a great photographer! God is a great creator! All I do is capture His creation with the tools He has provided me."
'I like to think so far outside the box that it would require a telephoto lens just to see the box!' ~ 'My Quote :)'
http://www.michaelfastphotography.com/galleries/VP-BDI_3a.jpg
http://www.airliners.net/user/SpeEedy/profile/photos?sortBy=photoFavoriteCount

iso rivolta Contributing Member • Posts: 845
Re: K3III firmware 1.01 ?
2

JeremieB wrote:

Hello,

Did anyone keep/have/know where to find firmware 1.01 for Pentax K3iii ?

I just upgraded to 1.02, and apparently I didn't keep previous ones ...

Asking that because after this upgrade, I think AF is failing big time

1.01 is still available for download here: https://drivers.softpedia.com/get/SCANNER-Digital-CAMERA-WEBCAM/Ricoh/Ricoh-Pentax-K-3-Mark-III-Camera-Firmware-1-01.shtml#download

I don't know if the downgrade would work, though.

 iso rivolta's gear list:iso rivolta's gear list
Pentax K-3 II Pentax KP +3 more
selected answer This post was selected as the answer by the original poster.
OP JeremieB Senior Member • Posts: 1,000
Re: Is it possible to downgrade?

MarBa wrote:

This is sad to hear. I hope you will find out what is going on!

Seems to be really that: sometimes, AF will just keep getting closer without any logic.

I verified with the 150-450 limited to 6m - infinite, on a plane : it focuses somewhat correctly, then immediately moves closer, until it hits the 6m distance.

In "normal" use on subjects around me, it works correctly - except when it hits this issue, randomly, but if it hits it on a specific suject it will be reproducible on this same subject/framing.

I noticed also sometimes, on a distant subject out of focus, it will not even try to acquire focus - but the AF points will show up where the object is and if I move they will follow ! (object is visible but blurred).

I tried with subject detection OFF but it's the same.

I think i'ts a case for support ...

Is it even possible to downgrade the firmware?

I found the file in my computer trash ... But no, it's not possible to downgrade.

I tried to just change the number in this link ... But no luck.

http://www.ricoh-imaging.co.jp/english/support/digital/firmware/k3III_v102.zip

Hopefully someone will have the file.

Best,

M

 JeremieB's gear list:JeremieB's gear list
Pentax K100D Pentax K-3 Mark III Pentax smc FA 50mm F1.4 Pentax smc DA 18-55mm F3.5-5.6 AL Pentax smc D-FA 100mm F2.8 Macro WR +6 more
MightyMike Forum Pro • Posts: 41,069
Re: Is it possible to downgrade?
4

JeremieB wrote:

MarBa wrote:

This is sad to hear. I hope you will find out what is going on!

Seems to be really that: sometimes, AF will just keep getting closer without any logic.

I verified with the 150-450 limited to 6m - infinite, on a plane : it focuses somewhat correctly, then immediately moves closer, until it hits the 6m distance.

Had the same issue dating all the way back to the K10D (or K20D) with my Sigma 100-300mm F4.0 EX DG, when using multi-point AF and tracking planes and birds. it drove me nuts! I finally found out the cause, it was dust on the AF sensor optics in just the right place to cause the multi-point algorithm to fail as the mixed reading caused by the dust totally through off the algorithm, the lens would focus closer and closer in short movements with slight pauses in between until it stopped at the minimum focusing distance. I'd then have to point it elsewhere and tell it to refocus before it went back to normal (only for a while and then it would happen again). Simply blow the dust off the AF module optics and you'll find the problem should go away.

In "normal" use on subjects around me, it works correctly - except when it hits this issue, randomly, but if it hits it on a specific suject it will be reproducible on this same subject/framing.

I noticed also sometimes, on a distant subject out of focus, it will not even try to acquire focus - but the AF points will show up where the object is and if I move they will follow ! (object is visible but blurred).

I tried with subject detection OFF but it's the same.

I think i'ts a case for support ...

Is it even possible to downgrade the firmware?

I found the file in my computer trash ... But no, it's not possible to downgrade.

I tried to just change the number in this link ... But no luck.

http://www.ricoh-imaging.co.jp/english/support/digital/firmware/k3III_v102.zip

Hopefully someone will have the file.

Best,

M

-- hide signature --

Mike from Canada
"I am not a great photographer! God is a great creator! All I do is capture His creation with the tools He has provided me."
'I like to think so far outside the box that it would require a telephoto lens just to see the box!' ~ 'My Quote :)'
http://www.michaelfastphotography.com/galleries/VP-BDI_3a.jpg
http://www.airliners.net/user/SpeEedy/profile/photos?sortBy=photoFavoriteCount

OP JeremieB Senior Member • Posts: 1,000
Re: K3III firmware 1.01 ?
3

MightyMike wrote:

First off, go into sensor cleaning mode and take an air blower and blow the area at the bottom of the mirror box a good amount to knock any dust out of there. Secondly take a dry cloth and give the contacts on the camera mount and lens a good wipe down. The try it out again, if the issues persist then there may be other problems that could be hard to diagnose and pin down.

Thank you so much - I did both, and my beloved AF is back !

Before cleaning I didn't notice anything wrong, didn't see any particles or bad stuff on contacts, but apparently there was that's weird. Now it works like a charm.

 JeremieB's gear list:JeremieB's gear list
Pentax K100D Pentax K-3 Mark III Pentax smc FA 50mm F1.4 Pentax smc DA 18-55mm F3.5-5.6 AL Pentax smc D-FA 100mm F2.8 Macro WR +6 more
OP JeremieB Senior Member • Posts: 1,000
Re: Is it possible to downgrade?
1

MightyMike wrote:

JeremieB wrote:

MarBa wrote:

This is sad to hear. I hope you will find out what is going on!

Seems to be really that: sometimes, AF will just keep getting closer without any logic.

I verified with the 150-450 limited to 6m - infinite, on a plane : it focuses somewhat correctly, then immediately moves closer, until it hits the 6m distance.

Had the same issue dating all the way back to the K10D (or K20D) with my Sigma 100-300mm F4.0 EX DG, when using multi-point AF and tracking planes and birds. it drove me nuts! I finally found out the cause, it was dust on the AF sensor optics in just the right place to cause the multi-point algorithm to fail as the mixed reading caused by the dust totally through off the algorithm, the lens would focus closer and closer in short movements with slight pauses in between until it stopped at the minimum focusing distance. I'd then have to point it elsewhere and tell it to refocus before it went back to normal (only for a while and then it would happen again). Simply blow the dust off the AF module optics and you'll find the problem should go away.

Yes, it was exactly the same before I followed you advice, thanks again.

It's amazing that a small particle could cause such big issueΒ  Never happened to me with K70 maybe I was lucky.

No, I know what happened. I tested to switch AF lens with MF lens without shutting down the camera, to see if it was keeping the AF array selected for another question. I realize now that dust most certainly entered at this time.

In "normal" use on subjects around me, it works correctly - except when it hits this issue, randomly, but if it hits it on a specific suject it will be reproducible on this same subject/framing.

I noticed also sometimes, on a distant subject out of focus, it will not even try to acquire focus - but the AF points will show up where the object is and if I move they will follow ! (object is visible but blurred).

I tried with subject detection OFF but it's the same.

I think i'ts a case for support ...

Is it even possible to downgrade the firmware?

I found the file in my computer trash ... But no, it's not possible to downgrade.

I tried to just change the number in this link ... But no luck.

http://www.ricoh-imaging.co.jp/english/support/digital/firmware/k3III_v102.zip

Hopefully someone will have the file.

Best,

M

 JeremieB's gear list:JeremieB's gear list
Pentax K100D Pentax K-3 Mark III Pentax smc FA 50mm F1.4 Pentax smc DA 18-55mm F3.5-5.6 AL Pentax smc D-FA 100mm F2.8 Macro WR +6 more
Valeriu 64
Valeriu 64 Veteran Member • Posts: 3,938
Re: K3III firmware 1.01 ?
2

Dear Jeremie, I have now checked for you K3III and 150-450 mm and it works perfectly, thank God, so it is not from the firmware.

Best regards, Valeriu

 Valeriu 64's gear list:Valeriu 64's gear list
Pentax K-1 II Pentax K-3 Mark III Sigma 70-200mm F2.8 EX DG Macro HSM II Pentax smc D-FA 100mm F2.8 Macro WR Pentax smc DA 18-135mm F3.5-5.6ED AL [IF] DC WR +8 more
MightyMike Forum Pro • Posts: 41,069
Re: Is it possible to downgrade?
1

JeremieB wrote:

MightyMike wrote:

JeremieB wrote:

MarBa wrote:

This is sad to hear. I hope you will find out what is going on!

Seems to be really that: sometimes, AF will just keep getting closer without any logic.

I verified with the 150-450 limited to 6m - infinite, on a plane : it focuses somewhat correctly, then immediately moves closer, until it hits the 6m distance.

Had the same issue dating all the way back to the K10D (or K20D) with my Sigma 100-300mm F4.0 EX DG, when using multi-point AF and tracking planes and birds. it drove me nuts! I finally found out the cause, it was dust on the AF sensor optics in just the right place to cause the multi-point algorithm to fail as the mixed reading caused by the dust totally through off the algorithm, the lens would focus closer and closer in short movements with slight pauses in between until it stopped at the minimum focusing distance. I'd then have to point it elsewhere and tell it to refocus before it went back to normal (only for a while and then it would happen again). Simply blow the dust off the AF module optics and you'll find the problem should go away.

Yes, it was exactly the same before I followed you advice, thanks again.

Happy to help!

It's amazing that a small particle could cause such big issue Never happened to me with K70 maybe I was lucky.

No, I know what happened. I tested to switch AF lens with MF lens without shutting down the camera, to see if it was keeping the AF array selected for another question. I realize now that dust most certainly entered at this time.

In "normal" use on subjects around me, it works correctly - except when it hits this issue, randomly, but if it hits it on a specific suject it will be reproducible on this same subject/framing.

I noticed also sometimes, on a distant subject out of focus, it will not even try to acquire focus - but the AF points will show up where the object is and if I move they will follow ! (object is visible but blurred).

I tried with subject detection OFF but it's the same.

I think i'ts a case for support ...

Is it even possible to downgrade the firmware?

I found the file in my computer trash ... But no, it's not possible to downgrade.

I tried to just change the number in this link ... But no luck.

http://www.ricoh-imaging.co.jp/english/support/digital/firmware/k3III_v102.zip

Hopefully someone will have the file.

Best,

M

-- hide signature --

Mike from Canada
"I am not a great photographer! God is a great creator! All I do is capture His creation with the tools He has provided me."
'I like to think so far outside the box that it would require a telephoto lens just to see the box!' ~ 'My Quote :)'
http://www.michaelfastphotography.com/galleries/VP-BDI_3a.jpg
http://www.airliners.net/user/SpeEedy/profile/photos?sortBy=photoFavoriteCount

OP JeremieB Senior Member • Posts: 1,000
Re: K3III firmware 1.01 ?
1

Valeriu 64 wrote:

Dear Jeremie, I have now checked for you K3III and 150-450 mm and it works perfectly, thank God, so it is not from the firmware.

Best regards, Valeriu

MightyMike found the problem πŸ‘

Some dust ...

 JeremieB's gear list:JeremieB's gear list
Pentax K100D Pentax K-3 Mark III Pentax smc FA 50mm F1.4 Pentax smc DA 18-55mm F3.5-5.6 AL Pentax smc D-FA 100mm F2.8 Macro WR +6 more
Valeriu 64
Valeriu 64 Veteran Member • Posts: 3,938
Re: K3III firmware 1.01 ?

JeremieB wrote:

Valeriu 64 wrote:

Dear Jeremie, I have now checked for you K3III and 150-450 mm and it works perfectly, thank God, so it is not from the firmware.

Best regards, Valeriu

MightyMike found the problem πŸ‘

Some dust ...

Thank God!

God bless Mike!

Best regards, Valeriu

 Valeriu 64's gear list:Valeriu 64's gear list
Pentax K-1 II Pentax K-3 Mark III Sigma 70-200mm F2.8 EX DG Macro HSM II Pentax smc D-FA 100mm F2.8 Macro WR Pentax smc DA 18-135mm F3.5-5.6ED AL [IF] DC WR +8 more
Valeriu 64
Valeriu 64 Veteran Member • Posts: 3,938
Re: K3III firmware 1.01 ?

MightyMike wrote:

First off, go into sensor cleaning mode and take an air blower and blow the area at the bottom of the mirror box a good amount to knock any dust out of there. Secondly take a dry cloth and give the contacts on the camera mount and lens a good wipe down. The try it out again, if the issues persist then there may be other problems that could be hard to diagnose and pin down.

Should it be blown under the mirror, exactly on the sensor?

Can't blow dust into the camera?

I also blew a few years ago at the K5 with a photo pump and it was filled with dust and lint, inside the focusing screen glass.

-- hide signature --

Mike from Canada
"I am not a great photographer! God is a great creator! All I do is capture His creation with the tools He has provided me."
'I like to think so far outside the box that it would require a telephoto lens just to see the box!' ~ 'My Quote :)'
http://www.michaelfastphotography.com/galleries/VP-BDI_3a.jpg
http://www.airliners.net/user/SpeEedy/profile/photos?sortBy=photoFavoriteCount

 Valeriu 64's gear list:Valeriu 64's gear list
Pentax K-1 II Pentax K-3 Mark III Sigma 70-200mm F2.8 EX DG Macro HSM II Pentax smc D-FA 100mm F2.8 Macro WR Pentax smc DA 18-135mm F3.5-5.6ED AL [IF] DC WR +8 more
kypfer Contributing Member • Posts: 562
Re: K3III firmware 1.01 ?
1

Just for reference … downgrading from v1.02 to v1.01 is no problem … just tried it. Here's hoping it'll go back to v1.02 no problem

OP JeremieB Senior Member • Posts: 1,000
Re: K3III firmware 1.01 ?
1

Thanks everyone for the helping hand !

 JeremieB's gear list:JeremieB's gear list
Pentax K100D Pentax K-3 Mark III Pentax smc FA 50mm F1.4 Pentax smc DA 18-55mm F3.5-5.6 AL Pentax smc D-FA 100mm F2.8 Macro WR +6 more
drummercam Senior Member • Posts: 1,910
Re: K3III firmware 1.01 ?
2

If a firmware update were to have a defect, Pentax would release a replacement firmware pronto.
-------------------
"Elegance of operation" -- Pentax
"Heavy for its size" -- DPR

 drummercam's gear list:drummercam's gear list
Ricoh GR Digital III Leica Q Pentax K-01 Pentax Q7 Pentax K-3 +11 more
MightyMike Forum Pro • Posts: 41,069
Re: K3III firmware 1.01 ?
1

Valeriu 64 wrote:

MightyMike wrote:

First off, go into sensor cleaning mode and take an air blower and blow the area at the bottom of the mirror box a good amount to knock any dust out of there. Secondly take a dry cloth and give the contacts on the camera mount and lens a good wipe down. The try it out again, if the issues persist then there may be other problems that could be hard to diagnose and pin down.

Should it be blown under the mirror, exactly on the sensor?

Can't blow dust into the camera?

I also blew a few years ago at the K5 with a photo pump and it was filled with dust and lint, inside the focusing screen glass.

Blow and pray LOL I choose not to wipe the AF optics, no telling if they're easily scratched, I just blow the dust and if it lands on the sensor that is unfortunate... I tend to squeeze the blowers several times before aiming them into the camera in hopes that any dust that got in them gets out first.

-- hide signature --

Mike from Canada
"I am not a great photographer! God is a great creator! All I do is capture His creation with the tools He has provided me."
'I like to think so far outside the box that it would require a telephoto lens just to see the box!' ~ 'My Quote :)'
http://www.michaelfastphotography.com/galleries/VP-BDI_3a.jpg
http://www.airliners.net/user/SpeEedy/profile/photos?sortBy=photoFavoriteCount

PentUp Senior Member • Posts: 1,925
Re: K3III firmware 1.01 ?
1

Valeriu 64 wrote:

JeremieB wrote:

Valeriu 64 wrote:

Dear Jeremie, I have now checked for you K3III and 150-450 mm and it works perfectly, thank God, so it is not from the firmware.

Best regards, Valeriu

MightyMike found the problem πŸ‘

Some dust ...

Thank God!

God bless Mike!

Best regards, Valeriu

Yes, Mike is Mighty!

 PentUp's gear list:PentUp's gear list
Panasonic Lumix DMC-FZ300 Pentax K-x Pentax K-5 II Pentax K-50 Pentax K-3 Mark III +10 more
Valeriu 64
Valeriu 64 Veteran Member • Posts: 3,938
Re: K3III firmware 1.01 ?

PentUp wrote:

Valeriu 64 wrote:

JeremieB wrote:

Valeriu 64 wrote:

Dear Jeremie, I have now checked for you K3III and 150-450 mm and it works perfectly, thank God, so it is not from the firmware.

Best regards, Valeriu

MightyMike found the problem πŸ‘

Some dust ...

Thank God!

God bless Mike!

Best regards, Valeriu

Yes, Mike is Mighty!

πŸ‘πŸ˜€

 Valeriu 64's gear list:Valeriu 64's gear list
Pentax K-1 II Pentax K-3 Mark III Sigma 70-200mm F2.8 EX DG Macro HSM II Pentax smc D-FA 100mm F2.8 Macro WR Pentax smc DA 18-135mm F3.5-5.6ED AL [IF] DC WR +8 more
Keyboard shortcuts:
FForum MMy threads