Wifi on 5dmkIV totally unstable - assistance needed

Started 3 months ago | Questions
maboleth Contributing Member • Posts: 722
Wifi on 5dmkIV totally unstable - assistance needed

I've been trying to connect my camera wirelessly with my Ubee cable router for days, without much success.

In a nutshell, the connection, when does happen, lasts 1-2min. Only a single time I have managed to connect the camera for good, without any disconnecting.

I tried:
1. Connecting on my wireless network manually with password
2. Using WPS button on the modem itself.

It takes several program and camera restarts to even see them connecting. Usually nothing happens.

Either:

a) Canon utility doesn't come up or recognize the camera actually connected.
b) The connection is there, I can access and do everything as normal, but disconnection happens after 1-2min. This is much more common than a).

I'm trying to figure out why my connection isn't stable once established?

My machine is Windows 10 PC, latest drivers, AMD motherboard, chipset, cpu, gpu. Latest Canon Utility v3, latest camera firmware.

 maboleth's gear list:maboleth's gear list
Canon EOS 5D Mark IV
ANSWER:
This question has not been answered yet.
Nikon 1 V3
If you believe there are incorrect tags, please send us this post using our feedback form.
jwpnyc Junior Member • Posts: 47
Re: Wifi on 5dmkIV totally unstable - assistance needed

Try to disable auto power off. I use 5D IV with iMac and don't have any problem at all.

 jwpnyc's gear list:jwpnyc's gear list
Canon EOS 5D Mark IV Canon EF 50mm f/1.2L USM Canon EF 24-70mm F2.8L II USM Canon EF 16-35mm F4L IS USM Canon EF 35mm F1.4L II USM +1 more
ikolbyi Contributing Member • Posts: 648
Re: Wifi on 5dmkIV totally unstable - assistance needed

maboleth wrote:

I've been trying to connect my camera wirelessly with my Ubee cable router for days, without much success.

In a nutshell, the connection, when does happen, lasts 1-2min. Only a single time I have managed to connect the camera for good, without any disconnecting.

I tried:
1. Connecting on my wireless network manually with password
2. Using WPS button on the modem itself.

It takes several program and camera restarts to even see them connecting. Usually nothing happens.

Either:

a) Canon utility doesn't come up or recognize the camera actually connected.
b) The connection is there, I can access and do everything as normal, but disconnection happens after 1-2min. This is much more common than a).

I'm trying to figure out why my connection isn't stable once established?

My machine is Windows 10 PC, latest drivers, AMD motherboard, chipset, cpu, gpu. Latest Canon Utility v3, latest camera firmware.

I noticed the most recent Android update to my phone broke my Canon connection with my 5D.m4.  The fix for me was to completely start over and reconnect the device as if it was its very first time connection.

 ikolbyi's gear list:ikolbyi's gear list
Canon EOS 5D Mark IV Canon EF 24-70mm F4L IS USM Canon EOS 70D Olympus E-M1 III Olympus Zuiko Digital 2.0x Teleconverter EC-20 +8 more
OP maboleth Contributing Member • Posts: 722
Re: Wifi on 5dmkIV totally unstable - assistance needed

ikolbyi wrote:

maboleth wrote:

I've been trying to connect my camera wirelessly with my Ubee cable router for days, without much success.

In a nutshell, the connection, when does happen, lasts 1-2min. Only a single time I have managed to connect the camera for good, without any disconnecting.

I tried:
1. Connecting on my wireless network manually with password
2. Using WPS button on the modem itself.

It takes several program and camera restarts to even see them connecting. Usually nothing happens.

Either:

a) Canon utility doesn't come up or recognize the camera actually connected.
b) The connection is there, I can access and do everything as normal, but disconnection happens after 1-2min. This is much more common than a).

I'm trying to figure out why my connection isn't stable once established?

My machine is Windows 10 PC, latest drivers, AMD motherboard, chipset, cpu, gpu. Latest Canon Utility v3, latest camera firmware.

I noticed the most recent Android update to my phone broke my Canon connection with my 5D.m4. The fix for me was to completely start over and reconnect the device as if it was its very first time connection.

Thanks. I have tried it all... but none works. I tested it at the cable modem level. I logged on the modem to check access and it connects as soon as I turn on the wifi on 5D, but after few mins it just disconnects by itself.

Also I have checked auto-off feature and it's not related. Camera disconnects even when working/dl-ing images wirelessly.

Oh yes, camera connects nicely on my Android. It's PC connection that has the problem.

 maboleth's gear list:maboleth's gear list
Canon EOS 5D Mark IV
Leica Eye
Leica Eye Veteran Member • Posts: 3,007
Re: Wifi on 5dmkIV totally unstable - assistance needed

I had to completely Trash/Delete the Canon apps from my iMac computer and then Reinstall.. Also after a few disconnections, I Deleted the Fotos App from my 8Plus and reinstalled.. Cured all the issues... L

-- hide signature --

Being Disabled, Photography is my way of telling the World "I Am Alive" ..

 Leica Eye's gear list:Leica Eye's gear list
Leica V-Lux 40 Leica D-Lux 7 Nikon D3100 Canon EOS 5DS Canon EOS 90D +5 more
MitchAlsup Veteran Member • Posts: 5,329
Re: Wifi on 5dmkIV totally unstable - assistance needed

Taking the card out and pluggin it into the computer is WAY faster.........;-)

-- hide signature --

Mitch

Leica Eye
Leica Eye Veteran Member • Posts: 3,007
Re: Wifi on 5dmkIV totally unstable - assistance needed

MitchAlsup wrote:

Taking the card out and pluggin it into the computer is WAY faster.........;-)

That's a workaround:- the OP needs an answer to his predicament..  L

-- hide signature --

Being Disabled, Photography is my way of telling the World "I Am Alive" ..

 Leica Eye's gear list:Leica Eye's gear list
Leica V-Lux 40 Leica D-Lux 7 Nikon D3100 Canon EOS 5DS Canon EOS 90D +5 more
OP maboleth Contributing Member • Posts: 722
Re: Wifi on 5dmkIV totally unstable - assistance needed

Leica Eye wrote:

MitchAlsup wrote:

Taking the card out and pluggin it into the computer is WAY faster.........;-)

That's a workaround:- the OP needs an answer to his predicament.. L

^^ Correct. I never said I need wifi for image DLs.

 maboleth's gear list:maboleth's gear list
Canon EOS 5D Mark IV
OP maboleth Contributing Member • Posts: 722
Re: Wifi on 5dmkIV totally unstable - assistance needed

Leica Eye wrote:

I had to completely Trash/Delete the Canon apps from my iMac computer and then Reinstall.. Also after a few disconnections, I Deleted the Fotos App from my 8Plus and reinstalled.. Cured all the issues... L

Wish I could do the same. But the camera loses connection from the modem itself, that's the biggest issue. So like, even if PC is off, the camera WILL lose connection after a few mins.

 maboleth's gear list:maboleth's gear list
Canon EOS 5D Mark IV
OP maboleth Contributing Member • Posts: 722
Re: Wifi on 5dmkIV totally unstable - assistance needed

I didn't fix it yet, but what I found so far:

1. When camera isn't paired with the PC, but is connected to the modem, the camera remains connected for as long as it turned on - forever.

2. If camera-pc are paired but no eos utility is started, the connection remains exactly 60 seconds. Then it's automatically disconnected by something...

3. If camera is detected by eos utility, connection lasts exactly 73 seconds after disconnect happens automatically.

4. Making IP static with manual setting in the camera makes Eos Utility restarting more easily, as soon as the connection is over.

 maboleth's gear list:maboleth's gear list
Canon EOS 5D Mark IV
Leica Eye
Leica Eye Veteran Member • Posts: 3,007
Re: Wifi on 5dmkIV totally unstable - assistance needed

maboleth wrote:

I didn't fix it yet, but what I found so far:

1. When camera isn't paired with the PC, but is connected to the modem, the camera remains connected for as long as it turned on - forever.

2. If camera-pc are paired but no eos utility is started, the connection remains exactly 60 seconds. Then it's automatically disconnected by something...

3. If camera is detected by eos utility, connection lasts exactly 73 seconds after disconnect happens automatically.

4. Making IP static with manual setting in the camera makes Eos Utility restarting more easily, as soon as the connection is over.

With my internet I can authorize a device, maybe you need to see if that's what is needed.  On my computer I would Delete/Trash ALL the Canon apps etc.. Reboot and download the latest versions, also maybe check the firmware on your camera... L

-- hide signature --

Being Disabled, Photography is my way of telling the World "I Am Alive" ..

 Leica Eye's gear list:Leica Eye's gear list
Leica V-Lux 40 Leica D-Lux 7 Nikon D3100 Canon EOS 5DS Canon EOS 90D +5 more
Enders Shadow
Enders Shadow Veteran Member • Posts: 3,381
Re: Wifi on 5dmkIV totally unstable - assistance needed

maboleth wrote:

I didn't fix it yet, but what I found so far:

1. When camera isn't paired with the PC, but is connected to the modem, the camera remains connected for as long as it turned on - forever.

2. If camera-pc are paired but no eos utility is started, the connection remains exactly 60 seconds. Then it's automatically disconnected by something...

3. If camera is detected by eos utility, connection lasts exactly 73 seconds after disconnect happens automatically.

After the camera to PC connection drops, does the PC connect to your router? If so, this sounds like a classical case of competing WiFi connections.

Your typical WiFi client is "promiscuous" and will search for and switch to a stronger/cleaner connection. Also, newer WiFi clients are programed to prefer 5GHz connections as they can potentially offer faster transfers. A connection to a host without internet access (such as a camera) also seems to trigger a check of available stored networks. This sometimes can be delayed or prevented if the connection is kept "busy".

Disable the WiFi on your router and try the camera to PC connection again.

Don't remember connecting to one of my computers over WiFi. A few times I did connect a camera to my router then access the camera from a computer over a ethernet connection. Just simple experiments to see how well it worked. Never did anything useful. I do occasionally use WiFi to connect to my phone while out shooting.

-- hide signature --

Phil

 Enders Shadow's gear list:Enders Shadow's gear list
Canon PowerShot G12 Olympus Tough TG-3 Fujifilm X30 Canon EOS 7D Mark II Nikon D500 +19 more
OP maboleth Contributing Member • Posts: 722
Re: Wifi on 5dmkIV totally unstable - assistance needed

Thanks, actually I do connect like you did.

My PC does not have a wifi itself, but since my router does (2 in 1), I essentially connect the camera to the router by WPS and then via ethernet EOS Utility finds it and connects it.

I lose no internet connection and my PC is connected to the router by ethernet/lan port.

However, so far the connection was unstable and something disconnected it exactly at the "right" time. And I still cannot find what and why.

Connection to my android smartphone is ok though.

Enders Shadow wrote:

maboleth wrote:

I didn't fix it yet, but what I found so far:

1. When camera isn't paired with the PC, but is connected to the modem, the camera remains connected for as long as it turned on - forever.

2. If camera-pc are paired but no eos utility is started, the connection remains exactly 60 seconds. Then it's automatically disconnected by something...

3. If camera is detected by eos utility, connection lasts exactly 73 seconds after disconnect happens automatically.

After the camera to PC connection drops, does the PC connect to your router? If so, this sounds like a classical case of competing WiFi connections.

Your typical WiFi client is "promiscuous" and will search for and switch to a stronger/cleaner connection. Also, newer WiFi clients are programed to prefer 5GHz connections as they can potentially offer faster transfers. A connection to a host without internet access (such as a camera) also seems to trigger a check of available stored networks. This sometimes can be delayed or prevented if the connection is kept "busy".

Disable the WiFi on your router and try the camera to PC connection again.

Don't remember connecting to one of my computers over WiFi. A few times I did connect a camera to my router then access the camera from a computer over a ethernet connection. Just simple experiments to see how well it worked. Never did anything useful. I do occasionally use WiFi to connect to my phone while out shooting.

 maboleth's gear list:maboleth's gear list
Canon EOS 5D Mark IV
Enders Shadow
Enders Shadow Veteran Member • Posts: 3,381
Re: Wifi on 5dmkIV totally unstable - assistance needed
2

maboleth wrote:

Thanks, actually I do connect like you did.

My PC does not have a wifi itself, but since my router does (2 in 1), I essentially connect the camera to the router by WPS and then via ethernet EOS Utility finds it and connects it.

Your description suggested you were connecting directly between the camera and PC. As WPS is horribly insecure and vulnerable to trivial attacks, it's always disabled on my routers.

The few times I tried it before, there were never problems maintaining connection between the 5D4 and router. I Just tested again. Manually selecting my network then shot a few pictures remotely using the EOS utility. Used both a Win 10 desktop & a Win 10 laptop. Not surprising, standard DHCP IP assignment produced immediate reconnections. Also tested with my 80D & 90D. No issues other than entering my long random WiFi password. Doesn't appear to be any connection related issues with the camera firmware or Canon software.

If you monitor the WiFi connections on your router, does it show the connection to the camera then suddenly disappear? Does it indicate IP assignment and signal strength?

I lose no internet connection and my PC is connected to the router by ethernet/lan port.

You shouldn't lose internet access. The camera is only a wireless client on your network. You only lose internet access when connecting directly to the camera in hotspot mode.

However, so far the connection was unstable and something disconnected it exactly at the "right" time. And I still cannot find what and why.

Difficult for anyone to troubleshoot these sort of problems remotely. As i mentioned, there doesn't appear to be any Canon related issues.

-- hide signature --

Phil

 Enders Shadow's gear list:Enders Shadow's gear list
Canon PowerShot G12 Olympus Tough TG-3 Fujifilm X30 Canon EOS 7D Mark II Nikon D500 +19 more
jwpnyc Junior Member • Posts: 47
Re: Wifi on 5dmkIV totally unstable - assistance needed

I have both Lightroom and Canon Utility installed in my iMac. Although I have never tried it, I think Lightroom may work by itself without Canon Utility. You can stop autostart for Canon Utility.

 jwpnyc's gear list:jwpnyc's gear list
Canon EOS 5D Mark IV Canon EF 50mm f/1.2L USM Canon EF 24-70mm F2.8L II USM Canon EF 16-35mm F4L IS USM Canon EF 35mm F1.4L II USM +1 more
OP maboleth Contributing Member • Posts: 722
Re: Wifi on 5dmkIV totally unstable - assistance needed

Thanks a lot Enders for your thorough testing.

I don't believe Canon is to blame though, as you said, more like some mismatch between my router/PC and camera.

Or maybe some setting in my Ethernet driver? But I'm not sure what to switch off or on. I tried to disable any power plan I found but to no avail. Disconnections still happened.

If you monitor the WiFi connections on your router, does it show the connection to the camera then suddenly disappear? Does it indicate IP assignment and signal strength?

Yes. IP is nicely assigned, esp. when I put a static one. Signal power is ok.
It shows a timer in seconds for each connection. That's how I discovered that Canon Wifi > Router-PC lasts 60 without EOS-U or 73 seconds when connected to EOS-Utility.

 maboleth's gear list:maboleth's gear list
Canon EOS 5D Mark IV
mmarian Senior Member • Posts: 2,022
Re: Wifi on 5dmkIV totally unstable - assistance needed

I find the implementation of WiFi on this camera cumbersome and confusing. I only use it for connecting to my smartphone for remote control but to set it up first time is a headache and then to try to use it when really needed on location can be a frustrating experience. The steps must be taken in a specific order and even then the ability of the Canon App to establish connection with the camera is unreliable. Sometimes it works, sometimes it does not. Not sure if the camera WiFi has anything to do with it or if it is the Canon App itself...

Leica Eye
Leica Eye Veteran Member • Posts: 3,007
Re: Wifi on 5dmkIV totally unstable - assistance needed

mmarian wrote:

I find the implementation of WiFi on this camera cumbersome and confusing. I only use it for connecting to my smartphone for remote control but to set it up first time is a headache and then to try to use it when really needed on location can be a frustrating experience. The steps must be taken in a specific order and even then the ability of the Canon App to establish connection with the camera is unreliable. Sometimes it works, sometimes it does not. Not sure if the camera WiFi has anything to do with it or if it is the Canon App itself...

The Leica FOTOS app was as clunky as hell & very intermittent, as I have said before, Delete the App, reboot and ReInstall.. Reset Camera.. These actions cured both my Leica D-Lux 7 and Canon 90D with their WiFi connection issues...   L

-- hide signature --

Being Disabled, Photography is my way of telling the World "I Am Alive" ..

 Leica Eye's gear list:Leica Eye's gear list
Leica V-Lux 40 Leica D-Lux 7 Nikon D3100 Canon EOS 5DS Canon EOS 90D +5 more
mmarian Senior Member • Posts: 2,022
Re: Wifi on 5dmkIV totally unstable - assistance needed

Leica Eye wrote:

mmarian wrote:

I find the implementation of WiFi on this camera cumbersome and confusing. I only use it for connecting to my smartphone for remote control but to set it up first time is a headache and then to try to use it when really needed on location can be a frustrating experience. The steps must be taken in a specific order and even then the ability of the Canon App to establish connection with the camera is unreliable. Sometimes it works, sometimes it does not. Not sure if the camera WiFi has anything to do with it or if it is the Canon App itself...

The Leica FOTOS app was as clunky as hell & very intermittent, as I have said before, Delete the App, reboot and ReInstall.. Reset Camera.. These actions cured both my Leica D-Lux 7 and Canon 90D with their WiFi connection issues... L

I have done all of that but it does not seem to make the system 100% reliable. I do not use it often, only when shooting in very tight spaces, such as interior shots of a small bathroom with mirrors and I have nowhere to hide I use the remote control to set up the angle of the shot with camera on tripod so close in the corner that I can not see the camera display in LV. Then step out from the room and trigger the shutter remotely using the App. That is about all when I need it. But to see my client standing right next to me watching me struggling with the system can be embarasing and frustrating.

Leica Eye
Leica Eye Veteran Member • Posts: 3,007
Re: Wifi on 5dmkIV totally unstable - assistance needed

mmarian wrote:

Leica Eye wrote:

mmarian wrote:

I find the implementation of WiFi on this camera cumbersome and confusing. I only use it for connecting to my smartphone for remote control but to set it up first time is a headache and then to try to use it when really needed on location can be a frustrating experience. The steps must be taken in a specific order and even then the ability of the Canon App to establish connection with the camera is unreliable. Sometimes it works, sometimes it does not. Not sure if the camera WiFi has anything to do with it or if it is the Canon App itself...

The Leica FOTOS app was as clunky as hell & very intermittent, as I have said before, Delete the App, reboot and ReInstall.. Reset Camera.. These actions cured both my Leica D-Lux 7 and Canon 90D with their WiFi connection issues... L

I have done all of that but it does not seem to make the system 100% reliable. I do not use it often, only when shooting in very tight spaces, such as interior shots of a small bathroom with mirrors and I have nowhere to hide I use the remote control to set up the angle of the shot with camera on tripod so close in the corner that I can not see the camera display in LV. Then step out from the room and trigger the shutter remotely using the App. That is about all when I need it. But to see my client standing right next to me watching me struggling with the system can be embarasing and frustrating.

I feel your pain, how did you manage before these connecting apps? Maybe look for a different marque of camera!   L

-- hide signature --

Being Disabled, Photography is my way of telling the World "I Am Alive" ..

 Leica Eye's gear list:Leica Eye's gear list
Leica V-Lux 40 Leica D-Lux 7 Nikon D3100 Canon EOS 5DS Canon EOS 90D +5 more
Keyboard shortcuts:
FForum MMy threads