Preventing video auto-play in web browsers

Started 4 months ago | Discussions
Sean Nelson
Sean Nelson Forum Pro • Posts: 14,164
Preventing video auto-play in web browsers

I'm getting really annoyed at having to hit the "pause" button on the videos that show up on many of the sites that I visit.  Videos chew up a lot of bandwidth needlessly and I'd especially like to prevent this from happening on my phone where it eats into my data cap.

I use Firefox on Windows and Chrome on my Android phone - is there a way to disable auto-play of videos in these browsers?   If not, are there any other browsers that would let me do this?

CAcreeks
CAcreeks Forum Pro • Posts: 16,076
Re: Preventing video auto-play in web browsers
1

Sean Nelson wrote:

I'm getting really annoyed at having to hit the "pause" button on the videos that show up on many of the sites that I visit. Videos chew up a lot of bandwidth needlessly and I'd especially like to prevent this from happening on my phone where it eats into my data cap.

I use Firefox on Windows and Chrome on my Android phone - is there a way to disable auto-play of videos in these browsers? If not, are there any other browsers that would let me do this?

Yeah, good luck.

I tried all the Firefox about:config settings that are supposed to prevent video autoplay. Never worked. Chrome seems to autoplay because they might be ads for Google to monetize.

Brave works well on my Android phone to prevent all sorts of nonsense, but Brave is buggy on Mac OS so I still use primarily Firefox with uBlock Origin on my desktops.

Searching Firefox add-ons, I see (new?) Disable Autoplay, but reviews are not glowing.

Sean Nelson
OP Sean Nelson Forum Pro • Posts: 14,164
Re: Preventing video auto-play in web browsers

Well, that's discouraging.  I can understand why Chrome wouldn't be wanting to disable ad revenue that Google reaps, but I'd expect more from Firefox...

robertfel Senior Member • Posts: 1,806
Re: Preventing video auto-play in web browsers
3

For Firefox about:config then media.autoplay.default = 1 works for me for YouTube, Amazon Prime and most others.

One trick is that you need to open links in a new tab, rather than direct clicking. I have 10 tabs open across 3 different Firefox windows. Those pesky Amazon Prime trailers never play for me that way.

The uBlock Origin add-on helps with anything that slips through. Just add a filter for sites like brightcove or any thing else. The element picker will let you finetune anything that annoys you.

 robertfel's gear list:robertfel's gear list
Nikon D800 Nikon D850 Nikon Z6 Nikon AF-S Nikkor 14-24mm f/2.8G ED Nikon AF-S Nikkor 24-70mm f/2.8G ED +25 more
Sean Nelson
OP Sean Nelson Forum Pro • Posts: 14,164
Re: Preventing video auto-play in web browsers
1

robertfel wrote:

For Firefox about:config then media.autoplay.default = 1 works for me for YouTube, Amazon Prime and most others.

This looks really promising, thanks! It seems to be working in Windows Firefox, now to see if it's possible in Firefox for Android...

FWIW I've also discovered a setting in Windows Microsoft Edge under the "..." button, "Settings" and then "Advanced". Just below "Adobe Flash" is "Media Autoplay", which you can set to "Block".

CAcreeks
CAcreeks Forum Pro • Posts: 16,076
Re: Preventing video auto-play in web browsers

robertfel wrote:

For Firefox about:config then media.autoplay.default = 1 works for me for YouTube, Amazon Prime and most others.

One trick is that you need to open links in a new tab, rather than direct clicking...

Aha! Thanks much.

Sean, if you have any luck with Firefox on Android, or if you feel it's improved, please say so. I don't even have it installed any more, since discovering Brave browser for Android.

Keyboard shortcuts:
FForum MMy threads