Z7: AF Assist Illuminator fires in MF/Timer- bug??

Started 3 months ago | Discussions
mibadt Senior Member • Posts: 1,179
Z7: AF Assist Illuminator fires in MF/Timer- bug??
1

Hi,

During my last studio work, I have found what I consider a possible bug with the Z7.

We were two photographers trying to work simultaneously in a (low) continuous light (no strobes) studio environment. Thus I was planning to avoid using the green AF light (which might ruin the photos of the other photographer).

My Z7 (latest firmware, at the time with FTZ+Nikkor 50mm 1.8G) was mounted on a tripod and set as follows:

  1. Manual exposure and Focus (after pre focusing)
  2. a11 Low Light AF -ON
  3. a12- Built-in AF-assist illuminator - OFF!

I was shooting by using the screen (activating the shutter while raising my finger from the screen).

This worked fine in single release, however, switching to timer 3- shots mode, with the same parameters, the green AF assist "fired" before each shot.

Did I forget something? How can I achieve my goal, or is it a bug?

Thanks

-- hide signature --

Regards,
Michael Badt
Photos gallery: http://www.flickr.com/photos/mibadt/

Nikon Z7
If you believe there are incorrect tags, please send us this post using our feedback form.
ZapperVT Contributing Member • Posts: 843
Re: Z7: AF Assist Illuminator fires in MF/Timer- bug??

The use of the AF illuminator in the self timer mode appears to be as an indicator and independent of whether you enable it or not.  From Thom Hogan's guide to the Z50 (I assume the Z7 is similar):

Self Timer Delay Settings

Remember, the light on the front of the camera tells you the status of the countdown. It flashes during the first part and then lights steadily during the last two seconds prior to exposure. The addition of Number of shots and Interval between shots is a nice touch. This gives you a quasi Continuous shooting method with the Self Timer active. The Autofocus Assist lamp still operates as before. For example, if you set Interval between shots to 3s you’ll see it wink once and then go steady. At shorter intervals it’ll come back to a steady state after taking a picture to indicate that the camera is still taking shots.

My low tech solution would be to cover the light with a small piece of black gaffer tape.

 ZapperVT's gear list:ZapperVT's gear list
Nikon Z7 Nikon Z50 Nikon AF-S DX Nikkor 35mm F1.8G Nikon AF DX Fisheye-Nikkor 10.5mm f/2.8G ED Nikon AF-S DX Micro-Nikkor 85mm f/3.5G ED VR +11 more
OP mibadt Senior Member • Posts: 1,179
Re: Z7: AF Assist Illuminator fires in MF/Timer- bug??

Thank you,

You (and Thom) are probably right!

Looks like I'll have to use the low tech tip   

-- hide signature --

Regards,
Michael Badt
Photos gallery: http://www.flickr.com/photos/mibadt/

Keyboard shortcuts:
FForum MMy threads