Sigma 30mm f/1.4 DC DN for Canon EF-M bug?

Started 3 months ago | Discussions
cheenachatze Junior Member • Posts: 40
Sigma 30mm f/1.4 DC DN for Canon EF-M bug?

Hi, everyone:

I bought the Sigma 30mm f/1.4 lens for Canon EF-M in May 2020. I do not know what is the firmware version (I do not have the Sigma USB dock). I have the Canon M6 Mk2 with firmware 1.1.0 and Canon M50 with firmware 1.1.0. I see the same issue with both cameras:

ExifTool reports the following:

LensModel: 30mm F1.4 DC DN | Contemporary 016

LensType: Sigma 56mm f/1.4 DC DN | C

The same issue happens on both bodies, with C-Raw files and with jpegs.

Does anyone else have this lens and encounters the same issue? Does it have any effect on the performance of the lens in any way?

Thanks for any input.

Canon EOS M50 (EOS Kiss M) Canon EOS M6 II Sigma 30mm F1.4 (E/EF-M mounts)
If you believe there are incorrect tags, please send us this post using our feedback form.
Alan Sh Senior Member • Posts: 2,352
Re: Sigma 30mm f/1.4 DC DN for Canon EF-M bug?
1

Umm  - you have the lens, can YOU see any issues (apart from the wrong Exif data).

Alan

 Alan Sh's gear list:Alan Sh's gear list
Canon EOS 6D Canon EOS M5 Canon EF-M 55-200mm f/4.5-6.3 IS STM Panasonic Lumix DMC-ZS40 (TZ60) Canon EOS M100 +14 more
beagle1 Forum Pro • Posts: 11,119
Re: Sigma 30mm f/1.4 DC DN for Canon EF-M bug?
1

cheenachatze wrote:

Hi, everyone:

I bought the Sigma 30mm f/1.4 lens for Canon EF-M in May 2020. I do not know what is the firmware version (I do not have the Sigma USB dock). I have the Canon M6 Mk2 with firmware 1.1.0 and Canon M50 with firmware 1.1.0. I see the same issue with both cameras:

ExifTool reports the following:

LensModel: 30mm F1.4 DC DN | Contemporary 016

LensType: Sigma 56mm f/1.4 DC DN | C

The same issue happens on both bodies, with C-Raw files and with jpegs.

Does anyone else have this lens and encounters the same issue? Does it have any effect on the performance of the lens in any way?

Thanks for any input.

I use the Sigma 30mm 1.4 on a Canon M5 with no issues

if it's just exif data I wouldn't worry about it

www.flickr.com/photos/mmirrorless

OP cheenachatze Junior Member • Posts: 40
Re: Sigma 30mm f/1.4 DC DN for Canon EF-M bug?

beagle1 wrote:

I use the Sigma 30mm 1.4 on a Canon M5 with no issues

if it's just exif data I wouldn't worry about it

www.flickr.com/photos/mmirrorless

Do you mind checking your files to see if you have the same phenomenon? Thanks.

vxcalais Regular Member • Posts: 208
Re: Sigma 30mm f/1.4 DC DN for Canon EF-M bug?

Do you have any 3rd party software like Lightroom or Affinity Photo to see if the lens profiles are picked up ? Take some shots in RAW only with vignetting and distortion and check to see if DPP4 or Affinity photo are correcting the RAW files into jpeg ? Thats all that matters. If you notice miscommunication between lens and body while in use then that it an issue...

 vxcalais's gear list:vxcalais's gear list
Sony Alpha NEX-F3 Canon EOS M6 II Sony E 18-55mm F3.5-5.6 OSS Sony E 50mm F1.8 OSS Canon EF-M 22mm f/2 STM +6 more
Keyboard shortcuts:
FForum MMy threads