EOS Utility

Started 3 months ago | Questions
Para5thbtn New Member • Posts: 1
EOS Utility

When i connect my eso5d to my computer and log on to Eos utility, i get a camera not recognized message. ???? can any one help please.

running windows 10, ACPIx64

ANSWER:
This question has not been answered yet.
tcphoto1 Senior Member • Posts: 1,125
Re: EOS Utility

I do not believe the original 5D is compatible with EOS Utility, check the website for the list of compatible bodies.

 tcphoto1's gear list:tcphoto1's gear list
Canon EOS 5D Mark IV Canon EF 50mm f/1.2L USM Canon EF 70-200mm f/2.8L IS USM Canon EF 100mm F2.8L Macro IS USM Canon EF 16-35mm F4L IS USM +10 more
John_Hoffman
John_Hoffman Senior Member • Posts: 1,917
Re: EOS Utility

Para5thbtn wrote:

When i connect my eso5d to my computer and log on to Eos utility, i get a camera not recognized message. ???? can any one help please.

running windows 10, ACPIx64

You need to go to the Canon support site for Windows Vista (x64)  and download EOS Utility 2.7.3 and see if that will work for you.

-- hide signature --

John Hoffman
Conway, NH

 John_Hoffman's gear list:John_Hoffman's gear list
Canon EOS-1D X Mark III Canon EF 100mm F2.8L Macro IS USM Canon EF 70-200mm F2.8L IS II USM Canon EF 8-15mm f/4L Fisheye USM Canon EF 24mm f/2.8 IS USM +9 more
ashton lamont
ashton lamont Contributing Member • Posts: 634
Re: EOS Utility

John_Hoffman wrote:

Para5thbtn wrote:

When i connect my eso5d to my computer and log on to Eos utility, i get a camera not recognized message. ???? can any one help please.

running windows 10, ACPIx64

You need to go to the Canon support site for Windows Vista (x64) and download EOS Utility 2.7.3 and see if that will work for you.

Yes, if you're using an older 5D such as the 5D Mark II you need to install EOS Utility 2, but for later cams such as the 5D Mark IV you need EOS Utility 3.

-- hide signature --

Pete

John_Hoffman
John_Hoffman Senior Member • Posts: 1,917
Re: EOS Utility

ashton lamont wrote:

John_Hoffman wrote:

Para5thbtn wrote:

When i connect my eso5d to my computer and log on to Eos utility, i get a camera not recognized message. ???? can any one help please.

running windows 10, ACPIx64

You need to go to the Canon support site for Windows Vista (x64) and download EOS Utility 2.7.3 and see if that will work for you.

Yes, if you're using an older 5D such as the 5D Mark II you need to install EOS Utility 2, but for later cams such as the 5D Mark IV you need EOS Utility 3.

And the version of EOSU2 that gets co-installed with EOSU3 will also not work with the 5D.

-- hide signature --

John Hoffman
Conway, NH

 John_Hoffman's gear list:John_Hoffman's gear list
Canon EOS-1D X Mark III Canon EF 100mm F2.8L Macro IS USM Canon EF 70-200mm F2.8L IS II USM Canon EF 8-15mm f/4L Fisheye USM Canon EF 24mm f/2.8 IS USM +9 more
Keyboard shortcuts:
FForum MMy threads