Reinsert memory card message?

Started 2 months ago | Discussions
Barcud Regular Member • Posts: 143
Reinsert memory card message?

Hi all. I keep getting a reinsert memory card message on my nex3. Tried different cards but keep getting the same message. Any help?

Sony Alpha NEX-3
If you believe there are incorrect tags, please send us this post using our feedback form.
OP Barcud Regular Member • Posts: 143
Re: Reinsert memory card message?

The lack of replies suggests this is not a common problem. The fact is the Nex 3 has really been a good camera for me. I've used it for all types of photography including a wedding last year with really good results. It does look like I am going to have to give up on it as this issue means in effect the camera doesn't work. As I have a number of accessories including a number of filters for the e mount lens it makes sense to get another e mount camera. A step in the right direction for me would be the A6000. Okay it's getting on a bit but I'm sure it is just as good if not more capable than my nex 3.

jjdp Contributing Member • Posts: 500
Re: Reinsert memory card message?

I've gotten this occasionally on the a6500. Reinsert more deliberately, hold it in a couple seconds before letting it slowly snap back into place. Seems to work, or maybe just coincidence. But if I got that error nonstop with multiple cards, I'd take it as a sign of malfunction. You could also try compressed air.

wb2trf Veteran Member • Posts: 3,293
Re: Reinsert memory card message?

Barcud wrote:

Hi all. I keep getting a reinsert memory card message on my nex3. Tried different cards but keep getting the same message. Any help?

If above suggestions don't work, try dampening the card contacts with lens cleaning alcohol and inserting/removing a few times.

Then try resetting the camera to factory settings.

OP Barcud Regular Member • Posts: 143
Re: Reinsert memory card message?

Coincidence? ... Last night I thought I would just put a couple of blows of air into the card reader and on placing the card back in the camera there was no message! The camera was working. If this will be permanent I don't know or maybe hit and miss?

Keyboard shortcuts:
FForum MMy threads