Godox flash firmware update

Started Jul 12, 2020 | Questions
Padi2 Junior Member • Posts: 35
Godox flash firmware update
1

I seem to be unable to update tt350s to the 1.8 firmware version. Have the dfu file, and it required ExpressZip to instal, but it says it can't open it, file was corrupted or some such thing. Connected the flash to usb and it's looking forever for a driver but can't find one.

Not sure, but I seem to be unable to use this flash without the firmware update for 2.4G wireless, or am I mistaken in this? The update enables the channel ID. It doesn't seem to work, at least not as slave unit which I have tried, with a tt685s as master.

This technology is beginning to take so much fun out of photography 😭.

I should add that I am using Win7 to attempt this update, as I've read you'd have to tweak the whole system if using win10.

ANSWER:
This question has not been answered yet.
Nikon Df
If you believe there are incorrect tags, please send us this post using our feedback form.
kli
kli Veteran Member • Posts: 4,682
Re: Godox flash firmware update
1

Try using 7Zip on the .rar archive download file. Hopefully you can then get the .dfu and PDF instructions out of the archive.

If you have got the .dfu file, then you need the G2 updater from Godox to install it.

The Godox downloads page is here:

http://www.godox.com/EN/Download.html

The link for the G2 updater is:

http://www.godox.com/EN/InstructionManual/Godox_Firmware_Update_Software_G2.rar

It should run on Windows XP, 7, 8, or 10.

The link for the latest firmware for the TT350S is here:

http://www.godox.com/EN/InstructionManual/Godox_TT350S_V1.8.rar

See also:

https://photo.stackexchange.com/questions/98901/how-do-i-troubleshoot-my-godox-firmware-updating-process

 kli's gear list:kli's gear list
Fujifilm X100T Canon EOS 5D Mark II Canon EOS 50D Panasonic Lumix DMC-GX7 Canon EF 135mm F2L USM +12 more
OP Padi2 Junior Member • Posts: 35
Re: Godox flash firmware update

Thank you! I'll try that.

OP Padi2 Junior Member • Posts: 35
Re: Godox flash firmware update
2

Thank you sooo much!!! It worked this time - what I didn't do at first was to download the G2 updater file as I didn't realise it was right on top of the other download files. I kept looking for it but missed it, and assumed it was somehow hidden in the TT350s download file. And for the zip file it automatically assumed 'ExpressZip' which then told me the file is corrupt. So, doing everything like you said above helped a lot! I've just completed the download and upgrade! Thanks again, very grateful indeed!

Keyboard shortcuts:
FForum MMy threads