SD message in M10 viewfinder

Started 4 months ago | Discussions
eliehbk Senior Member • Posts: 1,880
SD message in M10 viewfinder

Hi all,

I am would be GRATEFUL for your help with the above. I have been getting a flashing SD message in my M10’s viewfinder. I would get the frame lines and would be able to take pictures, however, the picture wouldn’t register and show up on the back screen. Furthermore, the back screen wouldn’t work. I would have to change batteries, swap SD cards, or sometimes lenses for the camera to work properly again. I tried to search on the net to find out more about the problem but couldn’t find anything useful.

did it happen to anyone of you and anyone has an advice for me?

thanks a lot and be safe.

Elie

 eliehbk's gear list:eliehbk's gear list
Leica Q2 Leica SL2 Leica M10 Leica Summilux-M 50mm f/1.4 ASPH +1 more
Leica M10
If you believe there are incorrect tags, please send us this post using our feedback form.
forceofnature
forceofnature Contributing Member • Posts: 800
Re: SD message in M10 viewfinder

I couldn't find anything in the manual about this.  Probably a silly question but, have you tried reformatting the card?  Other than that I would contact Leica.

 forceofnature's gear list:forceofnature's gear list
Sony ZV-1 Sony a7R II Leica M-P (Typ 240) Leica M10 Sony a9 +9 more
OP eliehbk Senior Member • Posts: 1,880
Re: SD message in M10 viewfinder

I actually did, and switched cards repeatedly. It goes away for a while and then comes back for no apparent reason. I turn on the camera but back screen doesn’t turn on, and SD flashes on the viewfinder. I think the M cameras had a problem with fast SD cards where they gave such error messages but I thought Leica had fixed them. I also tried using a slow card, same thing.

 eliehbk's gear list:eliehbk's gear list
Leica Q2 Leica SL2 Leica M10 Leica Summilux-M 50mm f/1.4 ASPH +1 more
RobertLysakowski Forum Member • Posts: 99
Re: SD message in M10 viewfinder

Have you seen this: https://www.l-camera-forum.com/topic/292139-leica-m10-p-turning-on-problem/

Does it ring a bell (or two)?

OP eliehbk Senior Member • Posts: 1,880
Re: SD message in M10 viewfinder
1

Exactly what’s happening to me. Thanks for sharing. I am using a 16gig SD now and the camera seems okay. I wonder why Leica can’t fix such an issue on cameras that cost 8k!!

 eliehbk's gear list:eliehbk's gear list
Leica Q2 Leica SL2 Leica M10 Leica Summilux-M 50mm f/1.4 ASPH +1 more
forceofnature
forceofnature Contributing Member • Posts: 800
Re: SD message in M10 viewfinder

RobertLysakowski wrote:

Have you seen this: https://www.l-camera-forum.com/topic/292139-leica-m10-p-turning-on-problem/

Does it ring a bell (or two)?

YIkes,  reading that thread makes me second guess my desire to purchase the M10-P.  Was hoping to get one by end of May.  Well since I will getting a new one I can do a retailer exchange more easily.

Hope the issue gets resolved for the OP.

 forceofnature's gear list:forceofnature's gear list
Sony ZV-1 Sony a7R II Leica M-P (Typ 240) Leica M10 Sony a9 +9 more
OP eliehbk Senior Member • Posts: 1,880
Re: SD message in M10 viewfinder

This is has been ongoing since years, I am not sure it will get resolved soon or ever. When I was at B&H trying out the camera, the guy asked for a slow SD card for me to try out on the camera. Now I know why!

 eliehbk's gear list:eliehbk's gear list
Leica Q2 Leica SL2 Leica M10 Leica Summilux-M 50mm f/1.4 ASPH +1 more
forceofnature
forceofnature Contributing Member • Posts: 800
Re: SD message in M10 viewfinder

eliehbk wrote:

This is has been ongoing since years, I am not sure it will get resolved soon or ever. When I was at B&H trying out the camera, the guy asked for a slow SD card for me to try out on the camera. Now I know why!

I think I have some slow ones but mostly have the fast Sony Cards. Glad there is some resolution but sheesh that M10 should be able to handle fast cards.  Its not that old a camera.

 forceofnature's gear list:forceofnature's gear list
Sony ZV-1 Sony a7R II Leica M-P (Typ 240) Leica M10 Sony a9 +9 more
RobertLysakowski Forum Member • Posts: 99
Re: SD message in M10 viewfinder

At least you know you're not alone. That sometimes brings a relief

And now you know your options: live with that or service the camera.

p.s. my 240 tricked me the other day - it would continue shooting pictures but not recording them. I only found out when I saw that LCD is stuck on the photo I took a while back. Had to switch off/on and it helped, but none of the images I took in between were recorded. I only wonder what if that happens to those Ms without LCD screen...

OP eliehbk Senior Member • Posts: 1,880
Re: SD message in M10 viewfinder
2

Like the D version, that would suck

 eliehbk's gear list:eliehbk's gear list
Leica Q2 Leica SL2 Leica M10 Leica Summilux-M 50mm f/1.4 ASPH +1 more
JDLaing50 Senior Member • Posts: 2,053
Re: SD message in M10 viewfinder

eliehbk wrote:

Hi all,

I am would be GRATEFUL for your help with the above. I have been getting a flashing SD message in my M10’s viewfinder. I would get the frame lines and would be able to take pictures, however, the picture wouldn’t register and show up on the back screen. Furthermore, the back screen wouldn’t work. I would have to change batteries, swap SD cards, or sometimes lenses for the camera to work properly again. I tried to search on the net to find out more about the problem but couldn’t find anything useful.

did it happen to anyone of you and anyone has an advice for me?

thanks a lot and be safe.

Elie

More than likely a bad SD card.

 JDLaing50's gear list:JDLaing50's gear list
Sony RX1R II Olympus PEN-F Leica M-P (Typ 240) Voigtlander 50mm F1.5 Nokton +4 more
OP eliehbk Senior Member • Posts: 1,880
Re: SD message in M10 viewfinder

I’ve tried two already.

 eliehbk's gear list:eliehbk's gear list
Leica Q2 Leica SL2 Leica M10 Leica Summilux-M 50mm f/1.4 ASPH +1 more
JDLaing50 Senior Member • Posts: 2,053
Re: SD message in M10 viewfinder

The contacts inside the camera might have a piece of lint stuck in there. Take a look.

Are you shooting in continuous mode?

 JDLaing50's gear list:JDLaing50's gear list
Sony RX1R II Olympus PEN-F Leica M-P (Typ 240) Voigtlander 50mm F1.5 Nokton +4 more
OP eliehbk Senior Member • Posts: 1,880
Re: SD message in M10 viewfinder

Never continuous. How do you check if there’s any debris inside?

 eliehbk's gear list:eliehbk's gear list
Leica Q2 Leica SL2 Leica M10 Leica Summilux-M 50mm f/1.4 ASPH +1 more
JDLaing50 Senior Member • Posts: 2,053
Re: SD message in M10 viewfinder

A couple quick puffs with a rocket blower should bring anything out.

 JDLaing50's gear list:JDLaing50's gear list
Sony RX1R II Olympus PEN-F Leica M-P (Typ 240) Voigtlander 50mm F1.5 Nokton +4 more
BrianVS Regular Member • Posts: 127
Re: SD message in M10 viewfinder

After reading the thread on the Leica Forum- it sounds like a defective board.

I would try reloading the firmware on the camera. I would also use an older 4x SD card for that function, a smaller 8gbyte card. Many of the newer cards use a number of internal tricks to get faster read/write times and are not entirely made to spec.

 BrianVS's gear list:BrianVS's gear list
Ricoh CX1 Leica M8 Leica M9 Olympus PEN E-P2 Olympus PEN E-PM1 +4 more
OP eliehbk Senior Member • Posts: 1,880
Re: SD message in M10 viewfinder
1

”Defective board” Isn't this a hardware issue then, why would Reinstalling the firmware work?

 eliehbk's gear list:eliehbk's gear list
Leica Q2 Leica SL2 Leica M10 Leica Summilux-M 50mm f/1.4 ASPH +1 more
OP eliehbk Senior Member • Posts: 1,880
Re: SD message in M10 viewfinder
1

Actually, if you read the thread till the end, you see that someone with an M10M is having the same problem. I am at a loss, and can’t fathom a luxury company that sells premium products, at premium prices, can ignore such a big, prevalent problem, and transfer the problem from one generation to the other, M10, M10P, M10M, etc...

rianVS wrote:

After reading the thread on the Leica Forum- it sounds like a defective board.

I would try reloading the firmware on the camera. I would also use an older 4x SD card for that function, a smaller 8gbyte card. Many of the newer cards use a number of internal tricks to get faster read/write times and are not entirely made to spec.

 eliehbk's gear list:eliehbk's gear list
Leica Q2 Leica SL2 Leica M10 Leica Summilux-M 50mm f/1.4 ASPH +1 more
BrianVS Regular Member • Posts: 127
Re: SD message in M10 viewfinder

eliehbk wrote:

”Defective board” Isn't this a hardware issue then, why would Reinstalling the firmware work?

I stated that the problem sounds like a defective board, not that it was definitely a defective board. Reloading firmware is something that can be done without sending the camera back to Leica and would further help isolate the problem. Anyone that works with embedded systems knows that one source of problems can be the firmware load becomes corrupt. Check for the latest update, download and reload. If nothing changes- then the problem was not that the current firmware load was somehow corrupted. It will only take 10 minutes to try, not 3 months to get the camera back from Leica.

My humorous examination of the reported M9 issue with Sandisk SD cards years ago.

https://rangefinderforum.com/modules.php?name=News&file=showarticle&threadid=109092&page=3

Except the cards failed and I never put any of the three into my M9.

The M10M is not a new generation product, and there is probably a large re-use of hardware and firmware from the M10. Whatever is causing this problem is common to the M10 and M10M. On the M9 and M Monochrom- problems such as banding could be traced to voltage regulators that were borderline on the spec.

 BrianVS's gear list:BrianVS's gear list
Ricoh CX1 Leica M8 Leica M9 Olympus PEN E-P2 Olympus PEN E-PM1 +4 more
OP eliehbk Senior Member • Posts: 1,880
Re: SD message in M10 viewfinder

Thank you so much. In order to reload the latest firmware, do I just download it again on the SD and upload it to the camera? Would the camera allow it since it has already the latest firmware?

 eliehbk's gear list:eliehbk's gear list
Leica Q2 Leica SL2 Leica M10 Leica Summilux-M 50mm f/1.4 ASPH +1 more
Keyboard shortcuts:
FForum MMy threads