Clunky Work-Around to Open raw images in Pixelmator Photo

Started 2 months ago | Discussions
RebDovid2 Regular Member • Posts: 127
Clunky Work-Around to Open raw images in Pixelmator Photo

Next week, we’re leaving for a ten-day vacation in Andalucia. I shoot raw+JPEG with my LX100M2. Wanting to be able to do some culling and light editing on my iPad, I bought a Lightning SD card reader and the Pixelmator Photo app.

Transferring a couple of images to my iPad was a snap. But to my chagrin, although Pixelmator seems to see the raw image within Photos, it’s unable to open/import the image for editing. E-mail correspondence with Pixelmator support confirmed the issue, which, because they think it’s an iOS problem, they’re reporting to Apple.

From a post at the Pixelmator forum, it may be that the problem occurs when one shoots raw+JPEG, what the poster referred to as a “stacked” image. (If I recall correctly, he was using a Sony camera.)

Disappointed, I thought I would try getting the JPEG version into Pixelmator. Although this would limit culling possibilities, it would let me play around a bit with the app, which I could use to share some photos with family and friends while still in Spain. The problem was the Pixelmator sees only the raw version within Photos.

I opened Snapseed, which seemed only to see the JPEG version. After bringing the JPEG into Snapseed, I was able to use the app’s “Open In” function to copy the JPEG to Pixelmator. When I then opened Pixelmator, I saw both the JPEG and raw images. After successfully opening the JPEG, I tried opening the raw. It worked!!!

Plainly, this is a somewhat clunky work-around. But it will give me a chance to try out my original plan.

If anyone else has a more elegant solution, I’d be grateful to learn it. Alternatively, anyone else running into this problem may benefit from my kludge.

 RebDovid2's gear list:RebDovid2's gear list
Panasonic LX100 II Google Pixel 3
Keyboard shortcuts:
FForum MMy threads