SD card doesn't work for a7iii?

Started Sep 18, 2018 | Questions
jazz280z New Member • Posts: 4
Re: SD card doesn't work for a7iii?

Over on Reddit this info may help us get Sony's attention:

Hendrixj92
So I also started experiencing this issue, so I contacted Sony. After a quick explanation of the issue, the rep found other reports of this happening. It appears to be a firmware issue with 128gb cards. They are working on it.

Weirdly enough, one of my two Lexar 128gb cards works in slot 1 but the other nor my Sandisk 128gb's don't.

Anyways, Hope this helps.

Dany74m New Member • Posts: 3
Re: SD card doesn't work for a7iii?

Same exact problem here. Just bought the camera from bh

jchng88 wrote:

I recently got a sandisk extreme pro 128gb UHS-i sd card.

My rx100v is able to detect it, but my a7iii keeps saying unable to read memory card, resinsert card slot 1. I was able to use this same card to take photos on the rx100v.

anyone else has this issue? This is a brand new a7iii

Edit: It's able to read in slot 2, but not in slot 1

Dany74m New Member • Posts: 3
Re: SD card doesn't work for a7iii?

jazz280z wrote:

Over on Reddit this info may help us get Sony's attention:

Hendrixj92
So I also started experiencing this issue, so I contacted Sony. After a quick explanation of the issue, the rep found other reports of this happening. It appears to be a firmware issue with 128gb cards. They are working on it.

Weirdly enough, one of my two Lexar 128gb cards works in slot 1 but the other nor my Sandisk 128gb's don't.

Anyways, Hope this helps.

Cool, the Sony rep told me my camera was broken, but it doesn’t look he was aware of the issue

bayindirh
bayindirh Regular Member • Posts: 395
Re: SD card doesn't work for a7iii?

jazz280z wrote:

Over on Reddit this info may help us get Sony's attention:

Hendrixj92
So I also started experiencing this issue, so I contacted Sony. After a quick explanation of the issue, the rep found other reports of this happening. It appears to be a firmware issue with 128gb cards. They are working on it.

Weirdly enough, one of my two Lexar 128gb cards works in slot 1 but the other nor my Sandisk 128gb's don't.

Anyways, Hope this helps.

I think it's something about cards' response time and camera's expectation about that response.

It's logical to think about a topology change when moving from 64 to 128GB (it's a lot of storage to have in a single module), so possibly the cards' response to commands change slightly. And this throws the first slot off, because first card is running on different code (since it's UHS-II slot).

It's a relatively easy fix from my POV, but the ball is in Sony's yard now.

 bayindirh's gear list:bayindirh's gear list
Sony a7 III Sony FE 28-70mm F3.5-5.6 OSS Sony FE 55mm F1.8 Nikon D70s Nikon AF-S DX Nikkor 18-70mm f/3.5-4.5G ED-IF +4 more
XeroJay
XeroJay Senior Member • Posts: 2,309
SanDisk 766G cards won't work

As we've discovered in other threads by comparing notes, SanDisk Extreme Pro 128Gb cards with the batch code ending in ...766G will not work in multipe cameras UHS-II slots.

 XeroJay's gear list:XeroJay's gear list
Canon EOS M6 Sony a7 III Sony a9 Canon EF 100mm F2.8L Macro IS USM Canon EF-M 22mm f/2 STM +7 more
DI_Jeff Regular Member • Posts: 193
Re: SD card doesn't work for a7iii?

As noted in other threads, I also had the same issue with a 64gb Sandisk Disk Extreme Pro purchased from Best Buy store (so I am pretty sure it is not a fake).

It seems to be linked to new Sandisk Extreme Pro Cards. I have tested both new and old cards.

I have 8 total Sandisk Extreme Pro Cards (used for multiple devices) that I tested

- One 128gb works (older card)

- My recently purchased 128gb has issue

- For the 64gb cards; 4 of my older cards have no issues; my two most recent cards have the same issue.

 DI_Jeff's gear list:DI_Jeff's gear list
Sony RX100 IV Sony a7 III NEX-5T Sony FE 24-70mm F4 OSS Sony Vario-Tessar T* FE 16-35mm F4 ZA OSS +10 more
XeroJay
XeroJay Senior Member • Posts: 2,309
Re: SD card doesn't work for a7iii?

DI_Jeff wrote:

As noted in other threads, I also had the same issue with a 64gb Sandisk Disk Extreme Pro purchased from Best Buy store (so I am pretty sure it is not a fake).

It seems to be linked to new Sandisk Extreme Pro Cards. I have tested both new and old cards.

I have 8 total Sandisk Extreme Pro Cards (used for multiple devices) that I tested

  • One 128gb works (older card)
  • My recently purchased 128gb has issue
  • For the 64gb cards; 4 of my older cards have no issues; my two most recent cards have the same issue.

Hoping you could help us out... Could you provide the last 4 digits of the batch codes for these cards and whether they work or not?

 XeroJay's gear list:XeroJay's gear list
Canon EOS M6 Sony a7 III Sony a9 Canon EF 100mm F2.8L Macro IS USM Canon EF-M 22mm f/2 STM +7 more
DI_Jeff Regular Member • Posts: 193
Re: SD card doesn't work for a7iii?
1

All Cards are Sandisk Extreme Pro UHS-I Cards

128gb - 766G - Doesn't Work

64gb - 838G - Doesn't Work

128gb - 824G - Does Work

64gb - 860G - Does Work

64gb - 127G - Does Work (2 have two of these)

I don't have access to my other 2 card at this time(in my daughters camera); one of which is another 64gb not working.

 DI_Jeff's gear list:DI_Jeff's gear list
Sony RX100 IV Sony a7 III NEX-5T Sony FE 24-70mm F4 OSS Sony Vario-Tessar T* FE 16-35mm F4 ZA OSS +10 more
bayindirh
bayindirh Regular Member • Posts: 395
Re: SD card doesn't work for a7iii?

I also have two Sandisk Extreme Pro UHS-I 64G cards which are working. Both are ending with 860G

 bayindirh's gear list:bayindirh's gear list
Sony a7 III Sony FE 28-70mm F3.5-5.6 OSS Sony FE 55mm F1.8 Nikon D70s Nikon AF-S DX Nikkor 18-70mm f/3.5-4.5G ED-IF +4 more
XeroJay
XeroJay Senior Member • Posts: 2,309
Re: SD card doesn't work for a7iii?

DI_Jeff wrote:

All Cards are Sandisk Extreme Pro UHS-I Cards

128gb - 766G - Doesn't Work

64gb - 838G - Doesn't Work

128gb - 824G - Does Work

64gb - 860G - Does Work

64gb - 127G - Does Work (2 have two of these)

I don't have access to my other 2 card at this time(in my daughters camera); one of which is another 64gb not working.

This is gold! I'm going to cross post this in the other thread where we're logging the batches.

Thanks a bunch!

 XeroJay's gear list:XeroJay's gear list
Canon EOS M6 Sony a7 III Sony a9 Canon EF 100mm F2.8L Macro IS USM Canon EF-M 22mm f/2 STM +7 more
Johnny V New Member • Posts: 17
Re: SD card doesn't work for a7iii?
1

Recently purchased two of the above Sandisk cards from Amazon with the same batch number (766G).

I can confirm: 128gb - 766G - Doesn't Work in slot One

-- hide signature --

Purchased two 128gb cards a few months ago and all work well in slot One

514G - Works
824G - Works

OP jchng88 New Member • Posts: 10
Re: SD card doesn't work for a7iii?
1

Update:

Sony service rep called me and requested me to bring both my a7iii and SD card so that their engineers can check.

I told them that it's due to the bad 766G batch. She will inform the engineers and get back to me on this. Hopefully this can be fixed with firmware

Shawn Cope Photo New Member • Posts: 2
Re: SD card doesn't work for a7iii?

Seems to be a batch issue with the Sandisk. Check this thread out.

https://briansmith.com/sony-a7-iii-warning-sandisk-128gb-extreme-pro-uhs-i-sdxc-memory-cards/

Shawn Cope Photo New Member • Posts: 2
Re: SD card doesn't work for a7iii?

XeroJay wrote:

jchng88 wrote:

Thanks for all your input.

It's definitely not counterfeit, I got it from the authorised distributor. I changed the card once at Sandisk, same thing happened to the new card. The guy at Sandisk said that someone had the exact same issue the day before. Only happens for 128gb at slot 1, 64gb is fine. 128gb at slot 2 is fine also

I then went to Sony repair centre. I tested with one of their display set in the shop, same thing happened. The a7iii slot 1 doesn't work with the Sandisk Extreme Pro 128gb. The Sony guy said that he will feedback to upper management, and he will get back to me regarding this

Edit: To add, the sandisk 128gb didn't work for the a7riii (slot 1) display set as well

Strange... My SanDisk 128Gb Extreme Pro (bought from B&H) works in slot 1 without issue.
Edit: Actually, so does my assistants. Both the same 128Gb SanDisk and A7III. Must be a card batch/camera batch thing.

Can you figure out what batch cards they are? Last 3 numbers and 1 letter on bottom of back of card.

jazz280z New Member • Posts: 4
Re: SD card doesn't work for a7iii?

Amazon sent me a replacement card for my SD card, xx824G - Works either slot.

I can confirm: 128gb - xx766G - Doesn't Work in slot One, works in slot 2 fine. Ordered Sep 30.

I'm testing writing to both cards to make sure they keep working! I hope that Sony will ensure reliable new tech and tell us what was really wrong. SanDisk has been my standard for many years hope I can know they still are. Thanks all.

jedediah New Member • Posts: 1
Re: SD card doesn't work for a7iii?

Same issue. Got cards from my local Costco (batch number ending in 762G). No problems with several older cards in slot 1, but the SDXC UHS-I card won't register in slot 1.

CitizenVectron New Member • Posts: 18
Re: SD card doesn't work for a7iii?

So what does everyone thing, should I keep the two cards I just received today (from Amazon.ca), or return them? Do you think a firmware update will fix them? And how soon can we expect one?

I am probably safer returning them as if it's more than a few weeks I probably won't be able to exchange them any more.

XeroJay
XeroJay Senior Member • Posts: 2,309
Re: SD card doesn't work for a7iii?

CitizenVectron wrote:

So what does everyone thing, should I keep the two cards I just received today (from Amazon.ca), or return them? Do you think a firmware update will fix them? And how soon can we expect one?

I am probably safer returning them as if it's more than a few weeks I probably won't be able to exchange them any more.

The safest thing to do is return the cards, though if I were to bet, I'd say Sony will find a solution and we'll see a firmware fix within a few months.

 XeroJay's gear list:XeroJay's gear list
Canon EOS M6 Sony a7 III Sony a9 Canon EF 100mm F2.8L Macro IS USM Canon EF-M 22mm f/2 STM +7 more
bayindirh
bayindirh Regular Member • Posts: 395
Re: SD card doesn't work for a7iii?

CitizenVectron wrote:

So what does everyone thing, should I keep the two cards I just received today (from Amazon.ca), or return them? Do you think a firmware update will fix them? And how soon can we expect one?

I am probably safer returning them as if it's more than a few weeks I probably won't be able to exchange them any more.

If they are one of the problematic batches, send them back. It looks like  the controllers of these cards behave a little differently, and a firmware update won't probably change anything. If nothing else, a more compatible card will be more reliable on a Sony A7III in the long run.

 bayindirh's gear list:bayindirh's gear list
Sony a7 III Sony FE 28-70mm F3.5-5.6 OSS Sony FE 55mm F1.8 Nikon D70s Nikon AF-S DX Nikkor 18-70mm f/3.5-4.5G ED-IF +4 more
CitizenVectron New Member • Posts: 18
Re: SD card doesn't work for a7iii?

Thanks, that is what I am doing. Do you have any suggestions for other UHS-I cards that are a good alternative? I don't want to go UHS-II as they are 2x the money for no return (I shoot two cards duplicate RAW, so no speed increase). What I liked about these faulty cards was the 95/90 read/write speeds. It seems that some alternatives (Lexar) are 90/20 or 90/50, which sucks.

Keyboard shortcuts:
FForum MMy threads