Plugged camera into computer, it doesn't show up

Started 5 months ago | Questions
crimsonclover New Member • Posts: 3
Plugged camera into computer, it doesn't show up

Hi, I have a FinePix S4800 and when I plug it into my MacBook, the camera does not show on my desktop, and on the camera screen it says "USB." What am I supposed to do? I wanted to copy pics off the camera this way. Thanks

ANSWER:
Fujifilm FinePix S4800
If you believe there are incorrect tags, please send us this post using our feedback form.
Labe
MOD Labe Veteran Member • Posts: 7,957
Re: Plugged camera into computer, it doesn't show up

try downloading the Fuji software.

 Labe's gear list:Labe's gear list
Fujifilm FinePix IS-1 Sony Cyber-shot DSC-RX10 Sony Alpha NEX-3 Fujifilm X-T20 Samsung Galaxy S7 edge
OP crimsonclover New Member • Posts: 3
Re: Plugged camera into computer, it doesn't show up

Thanks...I went to their site and they don't have software for the S4800, I looked at the firmware for the S4500, and it appears to be a PC file, not meant for Macs, so I guess this is not an option. I am bummed, I thought I could just plug the camera in (like my other digital cameras before) and see the pics. Guess I'll have to call them. They could not answer me via email for some reason.

Labe
MOD Labe Veteran Member • Posts: 7,957
heres What your manual says....

crimsonclover wrote:

Thanks...I went to their site and they don't have software for the S4800, I looked at the firmware for the S4500, and it appears to be a PC file, not meant for Macs, so I guess this is not an option. I am bummed, I thought I could just plug the camera in (like my other digital cameras before) and see the pics. Guess I'll have to call them. They could not answer me via email for some reason.

. Looks like you might have to use a card reader

 Labe's gear list:Labe's gear list
Fujifilm FinePix IS-1 Sony Cyber-shot DSC-RX10 Sony Alpha NEX-3 Fujifilm X-T20 Samsung Galaxy S7 edge
Labe
MOD Labe Veteran Member • Posts: 7,957
Re: Plugged camera into computer, it doesn't show up

crimsonclover wrote:

Hi, I have a FinePix S4800 and when I plug it into my MacBook, the camera does not show on my desktop, and on the camera screen it says "USB." What am I supposed to do? I wanted to copy pics off the camera this way. Thanks

Here’s the Mac software link ( you should have a disc with it on as well supplied with camera)

http://www.fujifilm.com/support/digital_cameras/software/finepix_viewer/ver36mac/

 Labe's gear list:Labe's gear list
Fujifilm FinePix IS-1 Sony Cyber-shot DSC-RX10 Sony Alpha NEX-3 Fujifilm X-T20 Samsung Galaxy S7 edge
selected answer This post was selected as the answer by the original poster.
OP crimsonclover New Member • Posts: 3
Re: Plugged camera into computer, it doesn't show up

Thanks very much. All I saw on the provided CD was the user manual.

Aberaeron Senior Member • Posts: 6,544
Re: Plugged camera into computer, it doesn't show up

crimsonclover wrote:

Hi, I have a FinePix S4800 and when I plug it into my MacBook, the camera does not show on my desktop, and on the camera screen it says "USB." What am I supposed to do? I wanted to copy pics off the camera this way. Thanks

If its like every other camera, or most other cameras, it just needs you to confirm in the camera that you are using USB. The Mac should then automatically launch Photos to the Import page where you can choose which files to upload.

I find my iMac's USB ports to be somewhat temperamental at times, along with its card reader. Sometimes it just doesn't see the device or card. You can check whether it does in finder, where it should be listed as an external device if it is detected.

 Aberaeron's gear list:Aberaeron's gear list
Fujifilm X20 Sony SLT-A57 Olympus OM-D E-M10 Panasonic Lumix DMC-G7 Olympus 7-14mm F2.8 Pro +21 more
Keyboard shortcuts:
FForum MMy threads