G1X Mark III - Lightroom Bug - Pixels on the edge

Started 8 months ago | Questions
yaxexa New Member • Posts: 11
G1X Mark III - Lightroom Bug - Pixels on the edge

Hello everyone. I just bought a Canon G1X Mark III and already have an issue with it.

When I look at the picture on the back of the camera everything seems to be fine. However when I import and look at the picture in Lightroom, there is a black band on top of the picture and some banding on the side.

Do you also have the same issue with your camera? It seems to be a bug created by Lightroom.

Thanks for your help!

Black band & banding.

ANSWER:
Twitchly
Twitchly Contributing Member • Posts: 627
Re: G1X Mark III - Lightroom Bug - Pixels on the edge
2

Yes, it’s a bug in Adobe Camera Raw. There’s been a bug report filed with Adobe and they’re looking into it. (Maybe somebody here has that link? It was posted here a while back.)

Apparently ACR isn’t trimming those pixels. You can either crop the image yourself or open it in Canon’s software (or other RAW conversion software), which does automatically crop them.

-- hide signature --

Instagram: @twitchly

 Twitchly's gear list:Twitchly's gear list
Nikon Coolpix AW120 Canon G1 X III Nikon D5300 Nikon AF-S DX Nikkor 18-200mm f/3.5-5.6G ED VR II Nikon AF Nikkor 50mm f/1.4D
Twitchly
Twitchly Contributing Member • Posts: 627
Re: G1X Mark III - Lightroom Bug - Pixels on the edge
2

Found the link:

https://www.dpreview.com/forums/post/60658194

-- hide signature --

Instagram: @twitchly

 Twitchly's gear list:Twitchly's gear list
Nikon Coolpix AW120 Canon G1 X III Nikon D5300 Nikon AF-S DX Nikkor 18-200mm f/3.5-5.6G ED VR II Nikon AF Nikkor 50mm f/1.4D
selected answer This post was selected as the answer by the original poster.
OP yaxexa New Member • Posts: 11
Re: G1X Mark III - Lightroom Bug - Pixels on the edge

Thank you very much for your feedback.

I am glad to see that it is just a bug from Lightroom. Hopefully they will fixed it soon!

landov Forum Member • Posts: 56
Re: G1X Mark III - Lightroom Bug - Pixels on the edge

Lightroom CC Classic 7.2 is out. Is problem solved ? Im on LR 6.14 so I can not check it.

 landov's gear list:landov's gear list
Canon G1 X III Nikon D500
Twitchly
Twitchly Contributing Member • Posts: 627
Re: G1X Mark III - Lightroom Bug - Pixels on the edge

landov wrote:

Lightroom CC Classic 7.2 is out. Is problem solved ? Im on LR 6.14 so I can not check it.

Not solved.

-- hide signature --

Instagram: @twitchly

 Twitchly's gear list:Twitchly's gear list
Nikon Coolpix AW120 Canon G1 X III Nikon D5300 Nikon AF-S DX Nikkor 18-200mm f/3.5-5.6G ED VR II Nikon AF Nikkor 50mm f/1.4D
Phree_ed Junior Member • Posts: 38
Re: G1X Mark III - Lightroom Bug - Pixels on the edge

Also the only bit of exif attached to the full image shows a shutter speed of 1/10000 which the camera cannot achieve. Wonder why that is??

In this forum thread the third image in the series has the same figure as a shutter speed.

https://www.dpreview.com/forums/thread/4254029

Maybe a firmware update is needed??

 Phree_ed's gear list:Phree_ed's gear list
Canon PowerShot D10 Canon PowerShot SX20 IS FinePix XP70 Canon G1 X III Canon EOS 70D +6 more
OP yaxexa New Member • Posts: 11
Re: G1X Mark III - Lightroom Bug - Pixels on the edge

landov wrote:

Lightroom CC Classic 7.2 is out. Is problem solved ? Im on LR 6.14 so I can not check it.

I tried to import some RAW after the update to Lightroom CC Classic 7.2 and can confirm that this issue has not been fixed.

Since we pay Adobe for a subscription, they don't bother anymore to fix fundamental bugs for point and shoot cameras. The issue with importing raw files from the Canon G1X Mark III is too small of a problem for them...

landov Forum Member • Posts: 56
Re: G1X Mark III - Lightroom Bug - Pixels on the edge

so I can stay with with my standalone LR 6.14

 landov's gear list:landov's gear list
Canon G1 X III Nikon D500
Keyboard shortcuts:
FForum MMy threads