RX100-M4 focus locks as soon as camera turns on; can't refocus

Started 4 months ago | Discussions
pan2 Forum Member • Posts: 52
RX100-M4 focus locks as soon as camera turns on; can't refocus

I have a 1.5 year-old RX100-M4. Since yesterday, when the camera turns on it immediately focus locks (as though I've half-pressed the shutter) and there's no way to get it to unlock or refocus. Even after taking a picture the focus remains locked to its original focus. It's as if the camera thinks the shutter is half-pressed at all times. (I've tried removing/replacing the battery and recharging it.)

Anyone else experienced this or have any suggestions on how to fix it?

The camera is out of warranty but still covered by my credit card's extended warranty. It looks like standard Sony warranty service is through Precision Camera and, if the Yelp reviews are accurate, they are terrible. Any suggestions on where to have this repaired? I'm in the Bay Area (Mountain View, CA) in case anyone has local suggestions.

sludge21017
sludge21017 Regular Member • Posts: 430
Re: RX100-M4 focus locks as soon as camera turns on; can't refocus

Do you feel the half press tension on the shutter button?

OP pan2 Forum Member • Posts: 52
Re: RX100-M4 focus locks as soon as camera turns on; can't refocus

Yes I do. Physically the button does not seem to be pressed.

sludge21017
sludge21017 Regular Member • Posts: 430
Re: RX100-M4 focus locks as soon as camera turns on; can't refocus

Does manual focus mode work?

Go into custom settings and see if your center button inside the wheel is set to standard focus.  Will that re-focus?

OP pan2 Forum Member • Posts: 52
Re: RX100-M4 focus locks as soon as camera turns on; can't refocus

sludge21017 wrote:

Does manual focus mode work?

Go into custom settings and see if your center button inside the wheel is set to standard focus. Will that re-focus?

Manual focus works though it's pretty painful to use.

Programming the button to change focus modes (which I think is what you're suggesting) is a neat idea but ran into problems because when the camera is stuck in half-shutter-pressed mode many of the buttons don't work. E.g., the zoom switches and the Menu button don't work, and it seems the center button, along with some of the other programmable buttons, don't work either. (Once in a while I can snap the camera out of its focus lock mode by toggling the mode wheel --- doesn't always work --- and only then can I even get to the menu.)

sludge21017
sludge21017 Regular Member • Posts: 430
Re: RX100-M4 focus locks as soon as camera turns on; can't refocus
OP pan2 Forum Member • Posts: 52
Re: RX100-M4 focus locks as soon as camera turns on; can't refocus

Yep. Saw that thread when I was searching for my problem. Unfortunately, an old thread with no resolution given.

sludge21017
sludge21017 Regular Member • Posts: 430
Re: RX100-M4 focus locks as soon as camera turns on; can't refocus

Have you tried other odd things to get into the menu - like hitting the play button and then going to the menu? Does that work?

If that button is really jacked - if it thinks it is half pressed - the lens would extend and you would probably end up outside of play.

Also remove the SD CARD and try everything without.

Bill Borne
Bill Borne Forum Pro • Posts: 33,418
Re: RX100-M4 focus locks as soon as camera turns on; can't refocus
1

Menu/ reset

-- hide signature --

"Life's Too Short to Worry about the BS!"
So I Choose my Battles
Click for Wild Man's Photos
Rx10 IV

 Bill Borne's gear list:Bill Borne's gear list
Sony Cyber-shot DSC-R1 Sony Cyber-shot DSC-HX400V Sony RX100 III Sony Cyber-shot DSC-H5 Sony Cyber-shot DSC-F828 +3 more
OP pan2 Forum Member • Posts: 52
Re: RX100-M4 focus locks as soon as camera turns on; can't refocus

Tried that. Didn't help.

OP pan2 Forum Member • Posts: 52
Re: RX100-M4 focus locks as soon as camera turns on; can't refocus

It's kind of unpredictable. I've tried a lot of things like you've suggested and nothing works reliably, but sometimes I get lucky. E.g., sometimes when I turn the camera on it doesn't immediately focus lock, and sometimes I can get to the menu from the image review after taking a picture. But in the majority of cases nothing works.

Bill Borne
Bill Borne Forum Pro • Posts: 33,418
Re: RX100-M4 focus locks as soon as camera turns on; can't refocus

pan2 wrote:

Tried that. Didn't help.

I'd try squirting some electrical contact cleaner in the shutter button?

As a last resort give a couple hard whacks on a table?

-- hide signature --

"Life's Too Short to Worry about the BS!"
So I Choose my Battles
Click for Wild Man's Photos
Rx10 IV

 Bill Borne's gear list:Bill Borne's gear list
Sony Cyber-shot DSC-R1 Sony Cyber-shot DSC-HX400V Sony RX100 III Sony Cyber-shot DSC-H5 Sony Cyber-shot DSC-F828 +3 more
OP pan2 Forum Member • Posts: 52
Re: RX100-M4 focus locks as soon as camera turns on; can't refocus

Thanks for the tip. I tried some Caig Deoxit (D5S) spray. I sprayed some into the button from above and also pulled the back off the camera and tried to spray some in the general direction of the shutter button. (It's not exactly accessible by just removing the back and I didn't want to fully disassemble the thing, so not sure how effective this was.) In any case, the camera is definitely better. Not perfect, but by prodding the shutter button a bit I can usually make it unlock its focus. Not sure yet whether to try more of the same, try to take it apart even further and really get to the button, or send it to Precision Camera. (This last option is worrying because the problem is a little harder to surface now and I'm worried they'll assert that nothing is wrong with the camera; my impression of them so far has not been good.)

Keyboard shortcuts:
FForum MMy threads