Anybody has problem with Hot-Shoe on GX7 ?

Started Jan 13, 2014 | Questions
Maxster New Member • Posts: 19
Anybody has problem with Hot-Shoe on GX7 ?
1

Seems like since I did the last firmware update (1.2) I can't trigger any flash or flash trigger from my hot shoe. Anybody else having this problem ?

I have a Yongnuo 460-II flash and a Nissin Di866, plus I have Pixel Pawn Triggers.

They all worked fine not long ago, I'm trying to see if the hotshoe is defective or something that the firmware update did.

Thanks

ANSWER:
This question has not been answered yet.
Panasonic Lumix DMC-GX7
If you believe there are incorrect tags, please send us this post using our feedback form.
uRebel Rob Senior Member • Posts: 1,315
Re: Anybody has problem with Hot-Shoe on GX7 ?

Did you figure out your issue? I'm assuming it's not something like you're in silent mode, or flash is forced off, right?

FWIW, I didn't have any problems after updating the firmware to 1.2, with my Yongnuo 560-II (or my Panasonic FL-500), so it's not a firmware thing.

 uRebel Rob's gear list:uRebel Rob's gear list
Panasonic Lumix DMC-GX7 Pentax K-1 Panasonic Lumix G Vario 100-300mm F4-5.6 OIS Olympus M.Zuiko Digital ED 60mm 1:2.8 Macro Pentax FA 28-105mm F3.5-5.6 +17 more
MikeInRomsey
MikeInRomsey Regular Member • Posts: 292
Re: Anybody has problem with Hot-Shoe on GX7 ?

If you want to test the software update then you could do a factory reset on the camera which should remove any firmware updates I would guess? Then test the flash operation and if it works OK then re-apply the firmware update and test again.

-- hide signature --

Mike Wenman
http://www.flickr.com/photos/mikeinromsey/?details=1
Canon S40 -> Canon G9 -> Panasonic GX7

 MikeInRomsey's gear list:MikeInRomsey's gear list
Panasonic Lumix G Vario 14-42mm F3.5-5.6 ASPH OIS Panasonic Lumix G Vario 14-140mm F3.5-5.6 ASPH. / Power O.I.S Panasonic 20mm F1.7 II
OP Maxster New Member • Posts: 19
Re: Anybody has problem with Hot-Shoe on GX7 ?

I already tried a factory reset but it just resets your settings, I don't think its possible to downgrade firmware.

I don't think it is because of a silent mode because the pop flash works fine...

Very weird.

BPmonahan New Member • Posts: 3
Re: Anybody has problem with Hot-Shoe on GX7 ?

Hello: This issue has happened to me with the GX 7 and Nissin 466 Flash.  My flash works correctly on the GX1 .  Did you find a solution to the problem of the GX7 hotshoe not working to trigger the flash ?

Thanks

Guy Parsons
Guy Parsons Forum Pro • Posts: 27,106
Re: Anybody has problem with Hot-Shoe on GX7 ?

BPmonahan wrote:

Hello: This issue has happened to me with the GX 7 and Nissin 466 Flash. My flash works correctly on the GX1 . Did you find a solution to the problem of the GX7 hotshoe not working to trigger the flash ?

Thanks

Usually the issue is using the electronic shutter, that apparently disables the flash. Not a Panasonic user so not 100% certain.

Regards...... Guy

 Guy Parsons's gear list:Guy Parsons's gear list
Olympus PEN E-P5
Jacques Cornell
Jacques Cornell Veteran Member • Posts: 8,600
Eshutter = no flash

Guy Parsons wrote:

BPmonahan wrote:

Hello: This issue has happened to me with the GX 7 and Nissin 466 Flash. My flash works correctly on the GX1 . Did you find a solution to the problem of the GX7 hotshoe not working to trigger the flash ?

Thanks

Usually the issue is using the electronic shutter, that apparently disables the flash. Not a Panasonic user so not 100% certain.

Regards...... Guy

You are correct. Electronic shutter does not work with flash. This is because it takes the sensor much longer to read out than the duration of the flash. With G6 and GX7, when you have eshutter  enabled, the camera will not trigger a flash.

-- hide signature --

jacquescornell.com

 Jacques Cornell's gear list:Jacques Cornell's gear list
Panasonic Lumix DMC-GX7 Panasonic Lumix G Vario 7-14mm F4 ASPH Olympus M.Zuiko Digital 45mm F1.8 Olympus M.Zuiko Digital ED 12mm 1:2 Panasonic 12-35mm F2.8 +29 more
BPmonahan New Member • Posts: 3
Re: Eshutter = no flash

I am grateful for your reply , but in my case the electronic shutter is not enabled. The hotshoe will not trigger the flash.any further suggestions ?

thank you

uRebel Rob Senior Member • Posts: 1,315
Re: Silent mode?

BPmonahan wrote:

I am grateful for your reply , but in my case the electronic shutter is not enabled. The hotshoe will not trigger the flash.any further suggestions ?

thank you

Are you using Silent mode? That disables flash, too (as well as enable eshutter).

 uRebel Rob's gear list:uRebel Rob's gear list
Panasonic Lumix DMC-GX7 Pentax K-1 Panasonic Lumix G Vario 100-300mm F4-5.6 OIS Olympus M.Zuiko Digital ED 60mm 1:2.8 Macro Pentax FA 28-105mm F3.5-5.6 +17 more
WC8 Junior Member • Posts: 45
Re: Eshutter = no flash

Did you ever find the solution? I cant get my flash to work either. Wonder if I should just get the wireless lumix flash to circumvent the hotshoe.

geoffmorris New Member • Posts: 1
Re: Anybody has problem with Hot-Shoe on GX7 ?

I have the same problem and did the same troubleshooting steps as were noted in all of the replies on this thread. My camera's firmware rev is 1.3.

My Metz and my radio remote triggers all work fine on my DMC-FZ70 so...

I believe it is a defective hotshoe. I went online with Panasonic Tech Support and they've advised me to send it in for repair.

Best of luck!

aljudy Senior Member • Posts: 1,063
Re: Anybody has problem with Hot-Shoe on GX7 ?

GX7 that I bought less than a month ago came with v1.3, and my Nissin Di466 triggers just fine. I had not tried it before seeing this post... Al

-- hide signature --

Amateur Photographer of family mainly

 aljudy's gear list:aljudy's gear list
Panasonic Lumix DMC-GH2 Panasonic Lumix DMC-GH4 Panasonic Lumix DMC-GX85 Panasonic Leica D Summilux Asph 25mm F1.4 Panasonic Lumix G Vario 100-300mm F4-5.6 OIS +9 more
Samalamb New Member • Posts: 18
Re: Anybody has problem with Hot-Shoe on GX7 ?

I recently tried using my Yongnuo flash trigger and flash with the gx7 but it would not work. Weird because it was fine a month ago. Not the triggers or flash because they all work with my OMD EM5. Tried resetting - nothing. Electronic shutter and silent mode are off... anyone run across a solution?

WC8 Junior Member • Posts: 45
Re: Anybody has problem with Hot-Shoe on GX7 ?

My remotes would not work with a 3rd party lens.  I bought the Lumix Flash and that also didn't work in the hotshoe.  It works wirelessly, but it's a lousy wireless flash in my experience.

My camera was brand new.  I'd love to send it in to Panasonic for a fix, but with a 1 year old as my subject, the multi-month wait probably would get glares from mom.

Thanks Panasonic!

Samalamb New Member • Posts: 18
Re: Anybody has problem with Hot-Shoe on GX7 ?

WC8 wrote:

My remotes would not work with a 3rd party lens. I bought the Lumix Flash and that also didn't work in the hotshoe. It works wirelessly, but it's a lousy wireless flash in my experience.

My camera was brand new. I'd love to send it in to Panasonic for a fix, but with a 1 year old as my subject, the multi-month wait probably would get glares from mom.

Thanks Panasonic!

Yeah, it's frustrating because it worked before!!!! I can't pinpoint what has changed besides a hotshoe malfunction... Sucks

Jacques Cornell
Jacques Cornell Veteran Member • Posts: 8,600
Firmware?

Samalamb wrote:

WC8 wrote:

My remotes would not work with a 3rd party lens. I bought the Lumix Flash and that also didn't work in the hotshoe. It works wirelessly, but it's a lousy wireless flash in my experience.

My camera was brand new. I'd love to send it in to Panasonic for a fix, but with a 1 year old as my subject, the multi-month wait probably would get glares from mom.

Thanks Panasonic!

Yeah, it's frustrating because it worked before!!!! I can't pinpoint what has changed besides a hotshoe malfunction... Sucks

Is firmware up to date?

-- hide signature --

The way to make a friend is to act like one.
www.jacquescornell.photography

 Jacques Cornell's gear list:Jacques Cornell's gear list
Panasonic Lumix DMC-GX7 Panasonic Lumix G Vario 7-14mm F4 ASPH Olympus M.Zuiko Digital 45mm F1.8 Olympus M.Zuiko Digital ED 12mm 1:2 Panasonic 12-35mm F2.8 +29 more
Samalamb New Member • Posts: 18
Re: Firmware?

Jacques Cornell wrote:

Samalamb wrote:

WC8 wrote:

My remotes would not work with a 3rd party lens. I bought the Lumix Flash and that also didn't work in the hotshoe. It works wirelessly, but it's a lousy wireless flash in my experience.

My camera was brand new. I'd love to send it in to Panasonic for a fix, but with a 1 year old as my subject, the multi-month wait probably would get glares from mom.

Thanks Panasonic!

Yeah, it's frustrating because it worked before!!!! I can't pinpoint what has changed besides a hotshoe malfunction... Sucks

Is firmware up to date?

-- hide signature --

The way to make a friend is to act like one.
www.jacquescornell.photography

I'm pretty sure it is up to date. Version 1.3

dinoSnake Senior Member • Posts: 2,356
Re: Anybody has problem with Hot-Shoe on GX7 ?
1

WC8 wrote:

My remotes would not work with a 3rd party lens. I bought the Lumix Flash and that also didn't work in the hotshoe. It works wirelessly, but it's a lousy wireless flash in my experience.

My camera was brand new. I'd love to send it in to Panasonic for a fix, but with a 1 year old as my subject, the multi-month wait probably would get glares from mom.

Thanks Panasonic!

Yes, it is a failed hot shoe, it happened to me last month.

It won't take a month to come back from Panasonic service in Texas, I got my GX7 there and back within 2 weeks (shipped out to Texas UPS Next Day Air).  They were surprisingly quick and seemed to do a very nice job.

Keyboard shortcuts:
FForum MMy threads