RX100 Control Ring Not Working?

Started Nov 10, 2012 | Questions
Shop cameras & lenses ▾
Franks38 Regular Member • Posts: 107
RX100 Control Ring Not Working?
2

The control ring on my Sony RX100 has stopped working...I checked to see if it was on; it was set at Standard but no settings show up on the LCD when I turn it in any mode (PASM). I switched the control ring setting to Shutter Speed, but again no setting options were displayed in any mode. I checked Friedman's book but didn't see any suggestions...I assume the problem is some setting I have in the camera, but I can't think of any changes I made that would stop the control ring from showing information...the ring turns as usual.  I appreciate any suggestions...

ANSWER:
Sony RX100
If you believe there are incorrect tags, please send us this post using our feedback form.
Marti58
Marti58 MOD Forum Pro • Posts: 20,358
did you try a reset to factory defaults ?..nt
1
-- hide signature --

*All my Post Processing is done with Capture NX2*
Flickr Photo's
Galleries on DPR

 Marti58's gear list:Marti58's gear list
Olympus M.Zuiko Digital 45mm F1.8 Nikon 1 Nikkor 10mm f/2.8 Panasonic Lumix DMC-ZS1 Samsung HZ35W Canon PowerShot S95 +34 more
selected answer This post was selected as the answer by the original poster.
Franks38 OP Regular Member • Posts: 107
Re: RX100 Control Ring Not Working?

Problem Solved--RESET the camera to the default settings...so it was some kind of software glitch and not a mechanical problem...I dropped a note to Gary Friedman asking if his book had a solution...he replied quickly that if it were a software problem a RESET would return the control ring operation to normal...if not, then I had a mechanical problem.  Fortunately, it turned out to be software. Many thanks to Gary Friedman....Frank

Franks38 OP Regular Member • Posts: 107
Re: did you try a reset to factory defaults ?..nt

Thanks...Gary Friedman suggested that and it worked...hadn't occurred to me...thank you for the reply...Frank

Marti58
Marti58 MOD Forum Pro • Posts: 20,358
Re: did you try a reset to factory defaults ?..nt

Franks38 wrote:

Thanks...Gary Friedman suggested that and it worked...hadn't occurred to me...thank you for the reply...Frank

i dont own the camera or the book but often thats a good way to start with any camera.

anyhow glad it solved your problem.

cheers Marti

-- hide signature --

*All my Post Processing is done with Capture NX2*
Flickr Photo's
Galleries on DPR

 Marti58's gear list:Marti58's gear list
Olympus M.Zuiko Digital 45mm F1.8 Nikon 1 Nikkor 10mm f/2.8 Panasonic Lumix DMC-ZS1 Samsung HZ35W Canon PowerShot S95 +34 more
gp photo Junior Member • Posts: 43
Re: RX100 Control Ring Not Working?

I hate to say this but I also had a problem with the control ring not working properly.  If I am in for example P,A,S, or M mode, no matter what I change the control ring to in the menu, it stays on focus.  I was in New York for the photo show and showed it to a guy at the Sony booth who was very familiar with the camera.  He couldn't make it work properly either so he reset the camera and it worked for a while but is now stuck on focus again.  Does anyone from Sony monitor these forums?  Otherwise I love the camera and hope this if fixed with a firmware update.

 gp photo's gear list:gp photo's gear list
Sony Cyber-shot DSC-RX10 Sony Cyber-shot DSC-RX10 III Sony a77 II
Marti58
Marti58 MOD Forum Pro • Posts: 20,358
you and franks...

are the first who seem to report this as far as i recall, so lets see if franks.. one keeps working as it should.

a FW fix based on one user is not likely.

-- hide signature --

*All my Post Processing is done with Capture NX2*
Flickr Photo's
Galleries on DPR

 Marti58's gear list:Marti58's gear list
Olympus M.Zuiko Digital 45mm F1.8 Nikon 1 Nikkor 10mm f/2.8 Panasonic Lumix DMC-ZS1 Samsung HZ35W Canon PowerShot S95 +34 more
walker29 New Member • Posts: 1
Re: RX100 Control Ring Not Working?
1

Focus Mode > DMF and/or MF Assist > On can have an effect on the control ring not doing what you set it to do under Control Ring.

SilentMountain New Member • Posts: 1
Re: RX100 Control Ring Not Working?

walker29 wrote:

Focus Mode > DMF and/or MF Assist > On can have an effect on the control ring not doing what you set it to do under Control Ring.

This fixed the problem for me. While messing around with the Fn button settings, I set Focus Mode to DMF, and this disabled the A/S/P Mode Control Ring Functions. Choosing another Focus Mode re-enabled the functions. Much better than a system reset!

DidierML New Member • Posts: 1
Re: RX100 Control Ring Not Working?

I have a similar problem. I bought a refurbished one and the control ring just don't work. However, the display shows his "function". I got no results no matter what option I chose in the settings. I tried restoring the factory settings - without success... I'm a little sad, cause this is a really great camera.

gp photo Junior Member • Posts: 43
Re: RX100 Control Ring Not Working?

thanks for your post.  It is a great camera and I keep having to reset it (and lose my saved settings) to get the control ring to work.  Obviously there is also another problem since you are experiencing something different.  Hopefully Sony will notice and issue a firmware update for the RX100.  we can't be the only ones experiencing problems.

 gp photo's gear list:gp photo's gear list
Sony Cyber-shot DSC-RX10 Sony Cyber-shot DSC-RX10 III Sony a77 II
herojig
herojig New Member • Posts: 5
Re: RX100 Control Ring Not Working?

gp photo wrote:

I hate to say this but I also had a problem with the control ring not working properly. If I am in for example P,A,S, or M mode, no matter what I change the control ring to in the menu, it stays on focus. I was in New York for the photo show and showed it to a guy at the Sony booth who was very familiar with the camera. He couldn't make it work properly either so he reset the camera and it worked for a while but is now stuck on focus again. Does anyone from Sony monitor these forums? Otherwise I love the camera and hope this if fixed with a firmware update.

Same problem here, just got mine last week and today it locked up and I had to reset to get the control ring working again.

 herojig's gear list:herojig's gear list
Canon PowerShot G10 Sony RX100 Canon EOS 7D
herojig
herojig New Member • Posts: 5
Re: you and franks...

How about two?

 herojig's gear list:herojig's gear list
Canon PowerShot G10 Sony RX100 Canon EOS 7D
gp photo Junior Member • Posts: 43
Re: RX100 Control Ring Not Working?

Thanks!

 gp photo's gear list:gp photo's gear list
Sony Cyber-shot DSC-RX10 Sony Cyber-shot DSC-RX10 III Sony a77 II
herojig
herojig New Member • Posts: 5
Re: RX100 Control Ring Not Working?

thx for that, saved me from a second reset!

 herojig's gear list:herojig's gear list
Canon PowerShot G10 Sony RX100 Canon EOS 7D
Keyboard shortcuts:
FForum MMy threads