60D won't fire external flashes in live view!

Started Feb 2, 2011 | Discussions
Shop cameras & lenses ▾
Johan01 Regular Member • Posts: 459
60D won't fire external flashes in live view!

I ran into this problem. Live view was not firing the hotshoe.

Did some searching to find this is caused by silent mode being activated.

Would have never guessed.

Seems this happens on all Canon slr models.

Why?

ScratchDisk Veteran Member • Posts: 3,270
Re: 60D won't fire external flashes in live view!

I'm not sure but one possible explanation is as follows;

Normally, pre-flashes are fired when the mirror is down. Generally with live view the mirror is up, and when not in Silent mode, the mirror drops briefly (& noiseily) just for the pre-flashes, and then rises (noiseily) almost immediately again for the capture.

Perhaps silent mode omits the mirror movements & therefore stops the option of 'pre-flashes'.

Karl Gnter Wnsch Forum Pro • Posts: 11,408
Re: 60D won't fire external flashes in live view!

Johan01 wrote:

Why?

Because the flash synchronisation is physically linked to the first shutter curtain - which is replaced by an electronic first shutter curtain in silent mode...
--
regards
Karl Günter Wünsch

 Karl Gnter Wnsch's gear list:Karl Gnter Wnsch's gear list
Canon EOS 7D Mark II
Johan01 OP Regular Member • Posts: 459
Re: 60D won't fire external flashes in live view!

that's what I suspected eventually. Thanks for the info guysl.

Still seems strange that they would allow this design ever since the first live view cameras.

Silent mode isn't worth having o anyways, so whatever. I'll live with it.

Karl Gnter Wnsch wrote:

Johan01 wrote:

Why?

Because the flash synchronisation is physically linked to the first shutter curtain - which is replaced by an electronic first shutter curtain in silent mode...
--
regards
Karl Günter Wünsch

photofool Forum Member • Posts: 69
Re: 60D won't fire external flashes in live view!

Mine works fine.

 photofool's gear list:photofool's gear list
Samsung NX200
LiSkynden
LiSkynden Regular Member • Posts: 199
Re: 60D won't fire external flashes in live view!

photofool wrote:

Mine works fine.

Same here.
Here's mine, with 430EXII ... Silent mode 1

http://s1033.photobucket.com/albums/a414/lindon4/?action=view¤t=60Dexternalflash.mp4

 LiSkynden's gear list:LiSkynden's gear list
Canon PowerShot A310 Canon PowerShot A650 IS Canon PowerShot A80 Canon PowerShot S5 IS Canon PowerShot G5 X +5 more
Karl Gnter Wnsch Forum Pro • Posts: 11,408
Re: 60D won't fire external flashes in live view!

Johan01 wrote:

Silent mode isn't worth having o anyways, so whatever. I'll live with it.

Sorry to disagree but the silent mode is highly desirable as a mirror lock up replacement which improves significantly on the functionality of MLU (preview of what is happening to your subject movement and less mechanical movement when taking the shot yield superior results).
--
regards
Karl Günter Wünsch

 Karl Gnter Wnsch's gear list:Karl Gnter Wnsch's gear list
Canon EOS 7D Mark II
Johan01 OP Regular Member • Posts: 459
Re: 60D won't fire external flashes in live view!

Interesting. I wonder if the camera is actually using the hotshoe or wireless system to trigger your Canon flash? Mine does not trigger the 3rd party gear I have. I have read plenty of posts about other Canons having the same issue, so I guess selling the 60D would not help much if I wanted to.

I have done some tests on my Manfrotto and Giottos heavy duty tripod setup and don't get any vibration in my images from the shutter.

I am happy now with the way it works.

LiSkynden wrote:

photofool wrote:

Mine works fine.

Same here.
Here's mine, with 430EXII ... Silent mode 1

http://s1033.photobucket.com/albums/a414/lindon4/?action=view¤t=60Dexternalflash.mp4

LiSkynden
LiSkynden Regular Member • Posts: 199
Re: 60D won't fire external flashes in live view!

Johan01 wrote:

Interesting. I wonder if the camera is actually using the hotshoe or wireless system to trigger your Canon flash? Mine does not trigger the 3rd party gear I have. I have read plenty of posts about other Canons having the same issue, so I guess selling the 60D would not help much if I wanted to.

This is pretty interesting indeed, but i dont think the flash is triggered by the wireless system ... i mean you have to enable the wireless system from the menu and i didnt have it enabled, and also, you have to have the pop up flash up to trigger the external flash. (at least in 60D)

What about the other EOS's with LiveView? Do they fire the Canon flashes in?

 LiSkynden's gear list:LiSkynden's gear list
Canon PowerShot A310 Canon PowerShot A650 IS Canon PowerShot A80 Canon PowerShot S5 IS Canon PowerShot G5 X +5 more
Karl Gnter Wnsch Forum Pro • Posts: 11,408
Re: 60D won't fire external flashes in live view!

LiSkynden wrote:

What about the other EOS's with LiveView? Do they fire the Canon flashes in?

Canon flash guns are not the problem here - they are properly detected and thus the silent mode is disabled in live view automatically. The problem are third party flash guns that are connected to the PC-sync socket...
--
regards
Karl Günter Wünsch

 Karl Gnter Wnsch's gear list:Karl Gnter Wnsch's gear list
Canon EOS 7D Mark II
Satwant New Member • Posts: 17
Re: 60D won't fire external flashes in live view!

I've encountered the same problem with my 550D. In Live view it won't trigger my radio triggers (ebay & elinchrom skyport or even the Yongnou's ST-E2).

Don't think my 550D has a silent mode.

Johan01 OP Regular Member • Posts: 459
Re: 60D won't fire external flashes in live view!

Satwant wrote:

I've encountered the same problem with my 550D. In Live view it won't trigger my radio triggers (ebay & elinchrom skyport or even the Yongnou's ST-E2).

Don't think my 550D has a silent mode.

Your camera likely already has silent mode set by default, which would cause your issue. Without silent mode, the SLR takes a long time to fire off the actual picture.

Unfortunately I don't see any info on the net about switching it out of silent mode so the mirror causes the flash circuit to fire.

IT's a really pathetic design flaw, IMO. Canon can do better...

John Gray Junior Member • Posts: 41
Re: 60D won't fire external flashes in live view!

Many thanks for info re silent mode. My 60D came back from the repairers, where I was having the rubber grips replaced as they had started to come away and I guess they reset the camera. I couldn't figure out yesterday at all why it wasn't triggering my studio flashes using live view as I had always done before. Sure enough silent mode was enabled and that was the issue, would never have guessed that so thanks again to contributors here for info.

 John Gray's gear list:John Gray's gear list
Sony RX100 II Leica C Fujifilm XQ1 Panasonic Lumix DMC-ZS40 (TZ60) Canon EOS 60D +6 more
Keyboard shortcuts:
FForum MMy threads