Sigma 10-20 doesn't focus in live view on D7000

Started Nov 5, 2010 | Discussions
bluenoser23
bluenoser23 Senior Member • Posts: 2,032
My Sigma 10-20 with AF in LV

I wonder why? In LV mode, I tested out AF in Full time and Single Servo in AF-area mode - normal (both work). I'm using the MB-D11 grip (can't see how that would make a difference).

I tested this out at various distances from a few inches to several feet - AF locks focus in LV no problem.

Sorry if I'm perhaps I'm talking about something different. My Sigma SN is in the 2252xxx range.
--
James

 bluenoser23's gear list:bluenoser23's gear list
Canon PowerShot A95 Canon PowerShot SD800 IS Canon PowerShot S3 IS Canon PowerShot S95 Nikon D40 +13 more
jtra Contributing Member • Posts: 947
Re: My Sigma 10-20 with AF in LV

bluenoser23 wrote:

I wonder why? In LV mode, I tested out AF in Full time and Single Servo in AF-area mode - normal (both work). I'm using the MB-D11 grip (can't see how that would make a difference).

I tested this out at various distances from a few inches to several feet - AF locks focus in LV no problem.

Sorry if I'm perhaps I'm talking about something different. My Sigma SN is in the 2252xxx range.

I have tried my Sigma 30 on friend's D7000 and it did not focus in live view. It has sn below the number other poster wrote.

Maybe firmware update of D7000 solved the issue. I don't know if friend's was updated.
Which version of firmware do you have?

bluenoser23
bluenoser23 Senior Member • Posts: 2,032
Re: My Sigma 10-20 WILL AF in LV

jtra wrote:

bluenoser23 wrote:

I wonder why? In LV mode, I tested out AF in Full time and Single Servo in AF-area mode - normal (both work). I'm using the MB-D11 grip (can't see how that would make a difference).

I tested this out at various distances from a few inches to several feet - AF locks focus in LV no problem.

Sorry if I'm perhaps I'm talking about something different. My Sigma SN is in the 2252xxx range.

I have tried my Sigma 30 on friend's D7000 and it did not focus in live view. It has sn below the number other poster wrote.

Maybe firmware update of D7000 solved the issue. I don't know if friend's was updated.
Which version of firmware do you have?

Hi. I have the latest firmware update and confess to not having tried the Sigma lens in live view prior to the firmware release.

-- hide signature --

James

 bluenoser23's gear list:bluenoser23's gear list
Canon PowerShot A95 Canon PowerShot SD800 IS Canon PowerShot S3 IS Canon PowerShot S95 Nikon D40 +13 more
John_I Veteran Member • Posts: 6,361
Re: Sigma 10-20 doesn't focus in live view on D7000

The Big One wrote:

Has anyone else experienced this? Just tried last night, AF does not work (it tries to focus, but always ends up out of focus). Focus through the viewfinder is flawless.

Not a big deal, as I don't think that live view focus is worth much anyway, but still a bit annoying. Anyone else have this lens with the D7000 who can confirm?
http://photos.digitalcave.ca

Good news: Tokina 11-16 mm focuses fast in LV.

Not so good news: Same problem with older Sigma 150-500 OS. Fine with viewfinder but not with live view. Not a problem in practice as I never use this lens with live view.
--
John from Toronto
JBIPix Photoblog - http://jbipix.com

RichardBrown
RichardBrown New Member • Posts: 2
Re: Sigma 10-20 doesn't focus in live view on D7000

Good Day Everyone.. I know this post is old but I just grabbed a 20mm 1.8 Sigma. I am having the opposite, LIVE view is almost tack but through viewfinder it just will not focus anywhere near it. At infinity, its ok but 5ft in front I have to manually focus.. any ideas?

Thanks

Rich Brown

Keyboard shortcuts:
FForum MMy threads