How to prevent dialog box to appear in action

Started Sep 22, 2010 | Discussions
ccarrier Senior Member • Posts: 1,155
How to prevent dialog box to appear in action

Hi,

I have Photoshop CS5.

I have an action that insert my signature automatically at the bottom of my picture.

It's really simple. 2 steps : Make texte layer, then set layer styles of current layer.
I duplicated it, because I wanted to have a different layer style.

I went in the new action, selecte the layer style step, then clicked on "record again" to change it and then "OK".

Now each time I play that new action, the dialog box of the layer style keeps opening. I don't want that and it doesn't do it in my old action.

The "toggle dialog on/off" is set to off for this step and for the whole action. Still, that dialog box keeps poping up.

Is there something I'm missing ?

Thank you!
--
Claude Carrier

 ccarrier's gear list:ccarrier's gear list
Fujifilm FinePix 2600 Zoom Fujifilm FinePix F31fd Fujifilm X100S Nikon D300S Nikon D750 +7 more
Ralph Ramirez Veteran Member • Posts: 7,056
Re: How to prevent dialog box to appear in action

I am not 100% sure of this but if you click on the arrow in the upper right corner of the actions palette then select "Playback Options" then check "accelerated" in the pop up window and that should do it..........Ralph

ccarrier wrote:

Hi,

I have Photoshop CS5.

I have an action that insert my signature automatically at the bottom of my picture.

It's really simple. 2 steps : Make texte layer, then set layer styles of current layer.
I duplicated it, because I wanted to have a different layer style.

I went in the new action, selecte the layer style step, then clicked on "record again" to change it and then "OK".

Now each time I play that new action, the dialog box of the layer style keeps opening. I don't want that and it doesn't do it in my old action.

The "toggle dialog on/off" is set to off for this step and for the whole action. Still, that dialog box keeps poping up.

Is there something I'm missing ?

Thank you!
--
Claude Carrier

OP ccarrier Senior Member • Posts: 1,155
Re: How to prevent dialog box to appear in action

Hi Ralph,

thank you for your answer. Unfortunately this wasn't it. The playback option was already set to "Accelerated".

Weird thing, it only happens if I record again this step. I did a new action starting from scratch and the dialog box doesn't appear when I play it. Then I recorded again this step and the darn dialog box reappeard again!!!

It drives me crazy!
--
Claude Carrier

 ccarrier's gear list:ccarrier's gear list
Fujifilm FinePix 2600 Zoom Fujifilm FinePix F31fd Fujifilm X100S Nikon D300S Nikon D750 +7 more
joey_B
joey_B Veteran Member • Posts: 3,080
Re: How to prevent dialog box to appear in action

open up the steps of the action by clicking the 'right' arrow next to it. If you are in 'button-mode', use the menu to switch to the normal action view so the arrow is visible.

In front of each individual step, you see a checkbox containing a 'v' to toggle it on or of, and after that another box that can contain a little dialog icon. If you see one, it means that that step will expect user input. If you don't want to give input, click the dialog icon, it will go away, and your action will follow through.

OP ccarrier Senior Member • Posts: 1,155
Re: How to prevent dialog box to appear in action

Hi Joey,
Thank you for your reply.

From your answer I think you are talking about the "toggle dialog on/off" check box. As I mentionned in my original message, this check bock is off for all the steps in the action, as you can see below :

Still, the "set layer styles of current layer" pops a dialog box. Very annoying.
So, unfortunately, this doesn't solve my problem.
(I did learn, however, the button mode view, which I didn't know).

Have a good day!
--
Claude Carrier

 ccarrier's gear list:ccarrier's gear list
Fujifilm FinePix 2600 Zoom Fujifilm FinePix F31fd Fujifilm X100S Nikon D300S Nikon D750 +7 more
JJMacks
JJMacks Forum Pro • Posts: 10,587
Re: How to prevent dialog box to appear in action

download my crafiing actions package. http://www.mouseprints.net/old/dpr/JJMacksCraftingActions.zip
Contains:
Action Actions Palette Tips.txt
Action Creation Guidelines.txt
Action Dealing with Image Size.txt
Action Enhanced via Scripted Photoshop Functions.txt

CraftedActions.atn Sample Action set includes an example Watermarking action that add three watermark layer to any size imahg and these layers are sized for the image's size. No dialogs are seen by the user.

Sample Actions.txt Photoshop CraftedActions set saved as a text file. This file has some additional comments I inserted describing how the actions work.
12 Scripts for actions

-- hide signature --

JJMack

 JJMacks's gear list:JJMacks's gear list
Canon EOS-1D Mark II Canon EOS-1D Mark IV Canon EF 300mm f/2.8L IS USM Canon EF 24-70mm f/2.8L USM Canon EF 70-200mm f/2.8L IS USM +3 more
jdoo Senior Member • Posts: 2,962
Re: How to prevent dialog box to appear in action

That is odd, that the "Set Layer Styles Of Current Layer" step is popping up a dialogue, even without the second column being checked (which I thought was what would trigger a dialogue). Have you tried checking that column and running the action? Then uncheck it, and run it again? Worth a shot...
--
Joe
Old Acct: http://www.dpreview.com/members/5617432530/forums/Messages?Page=19

OP ccarrier Senior Member • Posts: 1,155
Re: How to prevent dialog box to appear in action

Hi Joe,

I did try that and it didn't change anything.

If you have the time could you try something simple for me to see if it is only on my computer ?

  • Create a simple action. Add a text layer, position it where you want, then confirm. Second step, add a layer style (drop shadow for example).

  • Run this action. There sould not be any windows poping up.

(let the text layer in place)

  • Select the "Set laye styles of current layer" and record it again. (Add in outer glow for example).

Then run the action again. That's where I have the popup. Befor modyfing the original action I didn't have the popup. Only on the action where I recorded this step again.

Have a good day!

-- hide signature --

Claude Carrier

 ccarrier's gear list:ccarrier's gear list
Fujifilm FinePix 2600 Zoom Fujifilm FinePix F31fd Fujifilm X100S Nikon D300S Nikon D750 +7 more
JJMacks
JJMacks Forum Pro • Posts: 10,587
Re: How to prevent dialog box to appear in action

ccarrier wrote:

Still, the "set layer styles of current layer" pops a dialog box. Very annoying.

Claude

From the look of the the dialog should not pop up. Please try resetting you Photoshop Preferences. If you exit Photoshop are rename your preferences folder and start Photoshop. Photoshop will create new default preferences for your userid. If that does not fix the problem you can delete the new preferences and rename the old ones back.

If resetting the preferences does not fix the problem please expand the set Layer Style of current layer step and post it here so we can see what layer effects you setting. None should open the layer style dialog.

-- hide signature --

JJMack

 JJMacks's gear list:JJMacks's gear list
Canon EOS-1D Mark II Canon EOS-1D Mark IV Canon EF 300mm f/2.8L IS USM Canon EF 24-70mm f/2.8L USM Canon EF 70-200mm f/2.8L IS USM +3 more
jdoo Senior Member • Posts: 2,962
Re: How to prevent dialog box to appear in action

Interesting! That did it. I now get a dialogue on the second "Set Layer Style of Current Layer" step in the action. This without the dilogue icon pressed. Not sure how to make it go away...

j

ccarrier wrote:

Hi Joe,

I did try that and it didn't change anything.

If you have the time could you try something simple for me to see if it is only on my computer ?

  • Create a simple action. Add a text layer, position it where you want, then confirm. Second step, add a layer style (drop shadow for example).

  • Run this action. There sould not be any windows poping up.

(let the text layer in place)

  • Select the "Set laye styles of current layer" and record it again. (Add in outer glow for example).

Then run the action again. That's where I have the popup. Befor modyfing the original action I didn't have the popup. Only on the action where I recorded this step again.

Have a good day!

bul New Member • Posts: 2
Re: How to prevent dialog box to appear in action

hi.
I have the same problem.

The only solution for me is to create a new "set layer styles of current layer" entry with desired settings and deleting the "popping up" one.

It will popup anytime you edit it so for any changes, you have to create new one

Keyboard shortcuts:
FForum MMy threads