Canon G10 defect must read

Started Apr 27, 2009 | Discussions
Ryank82 Regular Member • Posts: 212
Re: Canon G10 defect must read

Just seen the article this morning. I no longer have my G10 'sold it' but I don't think mine had this issue or at least I never noticed it. Be Interesting to see if anyone in here has a defective G10.

Ryan
--
Camera: Sony Cybershot DSC-H20
http://www.flickr.com/photos/ryankulawiak

Dustcloth Regular Member • Posts: 108
Re: Canon G10 defect must read

I got it...... #81..........

I noticed the line on one picture recently but didn't think too much of it because I don't think it's done it since. From the Canon site - "Occurrence of this phenomenon is due to the camera settings". So I wonder if I'll ever use the same combination of settings to make it do it again.......I'm considering sending it in at the moment unless someone can change my mind.

Thanks!

dotbalm Veteran Member • Posts: 3,222
Re: Canon G10 defect must read

Thanks for posting this.

If I go to the canonusa.com site and check theG10 support and services tab I see nothing regarding this. Am I missing something or is it not there, as usual.

Sandeman684 Regular Member • Posts: 428
There is something on the Canon US-site now

http://www.usa.canon.com/consumer/controller?act=PgComSmModDisplayAct&fcategoryid=222&modelid=17624&keycode=2112&id=57370

as well as on the Dutch site, and I suppose on other country sites. Mine also should be affected, but I have not seen it in any of my images yet.

 Sandeman684's gear list:Sandeman684's gear list
Canon G1 X II Canon EOS Rebel T6s Canon PowerShot SX10 IS Canon PowerShot G10 Canon EF-S 18-55mm f/3.5-5.6 IS STM +2 more
AdamT
AdamT Forum Pro • Posts: 61,124
UK too --------->

Mine falls in the serial number bracket but I've never seen the line, I'm not sure I want Lehmanns ripping the thing apart - are they fixing or replacing them ?

http://www.canon.co.uk/Support/Consumer_Products/products/cameras/Digital_Compact/Powershot_G_series/PowerShot_G10.aspx?faqtcmuri=tcm:14-644511&page=1&type=important

-- hide signature --

Please ignore the Typos, I'm the world's worst Typist

 AdamT's gear list:AdamT's gear list
Panasonic Lumix DMC-G5 Nikon D610 Nikon D850 Panasonic Lumix DC-G9
Greg Gebhardt
Greg Gebhardt Forum Pro • Posts: 25,610
Not camera settings

It says: "This phenomenon is not caused by the camera settings."

-- hide signature --

Greg Gebhardt in
Jacksonville, Florida

 Greg Gebhardt's gear list:Greg Gebhardt's gear list
Canon G1 X III Leica Q2 Leica M9 Nikon D4 Sony a6600
dotbalm Veteran Member • Posts: 3,222
Thank you. (nt)
demarren 123 Veteran Member • Posts: 3,622
Re: Canon G10 defect must read

In belgium,no problem never heard off,as usual.
lol
http://nl.canon.be/Search/index.asp

relate22 wrote:

http://translate.google.com/translate?hl=en&sl=auto&tl=en&u=http://cweb.canon.jp/e-support/products/dcam/psg10rep.html
--
http://www.pbase.com/reelate2
http://www.pbase.com/relate2
What flying means to me.
http://vimeo.com/2598837

-- hide signature --

Nikon D70s,Canon 450D,Oly 420,Sony A100,LX3,FZ18,Canon G7,S3-IS,SX10-IS,SX110-IS,SD880,SD990,
http://demarren.smugmug.com/
Claus M

 demarren 123's gear list:demarren 123's gear list
Olympus E-10 Nikon D70s Nikon 1 V1 Sony Alpha NEX-6
Sandeman684 Regular Member • Posts: 428
Re: Canon G10 defect must read
 Sandeman684's gear list:Sandeman684's gear list
Canon G1 X II Canon EOS Rebel T6s Canon PowerShot SX10 IS Canon PowerShot G10 Canon EF-S 18-55mm f/3.5-5.6 IS STM +2 more
MartyG9 Contributing Member • Posts: 531
Got it by email from Canon
-- hide signature --
lastoneleft Forum Member • Posts: 72
Re: Canon G10 defect must read

This problem has been posted to the Hungarian cust. support site. My g10 is affected based on SN, but to be honest I have not seen these lines so far. However I have seen some concerning spots (looks similar like the attached samples for the lines, but affects just a few pixels) I am going to look back again my pictures to look for it more precisely.

Anyway, I dropped a mail to the support asking if it is a hardware or a software problem - though I am not betting my life on getting a proper answer. If I get any valuable info I will post here.

 lastoneleft's gear list:lastoneleft's gear list
Konica Minolta Maxxum 7D Sony Alpha NEX-5 Sony SLT-A77
martingrumet Regular Member • Posts: 442
Does someone here read Japanese?

The fourth and fifth digits of my serial number are "10", so I think that means it's okay.
I have The Mark on the left. Is that good or bad?

Thank you.

lastoneleft Forum Member • Posts: 72
Re: Does someone here read Japanese?

That relates to the previous firmware update Canon provided for the g10 (the purple RAW problem at ISO1600) - they have marked in the factory those cameras which have been released already with the new firmware. Funny though - very professional way of distinguishing the new release with a simple marking pen, ha?

 lastoneleft's gear list:lastoneleft's gear list
Konica Minolta Maxxum 7D Sony Alpha NEX-5 Sony SLT-A77
martingrumet Regular Member • Posts: 442
Re: Does someone here read Japanese?

Thank you, Lastoneleft.

Groo21 Junior Member • Posts: 28
Re: Canon G10 defect must read

Anyone with a recent G10 find this issue? i.e. Less than 30 days old?

If so, where did you get it?

snap
snap Veteran Member • Posts: 6,211
To: Martin

It says that this marking on the lcd monitor side is not related to this phenomenon.

Rick

 snap's gear list:snap's gear list
Olympus C-8080 Wide Zoom Panasonic Lumix DMC-FX700 Olympus XZ-1 Fujifilm X10 Fujifilm X-S1 +48 more
Dustcloth Regular Member • Posts: 108
Re: Canon G10 defect must read

Mine's about 1 month old. Bought it at Best Buy. And I have the aforementioned issue.

michi098 Contributing Member • Posts: 555
Re: Canon G10 defect must read

I have had mine for quite a while now. I do have the affected serial number - 80. I usually shoot Av at minimum ISO. I have never run across this line. What to do...

lwiley
lwiley Senior Member • Posts: 1,269
I had the line

My camera had the line. I noticed it only once in a while. Finally I tired of seeing it and investigated. It was on all of the images, just not always easy to see. Sometimes it was yellow, sometimes blue and depending on the background it might blend in pretty good. I did not think it could be a widespread problem so I never posted anything here.

Long story but the essence of it is:

  • Returned camera to fix the line problem

  • Canon returned the camera with something else fixed that I didn't know was broken

  • But the line was still there

  • Return camera to Canon again

  • Came back with the line fixed but banged up. A couple of dents and a couple of dings.

  • Sent it back to Canon for the third time

  • Canon agreed to replace the camera

  • Have not yet received the replacement - should be late this week

I've been without the camera for about 7 weeks now. At least Canon is doing the right thing though.

Leroy

Keyboard shortcuts:
FForum MMy threads