5D Won't format Cards

Started Sep 14, 2008 | Discussions
Jonathan Lipkin New Member • Posts: 21
5D Won't format Cards

I just downloaded some images from two 4G CF cards from my 5D. When I put one of the cards in the camera, I got the message 'CF card not formatted'. Odd, I thought, maybe a problem with that card. When I looked at the card in the card reader on my Mac, I could see the images on the card, so the card is OK. I put the other card in. Same error. When I try to format the cards in the camera, I get the message "Cannot format". I then tried a couple of other cards. Same error message. Any ideas on how to fix this? Can the camera be reset somehow?

Rob Cohen Regular Member • Posts: 198
Re: 5D Won't format Cards

You might want to power off the camera, remove the battery, insert the battery, then try again.

I hate to even suggest this, but there might be a bent pin in the CF card slot in the camera.

Best of luck,

OP Jonathan Lipkin New Member • Posts: 21
Re: 5D Won't format Cards

Yes, tried removing battery, even the lithium battery. It doesn't look like any of the pins are bent...

Volker Hett Senior Member • Posts: 1,214
happens to me, too

but not all of the time and mostly it's enough to switch the camera off, reinsert the card, and switch the camera on.

This happens with cards I used in a USB cardreader with my macbook but not with a pcmcia Cardreader in an HP NC6000 with Linux.
So I suppose my cardreader is faulty.
I wanted a better viewfinder and now I need more money

OP Jonathan Lipkin New Member • Posts: 21
Re: happens to me, too

Curious, Volker. Sort of the same thing happened to me -- the camera worked for a few minutes, then I got exactly the same error message. I'm going to call Canon service first thing tomorrow.

PawelWoj Senior Member • Posts: 1,040
Re: happens to me, too

its a self destruct timer. It senses 5d mark II is near , forcing you to upgrade. Genius!!


Keyboard shortcuts:
FForum MMy threads