40D lockup problem?

Started Apr 27, 2008 | Discussions
Hans vdC
Hans vdC Veteran Member • Posts: 3,508
40D lockup problem?

Had to do my first assignment yesterday using my new 40D. To my horror, I experienced a few lockups during the shoot (which were fixed by removing and re-instering the batteries). This is with a 40D and a BG-E2 battery grip.

The camera just locks up, and no button responds. I got the feeling this happened when taking a few pics quickly in succession. Strange thing is, the shutter seemed to respond very slow right before the lockup (shutter speeds being quite high though). It really sounded like a took a picture with a 1/4sec shutter speed and then the camera locked up.

I had this about 3 times when using 1 battery in the grip, afterwards I put two batteries in it and it didn't lock up any more, but I did have the 'slow shutter although using high shutter speeds' problem about 3 times.
--
Canon 20D - Canon 50mm/1.8 - Canon 17-40L - Sigma 18-200 OS
my galleries at http://www.pbase.com/lapino

 Hans vdC's gear list:Hans vdC's gear list
Sony RX100 IV Sony a7 III Fujifilm X-T3 Fujifilm XF 18-55mm F2.8-4 R LM OIS Fujifilm XF 55-200mm F3.5-4.8 R LM OIS +5 more
Keith Reeder Veteran Member • Posts: 3,725
Re: 40D lockup problem?

Which lens?

Hans vdC
OP Hans vdC Veteran Member • Posts: 3,508
Re: 40D lockup problem?

Had it with both the Canon 17-40L and Tamron 28-75 XR Di
--
Canon 20D - Canon 50mm/1.8 - Canon 17-40L - Sigma 18-200 OS
my galleries at http://www.pbase.com/lapino

 Hans vdC's gear list:Hans vdC's gear list
Sony RX100 IV Sony a7 III Fujifilm X-T3 Fujifilm XF 18-55mm F2.8-4 R LM OIS Fujifilm XF 55-200mm F3.5-4.8 R LM OIS +5 more
Keyboard shortcuts:
FForum MMy threads