Windows XP slow to open folders

Started May 2, 2006 | Discussions
Steve_Horn Senior Member • Posts: 1,568
Windows XP slow to open folders

Why is Windows XP so slow to open folders in Windows Explorer sometimes?

I built my wife a machine built on 2.8 Ghz dual core Pentium and Windows XP to replace her old 600 Mhz Pent 2 running Windows 95. She has folders with sub folders that contain lots of small files. Opening these folders for the first time after boot up with the new machine is painfully slow. With her old machine and Windows 95, the folders containing the same files open more or less instantly.

I set the new hard drives to NTFS. Would FAT32 have been better? I have tried turning on and off the 'Indexing service" for the drives but it does not seem to make any difference. Any ideas to speed things up?

-- hide signature --
Torsten Hoff Veteran Member • Posts: 3,593
Re: Windows XP slow to open folders

Check if the Windows Explorer option to cache thumbnails is on or off.

It is also possible that a program that provides a shell extension (antivirus, compression, even some spyware) is slowing down Explorer.

 Torsten Hoff's gear list:Torsten Hoff's gear list
Olympus E-M1 Olympus E-300 Olympus E-510 Olympus E-3 Olympus E-5 +16 more
AmanitaM Veteran Member • Posts: 5,686
Re: Windows XP slow to open folders

I do not know how much time your wife has spent on the new computer, and you definitely should consider the points made by the above poster. However, I just installed XP on a new hard drive and was amazed to find that certain folders, like My Computer and the Control Panel took over 5 seconds to open. However, several days and many reboots later, this problem has completely abated. And I have no idea why. So, time may also factor in here.

-- hide signature --

RickMac Forum Member • Posts: 90
Re: Windows XP slow to open folders

I had a problem like that.. it was the folder marked for video or music, so it was continually looking for files to display. took a while for it to complete. do you see a music note on the folder background or a film clip in the folders background? I have to right click on the folder for that directory that was slow and click properties, and change it to data. that cured mine.

AmanitaM wrote:

I do not know how much time your wife has spent on the new
computer, and you definitely should consider the points made by the
above poster. However, I just installed XP on a new hard drive and
was amazed to find that certain folders, like My Computer and the
Control Panel took over 5 seconds to open. However, several days
and many reboots later, this problem has completely abated. And I
have no idea why. So, time may also factor in here.

-- hide signature --

Shaun Ivory Junior Member • Posts: 42
Re: Windows XP slow to open folders

I have found this helps:

1. Open "My Computer" properties
(here is a shortcut: Win+Break on your keyboard)

2. Select the "Advanced" tab

3. Click the "Settings" button in the "Performance" section

4. Scroll down the list until you find "Use common tasks in folders."

5. Ensure it is not checked (it is on by default)

6. Click OK in the "Performance Options" dialog

7. Click OK in the "System Properties" property sheet

Let me know if this helps you! Not only is it faster, but you reclaim some useful space.

  • Shaun

carl english
carl english Veteran Member • Posts: 9,182
Re: Windows XP slow to open folders

Thanks a lot for that information Shaun, had a dramatic effect on my PC.
Carl

 carl english's gear list:carl english's gear list
Panasonic Lumix DMC-FZ150 Panasonic Lumix DMC-FZ200 Panasonic FZ1000 +1 more
SteveB Veteran Member • Posts: 3,087
Re: Windows XP slow to open folders

5 seconds down to 1.5s for me. Thanks.

Ferenc MOGOR Veteran Member • Posts: 5,625
Two more tips...

Hi,

Here are two more tips:

1. In case you have QuickTime installed on your machine you should check if is installes itself upon start-up. It's a real resouce hog, it slowed down my PC significantly.

Here's how to do:

Go to - Start- Run-type in "msconfig" - go to "Start up" tab - look for "qttask",...if it's there make sure to uncheck it!

2. Here's a goodie: Advanced WindowsCare

You may d/load it from: http://www.iobit.com/WindowsCare.htm

I use it and run it twice a week and it keeps my Windows XP Pro in perfect shape. Licence is free!

Good luck!

-- hide signature --

Cheers, Feri

'I can look at a fine photograph and sometimes I can hear music. Ansel Adams.'

Torsten Hoff Veteran Member • Posts: 3,593
Re: Windows XP slow to open folders

There's some stuff that XP schedules to run a few days after the installation, as well as periodically thereafter. You can force it to run immediately by using Start -> Run and entering

%windir%\system32\Rundll32.exe advapi32.dll,ProcessIdleTasks

More information on idle task processing can be found here:

http://www.microsoft.com/whdc/system/sysperf/benchmark.mspx

 Torsten Hoff's gear list:Torsten Hoff's gear list
Olympus E-M1 Olympus E-300 Olympus E-510 Olympus E-3 Olympus E-5 +16 more
OP Steve_Horn Senior Member • Posts: 1,568
Thanks everyone

I'll try some of these suggestions.

I don't think it a background task that is slowing things down. It consistent, first opening of a folder after bootup - very slow, subsequent opening OK. It is worst on folders that contain sub folders that contain large numbers of small files.

-- hide signature --
tko Forum Pro • Posts: 12,415
also disable Window indexing

Windows XP indexes every file on every hard drive by default, so later searches are supposedly faster. Doesn't seem to work very well, but it better just to turn of indexing. From memory, right click on a drive or folder, go to properties, then uncheck file indexing, and check apply to all subfolders.

This might fit in w/your problem - the first time is accesses the folder it indexes it, if nothing changes it's good for next time and fast.

DavidMS Forum Member • Posts: 75
Re: Windows XP slow to open folders

If it's slow to open "My Computer" it might be a network issue. If you were connected to a network drive, it will try to reconnect to it, and if its not there will keep trying until it times out. Once it's open, look at the drives under "My Computer" and if any of the network drives show up as disconnected right click on the icon and select the "disconnect" option. (Yes, I know that disconnecting a disconnected drive sounds odd - I didn't write it!)

D

JJMacks
JJMacks Forum Pro • Posts: 10,494
If you are running Photoshop 7 there is a problem

The way to fix the problem is to get into windows explorer right click on a Jpeg thumbnail and click on properties. This will open the Properties Window. This window will have tabs across the top. There is one labeled Photoshop. In the Photoshop Tab uncheck let Photoshop generate Thumbnails then click OK.
--
JJMack

 JJMacks's gear list:JJMacks's gear list
Canon EOS-1D Mark II Canon EOS-1D Mark IV Canon EF 24-70mm f/2.8L USM Canon EF 70-200mm f/2.8L IS USM Canon EF 180mm f/3.5L Macro USM +3 more
Keyboard shortcuts:
FForum MMy threads