Light leak? Help...

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Ulrik Christiansen
Ulrik Christiansen Veteran Member • Posts: 3,064
Light leak? Help...

Okay, I have a problem which has been nagging me for a while. Pictures below.

I have two Mamiya C220 cameras and this "anomaly" happens with both of them. My negatives show some kind of light leak or too much exposure at both sides. It does not happen always, but often. Sometimes it is not so severe, sometimes it takes quite an effort to combat in post. I am almost always able to make it okay in post, but of course, I am interested in finding out what is wrong.

Since it is happening with both camera, with the second having had a CLA maybe 2 years ago (by another owner), I think it must happen in the steps after I have removed the film from the camera. I have tried removing the film from the camera inside my darkbag, which didn't help.

I use a standard Patterson tank with a white plastic wheel. I agitate using the stick but at the same time I sort move the tank around in circles

I most often use DD-X in 1+9 dilution.

Any ideas what I am doing wrong?

I do not see any of these light leaks when developing 35mm film in the same tank.

I am going to cross post this on Photrio as well, in the hope of help

 Ulrik Christiansen's gear list:Ulrik Christiansen's gear list
Fujifilm X-T20 Fujifilm X-T3 Fujifilm XF 35mm F1.4 R Fujifilm XF 27mm F2.8 Fujifilm XF 56mm F1.2 R +3 more
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow