RF 50mm 1.8 no AF

Started 5 months ago | Discussions thread
Basil Fawlty
Basil Fawlty Regular Member • Posts: 287
Re: RF 50mm 1.8 no AF

JKdad wrote:

Just bought my R8 with a few RF lenses including the one listed above.

It worked great yesterday, but today the 50mm will not AF. The camera doesn’t even give me an option other than MF. I tried the switch on the lens.

The 85mm and 28mm still AF as usual.
I’d appreciate some help.

Make sure you have the focus / control switch set to "focus"....then, you must make sure that the focus is set to AF. With this lens, that is set in the camel's menu system. This video shows how to switch from MF to AF from the camera menu.

https://youtu.be/DXcAZffkHa4?si=L5Ls42mGr0bkELN8

If you're sure you are in AF mode and it still isn't working, it's time to look into returning th lens.

 Basil Fawlty's gear list:Basil Fawlty's gear list
Canon EOS R5 Canon EF 50mm F1.4 USM Canon EF 135mm F2L USM Canon RF 24-105mm F4L IS USM Canon RF 85mm F2 Macro IS STM +8 more
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow