Olympus TG-5 - battery wont charge

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Shandit66 New Member • Posts: 2
Olympus TG-5 - battery wont charge

I took my TG-5 out of storage, after a few years, for a trip down south.

Charged the batter overnight - turned it on - got an icon for "no power"

Changed batteries - same result.

(gave up for that trip)

Got home, tried again. So here are the specifics

  1. - took the battery out, checked the terminals, all clean
  2. - ensured its put in right, so the terminal connect.

Plugged it in and tried again.

I used the HDMI Micro connector listed here as #25

https://cs.olympus-imaging.jp/en/support/imsg/digicamera/download/manual/tg/man_tg5_e.pdf

BTW its VERY irretating that Olympus used a proprietary cable rather than anything standard

  1. Screen came on, red light on top came on - ok its getting power from the charger
  2. on the back LED panel, it shows the battery as charging.
  3. left it overnight

Same result

Any suggestions?

thanks

Olympus TG-5
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow