Custom Mode on 90D Not Retaining Aperture Setting After Camera Waking Up

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
Danno B
Danno B Regular Member • Posts: 455
Custom Mode on 90D Not Retaining Aperture Setting After Camera Waking Up

This is very frustrating for me at times.

I first put the camera in Aperture priority and set f/8.  I then set a minimum shutter speed and Auto ISO.  I then saved these settings to the C1 custom mode.

Everything works fine as I turn the camera off and back on and set C1 mode if not there already.  But.........sometimes while in C1 mode I need to change the aperture to whatever and the camera works fine until it goes to sleep (the lcd screen goes black) with the altered aperture setting.

When I wake up the camera, without having turned the camera off, the aperture setting is reset to the original f/8.  Now, I can understand that is the way it should work had I turned the camera off and then back on but if the camera only went to sleep I would prefer my altered aperture setting to be retained when I woke up the camera.

The workaround I am using is that if I am likely to have to alter the aperture while pointing and shooting, I may as well just use Aperture Priority mode with min shutter speed and Auto ISO and not the C1 settings.

Do other cameras behave the same way when set to custom modes or am I missing something in the way I am saving/registering settings to C1 or C2 modes?

ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow