D750 not working with Godox Flash TTL mode

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Ocular Grep New Member • Posts: 8
D750 not working with Godox Flash TTL mode

I'm trying to control off-camera flash with my Nikon D750. I have Godox flash triggers for Nikon, both the Flashpoint (Godox) R2 i-TTL 2.4G Wireless Transmitter and the Godox XProN TTL Wireless Flash Trigger. I'm controlling a Flashpoint eVOLVE 200 (Godox AD200) strobe.

Things work as expected in Manual mode: I can set the power from the transmitter mounted on the camera hot shoe. However, when I set the transmitter to TTL mode, although the strobe also shows TTL setting, the pictures come out seriously underexposed. It appears that TTL isn't working.

  • Is there something I need to be setting in the D750? I'm just in manual exposure mode, 1/125 at f/8. The flash fires, but not enough power for correct exposure.
  • Is there anything else I should be setting in the transmitter and strobe? They're set to the same channel and group, and it appears that the transmitter is controlling the strobe.
  • Are there known problems with the D750 and this flash equipment?

Thanks for sharing experiences or suggestions.

 Ocular Grep's gear list:Ocular Grep's gear list
Canon ELPH 100 HS Nikon D7000 Nikon D750 Fujifilm X-T20 Nikon AF-S Nikkor 70-200mm f/2.8G ED VR +8 more
Nikon D750
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow