problems with my D90 and the 100-400mm tamron

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
lomoapontaechuta Regular Member • Posts: 322
problems with my D90 and the 100-400mm tamron

So.

I bought the tamron 100-400 mm Lense yesterday (second hand) for my D90, and today i noticed while testing it  i can't autofocus at 400mm, the camera simply doesn't focus at that range most of the times, some of the times it reaches focus and others it almost reaches but overall, it has a very erratic behaviour when it can achieve focus.

At 100mm, no problem, the camera+ lense works fine and snappy, at 200 mm same thing, +- at 300 mm the problems starts, the focus became slower and more erratic, until it reaches 400mm and literally nothing happens most of the times.

Yesterday i didn't brought my D90 with me when i went to the store, so they lend me a D70 to test the lenses (they were three lenses ) And all seemed fine, either at 400mm and at 100mm, the focus was snappy at long range (outside the store) and while abusing the minimum focus distance. (inside the store)

I put the 18-140mm back again in my D90 and all works fine.

Now I'm wondering what's happening.

 lomoapontaechuta's gear list:lomoapontaechuta's gear list
Sony Cyber-shot DSC-HX50V
Nikon D70 Nikon D90
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow