Initial experiences with Viltrox AF adapter

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
Satyaa Veteran Member • Posts: 4,938
Initial experiences with Viltrox AF adapter
1

Got my Viltrox F-M1 adapter that has no optical elements and has AF. First thing I did was to download the firmware update and install it. Then I connected it to GH5M2 and did some tests.

All the images below are SOOC, compressed using JPEG Mini Pro for file size reduction.

First the DX35/1.8

Camera beeps that the focus was acquired but both shots at f/4.5 were out of focus. The green squares were jumping around the face, but the cat's back is in focus.

At f/1.8, a couple of shots were in focus. The cat did not want to look at the camera though.

Shallow depth of field at f/1.8

Other shots showed that the face was in focus, but it was actually the back.

Then the 85/1.8
Camera completely fails to focus. The camera beeps but keeps hunting. I switched the lens switch to MF and it works great. MF is easy to use, but not for moving subjects.

The background on the outside in this next shot is completely flat and subdued. I don't know if there is a name for it, and others prefer it or not, but I like it. Looks very promising for portraits.

Then I tried the 70-200/2.8 zoom. Not one that I would use because it's a monster and doesn't balance well on a small body. The AF does not work! I had to turn the lens switch to MF but with no luck! The camera thinks that the lens is AF and keeps hunting.

At this point I discovered the AF-MF switch on the adapter. That did the trick. The camera got the message. I was able to use MF successfully. Not worth using this lens on GH5M2 unless I am desperate for the 200mm f/2.8 in a life-saving situation.

The other problem in this case is that the MF ring is closer to the camera and smaller. It is almost impossible to balance the lens when trying to turn the MF ring. This is a reject.

Then the Sigma 18-35/1.8 Art lens!

At first this did not AF at all. I checked the AF-MF switches on both the lens and adapter. Moved them back and forth. Nothing worked.

Manual focus works just fine. The problem is with the electronics. The image EXIF shows the focal length at 24mm always. And the aperture as f/0. Everything else is great.

I turned the camera off and on a few times. Suddenly the AF started working!

This time, the focus is where the camera says it is.

Preliminary conclusions

Lot of work is needed before I can rely on the 35/1.8 and 85/1.8 for regular portrait use. I am going to write to Viltrox support (wish me luck) and search for a solution to the AF issues.

Heavier lenses and f/2.8 zooms are not worth trying. The f/2.8 at the 12mm end and 50mm end of my PL zooms is sufficient.

The Sigma 18-35/1.8 Art is a gem. I plan to use this for video on a tripod. This is my cheaper alternative to PL f/1.7 video zoom. I need to find good long tripod plate for support because the whole setup is front heavy.

What next?

I got a second Viltrox adapter that has optical elements but no AF. It reduces the focal length and increases aperture by a stop. I did not get a chance to test this yet.

Next round of tests will be the AF-D lenses on that adapter, with MF. Two of them are f/2.8 and should work like f/2. The other is 50/1.4. I wonder how that looks when down to f/1.

Thanks

-- hide signature --

See my profile (About me) for gear and my posting policy.

ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow