Help! Anyone else having problems with Luminar AI 1.5.3?

Started 1 month ago | Questions thread
ForumParentFirstPrevious
Flat view
Barbie Heid
Barbie Heid Regular Member • Posts: 218
Help! Anyone else having problems with Luminar AI 1.5.3?

Hello all, first post on this forum (normally Nature/Wildlife.) Can anyone help?

I bought Luminar AI 1.5.3 and thought it was the greatest thing since sliced white bread. Loved it! But it kept crashing after four edits and now simply will not open.

I uninstalled/reinstalled, as per the company's instructions (twice), but now when I try to open it, it says it cannot start without a Windows update, giving a link to update it. The link is a legitimate Microsoft site, but it says my system is already fully updated. I have reached out to the company forum, haven't heard back from them yet (they are located in the Ukraine, understandable).

Until I figure this out, can anyone recommend a *comparable* program? Specifically, I don't want to lose the clone tool. I also love the sky tool, so I would really like something that offers those features. Thanks so much!

 Barbie Heid's gear list:Barbie Heid's gear list
Nikon AF-S DX Nikkor 18-55mm f/3.5-5.6G II Tamron 28-200mm F2.8-5.6 Sigma 150-600mm F5-6.3 DG DN OS +3 more
ANSWER:
This question has not been answered yet.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow