EOS R7 Err70

Started 2 months ago | Discussions thread
ForumParentFirstPrevious
Flat view
geniussamster New Member • Posts: 8
EOS R7 Err70
1

Anybody else getting an err70 on their R7 with adapted EF lenses?

I originally thought it had something to do with Eye-AF, but I've tested it and it is happening in any focus mode. It seems to only happen at 30fps electronic shutter, while pulsing the shutter button, getting to the edge or going over the buffer limit.

It's almost like instead of hitting the buffer and telling me to wait for it to clear, it just locks up and displays err70.

It takes a while the first time, but after I've switched off / pulled the battery and try to take shots again, it locks up again, but much much quicker.

I changed the sequence in which I connected the adapter and EF lenses and thought that solved my problem, but I think it was actually because I've been shooting EFCS and 15fps electronic for the last week, so I haven't run into the same issue.

I'm now wondering if it's a firmware or if it's a hardware problem. I've seen that the 70D had issues with err70 and it was the mainboard.

Is anyone else is having a similar issue, or am I the only one who got a dud?

I'm most likely going to send it back, but I am reluctant to, without knowing what stock levels are like and how long I'm going to be without it after waiting more than 2 months for it to arrive in the first place.

Many thanks,

Canon EOS 70D Canon EOS R7
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow