My R7 Shutter Shock unscientific experience

Started 1 month ago | Discussions thread
ForumParentFirstPrevious
Flat view
TeeJay626 Contributing Member • Posts: 536
My R7 Shutter Shock unscientific experience
2

I've noticed shutter shock on my R7 when shooting both Mechanical and EFCS, but only in certain situations.  It seems that when my shutter speed is at half or less of the focal length, that's when it happens.

For example, with my RF 100-400, at 400mm (or 640 ff), it only happens below 1/320.  With my EF 70-300 nano USM II, at 70mm (or 112 ff), it only happens below 1/60.  Also, it isn't consistent.  Sometimes it happens, sometimes it doesn't.

Today for example, I was taking some pics in my local park of a bird and was shooting EFCS.  I was at 400mm with a shutter speed of 1/320.  I was in H+ mode and taking 5-6 shot bursts.  The first image was tack sharp, but the rest were not.

At any shutter speed at or above the focal length, zero issues.

*I also have the R10 and so far have seen no examples of shutter shock.

 TeeJay626's gear list:TeeJay626's gear list
Sony Cyber-shot DSC-H55 Canon EOS R7 Canon EOS R10 Sigma 17-70mm F2.8-4 DC Macro OS HSM | C Canon 70-300 F4-5.6 IS II +5 more
Canon EOS R10 Canon EOS R7
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
Post (hide subjects) Posted by
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow