Repairing the rubber pad in an XQ2

Started 2 months ago | Questions thread
ForumParentFirstPrevious
Flat view
paulhoppe_photography
paulhoppe_photography Regular Member • Posts: 235
Repairing the rubber pad in an XQ2

Hello,

I gave my daughter my XQ2 so she can take a few pictures with me. She is still in kindergarden but she wants to do what her Dad does...it was 100€ Ebay find so I am alright if the camera gets damaged. It already has enough scuff marks anyway but it works fine. Besides at her age everything she can play with becomes automatically "hers" anyway

Problem is on my XQ2 the little rubber pad / thumb grip came off. Under it was a pretty thick layer of some kind of sticky glue. I cleaned it off with IPA and tried some superglue but it fell off a few days later...now with crusty superglue residue.

Has anyone had this problem before (maybe with another camera). How can I safely reattached the rubber pad. If not I'll put some black tape over it so my daughter won't injure herself in the sharp post and sticking up (for holding the pad). But that would obscure the status LED.

Thanks anyway...maybe some of you have an idea...

-- hide signature --
 paulhoppe_photography's gear list:paulhoppe_photography's gear list
Fujifilm X-E4 Fujifilm XF 16mm F2.8 Fujifilm XF 27mm F2.8 R WR Fujifilm XQ2 Ricoh GR III +1 more
ANSWER:
Fujifilm XQ2
If you believe there are incorrect tags, please send us this post using our feedback form.
ForumParentFirstPrevious
Flat view
ForumParentFirstPrevious
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow