Mamiya 645 1000s 8s exp with Prism CQS PrismFinder

Started 1 month ago | Questions thread
ForumParentFirstPreviousNext
Flat view
black_caniche New Member • Posts: 9
Mamiya 645 1000s 8s exp with Prism CQS PrismFinder

Hi, got a new-to-me 645 1000s and started experimenting with it.  I went to shoot the moon last night and discovered an interesting behaviour that I did not see documented anywhere.

It goes as so:

With the CQS Prism Finder equipped with the Aperture Priorty Meter (one with the needle and no speed dial on the prism), if I set the ExpSpeed to 4s or 8s while the meter is on, the shutter stays open (did not wait 5 min to check) much longer than 4 or 8 seconds respectively.  I therefore need to change the speed nob position or depress the batt-check button to close the shutter.  ALL other speed work normally in these conditions.  If I turn the meter off, then 4s and 8s speeds work fine.  This is systematic for only the 4 and 8 second speed settings.

I was curious to know if there is a detail or feature that I am not aware of behind this.  After all, these cameras are quite strange sometimes in their design.  From what I know, the camera is operating top notch (mint condition).

Thanks.

ANSWER:
This question has not been answered yet.
ForumParentFirstPreviousNext
Flat view
Post (hide subjects) Posted by
ForumParentFirstPreviousNext
Keyboard shortcuts:
FForum PPrevious NNext WNext unread UUpvote SSubscribe RReply QQuote BBookmark MMy threads
Color scheme? Blue / Yellow